Jump to content
Light-O-Rama Forums

upgrading firmware on G3-MP3 Standalone director


Recommended Posts

It all started so simple, get a pixel tree when it was on sale.   Of course, i had the prerequisite hardware although my G3-MP3 was old but matched exactly what was on the doc.    As expected, I do need to update the firmware but that is where I am stuck.  I have the USB dongle, and i can connect and control all of the controller and the pixie8 using it.   However, in order to upgrade the firmware, it says to connect to the director.   If i just use the network cable from the dongle, it does not power up.  But i can get it power up by connecting it one of the controllers.  But I do not see it in the hardware utility.  if i do refresh, it doesn't show up.  I go to the firmware tab, select MP3 device, and try to update it and it doesn't find it which i more or less expected since it doesn't show up from refresh either.   

I suspect i am missing something?

Edited by TexasLights
Link to comment
Share on other sites

Since I am new to the forum, would this be a question I should pose as a support ticket or do they reply here?

Link to comment
Share on other sites

Taken from http://www1.lightorama.com/Documents/G3-MP3_Man_Web.pdf


Firmware Update: G3-MP3

This section describes how to update the G3-MP3

firmware for both the stand-alone unit and the unit

built into the LOR1602MP3g3.

You must have:

Hardware Utility version 2.3.4 or later, see the

section Hardware Utility Version

No SD card in the G3-MP3

G3-MP3 should be displaying the time

The G3-MP3 powered (see the Power Input

section) and connected to the PC via Net 1.

Use a USB or serial adapter to connect the

G3-MP3 to the PC. Do not use wireless.

Get the latest firmware. www.lightorama.com

Support Firmware. Note the name of the firmware

file, G3-MP3-Vn_mm (n_mm is the version number)

and save it on your PC in My Documents\Light-ORama\


Start the LightORama Control Panel if it is not

running by clicking start All Programs

LightORama Light-O-Rama Control Panel. The

Light-O-Rama light bulb icon will appear in the

system tray on the lower right of your screen.

Start the Hardware Utility by right-clicking the Light-

O-Rama Control Panel light bulb and selecting

Hardware Utility from the menu.

Click the Firmware button in the LOR Control tab

and you will see this window:

In Step 3 – Press Download Button, click the

Download button. The firmware download will start


The Update progress bar will fill from left to right.

When the new firmware is loaded, the Status will

change to “Successful” and the G3-MP3 will reboot.

Link to comment
Share on other sites

You don't select the G3-MP3 as you would a controller

- Open the HU

- At the bottom of the HU window select firmware

- Go to Step 1 and select  MP3 Player radio button

- Go to Step 2 and select the update file, location where you saved it on your computer

- Go to Step 3 and press Download.

Link to comment
Share on other sites

thanks, that is what i thought from the instructions but it wasn't working.  One of the diagrams in the doc implied it might discover it.    I shut everything down and tried again and this time it was successful.    It also read the sequence I made with S5 and seems to be playing although it was a simple test sequence that just turned switches on and off.  It isn't doing that at the moment.   Hopefully, just another bump in the learning curve...

Edited by TexasLights
Link to comment
Share on other sites

While we do monitor stuff here, we try to let the community jump in and help as much as possible.

To be assured you get a response, go ahead and open a help desk ticket.  We are here to help!

FYI:  MP3 directors (and some of our controllers) can miss the 'Hey you!  Start Downloading Firmware!' command that the hardware utility sends.  If after several seconds of pressing the download button you don't see any activity (the sending/receiving/flushing stuff), power off the controller and then power it back on.  One of the very first things the bootloader does while coming alive is listen to the data stream to see if there is some kind of firmware update being broadcast.  That will usually get it moving.

Link to comment
Share on other sites

The forum worked just as planned... the support from the forum made me comfortable I was doing the right thing and your explanation also explains why restarting everything got it working.   

I managed to get everything else working as expected so far, being new to S5, still learning the tricks there

i suspectI am one of few in a 100 mile radius that had a Christmas tree up in their office on Easter (I made a stand so i could test it indoors).  

Link to comment
Share on other sites

  • The topic was locked
This topic is now closed to further replies.
  • Create New...