Jump to content
Light-O-Rama Forums

CTB16PCg3 Weird Occurance


Recommended Posts

I run a bunch of CTB16PCg3 firmware 1.08. 

I purchased a few more more controllers and they came with firmware 1.09.

This step up I upgraded all of my Hooli network boxes to firmware 1.09.

Last night I was out enjoying my show before the rain and noticed that sections were not working. This morning I did a network search for my LOR boxes and found three listed as example 03 - Bootxxxxxxx. <- Not the exact phrase.

It is not listing some as example 03 - 16PC-G3 Ver 1.09. All of the boxes with the boot listing were not working. I was able to connect directly to them and re-flash the firmware back to 1.09. 

They are all functioning properly again. 


Are there any ideas why some of my boxes would have lost their minds?

Has anyone else seen this behavior with old, two and three year old boxes doing this? One of the boxes was new, removed from the package this year but purchase a couple of years ago.

I am going to monitor this closer for the next few nights.





Link to comment
Share on other sites

Yes, I have experienced that with V2 controllers.  What happens sometimes is the firmware did not load fully for some reason, even though it may look like it had.   had to do the same thing you did, reload the firmware update and all was good.   I had this happen on a firmware update and one time I had it happen because I accidentally tried to load a sequence into a controller, not realizing it could not do a stand alone sequence, and this messed up the boot-loader, and had to reinstall the latest firmware update again for that controller to get it work again.    Only other issue that ever caused this issue with a couple of controllers was an unexpected power outage, they lost their firmware, and so again, reload the latest firmware update, check to be sure it's there, and controller back to normal.

Other than these 3 occurrences, never had it happen at any other time.

Best thing is to always double check after a firmware update of any kind and make sure it took, if you get any kind of error, especially boot-loader errors, chances are the firmware didn't take or has somehow gotten corrupted or the download of the firmware didn't take fully and you have a corrupted firmware file.   That can happen, fortunately I never had that issue witha a firmware download being corrupted.  But it does happen sometimes to folks.

EDIT: Just seen Phil's reply and he is correct.  You do need the latest devicefile.txt so it knows what hardware you have and to update it appropriately.   Thanks Phil, forgot about that one could be an issue with earlier versions of the hardware firmware updates.

Edited by Orville
Link to comment
Share on other sites

I am actually on 3.12.4.

I don't have any RGB, just 23 CTB16PCg3 and a few thousand lights... (On ninety Christmas trees)

I will check the devicefile.txt now. 

Last night everything worked perfectly. Everyone on the side of the road were happy. Not that they could tell when three controllers weren't working. But I could.

Thanks for the suggestions.



Follow Up: Yes - My LOR_DeviceFile.txt was different from the downloaded one.   - Again Thanks for that.

Edited by MikeERWNC
Link to comment
Share on other sites

  • Don locked this topic
This topic is now closed to further replies.

  • Create New...