Jump to content

CMB24D 1 Channel not turning off.


Frank Rhobotham
 Share

Recommended Posts

13 minutes ago, Frank Rhobotham said:

Hello all,

 I have a cmb24d driving my mini trees. I accidentally hooked up a cable that had a short in it on channel #6. Now that channel stays lit. It works but is always on dimly. Did I destroy that channel?

thanks,

Blaine

If it shorted then you probably blew the mosfet. Easy to replace with basic soldering skills. Contact the Help Desk as they will usually send you one.

Edited by Mr. P
Link to comment
Share on other sites

3 minutes ago, Frank Rhobotham said:

Thank you Mr. P.  I just sent them a request from the help desk. Hopefully I can fix it!

You're in Gainesville and I am down by Lawrenceville, if you can't fix it give me a yell and I will fix it.

Link to comment
Share on other sites

13 minutes ago, Frank Rhobotham said:

Awesome, thanks for the offer. If I’m in over my head I will reach out. Do you know which mosfet is used on that board? Maybe amazon can get it to me?

thanks again.

Here is the mosfet, not sure if Amazon sells them.

https://www.mouser.com/ProductDetail/NXP-Semiconductors/PSMN022-30PL127/?qs=sGAEpiMZZMshyDBzk1%2FWiy8mkjihaa%2bLT7ikOfKaAiM%3D

Link to comment
Share on other sites

1 hour ago, Frank Rhobotham said:

Mr. P,

installed new MOSFETs and it appears to working now. Thank you!

You are very welcome, keep in mind that with stranded wire all it takes is for one little strand to go astray and it will short something out.

Link to comment
Share on other sites

Frank, glad you got it fixed.

In reference to Mr P’s comment about one stray strand of wire, check out this thread:

I am now using ferrules on all new construction and am slowly retrofitting older stuff.

 

  • Like 1
Link to comment
Share on other sites

  • Don locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...