Jump to content
Light-O-Rama Forums

Software Not Responding, com port issue, and static electricity


Recommended Posts

I wanted to pass this along, sorry it's so long winded but I figure the more info I include the easier it might be for the next guy to find it. I doubt I am the first person to come across this, but I didn't find anything in my search. Please keep in mind I only bought my first controller 2 months ago and am a newbie to how all this works, and it is very overwhelming reading all about RBG lights, pixel trees, and people with 3200 channels. I have 32 channels now (2 CTB16PC-G3), looking to expand to 5 controllers and 4 singing faces for my first "real" show, Christmas 2018. 

I bought my house in March 2017 (this information comes into play later), and as I mentioned, this is also my first year with the LOR system. I set up one control unit on a table in my 3 season porch at the front of my house, and the other behind my bushes for the outside lights in the front yard this year (power cords running in through the mail slot, don't judge me). I didn't have time to learn the software and sequence a 32 channel show with  music, so I just had my house lights and some interior window decorations flickering on and off with an animated sequence I made on a schedule I created. Everything worked fine, except that almost every day my controllers would lose their connection to my laptop, the CP and/or HU programs would display a "Not Responding" error in the Windows title bar (Windows 7 Home Premium); the program would "lock up" (not the computer, just the LOR window that was open); and the controller light was blinking. Sometimes I couldn't even close it with the Windows Task Manager. I would reboot the PC and restart the LOR Control Panel and I was back in business (solid light on the controller); CP would start according to my schedule.

But again, occasionally the show would just stop running. It seemed to be very random, sometimes it would run for hours without any issues, sometimes it wouldn't last more than a minute; there was nothing else running on the PC, I had plenty of RAM (4GB), and the PC was more than capable of running the LOR software (Dell PC with 2.2 Ghz dual core processor and 277 GB free on a 500 GB hard drive). I opened a help desk ticket (I thought it was a software issue) and they suggested I uninstall / reinstall the LOR software and sent me a link to the registry cleaner utility. I reinstalled the software, started the Hardware Utility and let it run for over an hour with no trouble. I sat in my recliner next to the table I set my laptop on and thought I had it licked. I got up to get a beverage and when I came back I grabbed my computer my controller lost comm again. Rebooted the PC and it all came back on normally. Sat back to watch TV, went to check it again minutes later and it was disconnected again.

I worked on this for 2 days (off and on) over the weekend, changing cat5 cables, resetting different comm ports in the LOR Network Utility, figuring out that comm4 worked... until it didn't any more and I rebooted. I would take a break for a while, then come back to it later and try something new.

Now, I work with computers for a living, mostly Linux software, but I have a couple college degrees and I and know my way around a PC. I uninstalled / reinstalled the drivers for comm4 and the USB485 adapter, but the only thing that came of it was that I figured out all I had to do was unplug the adapter and plug it back in (a reboot wasn't necessary each time). As soon as I unlpugged the adapter I realized the "not responding" error went away and I could close the program normally (time saver).

After one such restart I walked past the controller wearing socks on my carpeted floor and got a shock when my hand brushed one of the dongles. Out of the corner of my eye I saw the light on the controller start flashing. I opened the HU and immediately got an error that comm4 could not be found. It has been below 20 degrees for more than a month here in E Central WI, and that means it is very dry inside the house. I have been complaining (to myself) for weeks about getting a shock every time I pick up my computer. Light bulb moment. I checked the outlet and sure enough, not grounded.  STATIC ELECTRICITY!!

Before I bought the house (built in the 50's) I tested several outlets to make sure the wiring was good. I guess I didn't check the outlet next to where I was going to set my recliner (the one I have the PC plugged into). Later, I found 2 outlets not grounded and another that has the hot and neutral reversed. I can fix that. I now have the PC plugged into a (verified) grounded outlet and I haven't had any other issues all day.

The end result is, and I had never seen this before, but a small electric shock was enough to disrupt communication from the PC to the controller and knock out the comm port temporarily. It was going out randomly because sometimes I would sit in my chair for more than an hour, sometimes for less than a minute. But each time I came back to the recliner I would burn off the static charge I created as soon as I picked the laptop off the table. I'm lucky I didn't fry my controllers. Make sure your outlets are properly grounded!!

Again, forgive me for this being so long, but maybe it will help someone else.

  • Like 1
Link to comment
Share on other sites

You have UNGROUNDED U-ground outlets?  Those are a code violation unless 2 things are present. 1) They must be GFCI protected (and all downstream outlets Labeled). 2) The label needs additional word UNGROUNDED.. If this is not done, the outlets MUST be 2 prong only. Replacement outlets are available at major home stores.

Back then, even if you had U ground outlets, they did not require a positive (wire) ground, but allowed the yoke mounting screw to be the connection to a GROUNDED metal box..

I highly recommend that all old 3 prong outlets be inspected for the presence of a Green or bare wire on the Green screw of the outlet, and not rely solely on the test plug Ground lamp.


Link to comment
Share on other sites

  • The topic was locked
This topic is now closed to further replies.
  • Create New...