Jump to content
Light-O-Rama Forums

Half of controller not working HELP


Recommended Posts

I have a 160xW, which I know is an older model, but it has been working great for years. I have 112 channels (7 controllers), been doing this since 2010.

My controller was tripping my GFI, at first I thought it was moister.  I tried systematically unplugging each channel with power off, could not find one to trip gfi.  Then I plugged in half the controller (9-16) and half of the lights worked no trip, Then when I plugged just the other half channels 1-8 by itself no red light and no action.  Then I tried again to plug in both black cords into the GFI and it tripped.   I checked the fuse and even traded it with the good side, still no power for channels 1-8. 

HELP any ideas.  Did my controller bite the dust or is there another fuse or something else I can try. We hosting our block Christmas party tomorrow night too.

Link to comment
Share on other sites

You're saying that there is no red light on the controller when you have channels 1-8 plugged in. Could it be that you've unplugged the power cord for channels 9-16 (of the 2 power cords that feed the controller)? If so, then that's your problem. The electronics in the controller are powered by the cord that powers channels 9-16. There will be no signs of power if you only have the one cord that feeds channels 1-8 plugged in.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...