Jump to content
Light-O-Rama Forums

Com Port Numbers Keep Changing....


Recommended Posts

Perhaps because I'm typically a Mac user and not too familiar with Windows I am missing something... BUT ... it seems that if I restart my computer my Com ports are magically changing numbers. So, that means each time I restart, my show doesn't play and I have to run the hardware utility to see which Unit IDs on on which Com port and then change them in the Network Preferences. By the way, I am running the Regular Network and Aux A, B, C & D...all with Fast (500K) connectors at 500K.


Is that normal?

Am I in need of a change in some setting?

Am I just being stupid??? LOL


I also noted a post from a while ago that commented on turning off the PCs ability to suspend the USB ports when not in use. Have yet to test if that is the issue...but I do know about that now and have changed the setting to "Disabled".


Any help that can be offered is greatly appreciated.

I know how to fix it now...but it is still a pain if I need/want to restart.



Edited by jamills706
Link to comment
Share on other sites



This is a rather unique issue.  All of my 'WinBlows' machines register a new device at COM XX.  Enumeration based on the device.  Windows remembers the device and its previous com port address.  I have seen this behavior on Win 2000, XP, Win 7 & Win 8.  I use many different USB devices and each gets its own unique com port number assigned (for the devices that have a serial port).  Windows remembers it b/c it has a device identifier and serial number.


What I CAN do is assign it a com port number in the advanced settings dialog.  Occasionly it will complain about another device having that port # (and I know it isn't being used) assigning it to a port number usually works.


Try to force it to REMEMBER that com port number.   Control Panel --> Device Manager --> Ports --> your dongle usb port --> double click --> Port Settings --> Advanced --> there you will see the port number assigned - you can change it to match the S4 port and it should remain like that. 


If this doesn't work - then there is something "broken" in Windows.  You didn't specify what version of Windows you were using.


Only other possible avenue would be while powering up the machine, keep the dongle disconnected until the machine is ready - shouldn't make a difference but it is a try.


Good luck.

Link to comment
Share on other sites

  • The topic was locked
This topic is now closed to further replies.
  • Create New...