Jump to content

Sandevices E682 and Internet issues


Caleb Linburg
 Share

Recommended Posts

I have my sandevices outside connect to my pixel tree. The wire then runs into my basement into a switch next o my show computer. This switch has internet and now E1.31 in it. The Sandevices wasn't being recognized by the switch so I put a router with the wifi turned off in between the E682 and the switch. I am using multicast because when I set everything up as unicast I can't get it to work unless I take my laptop and plug it directly into the E682. It seems to take awhile for the computer to find the Sandevices after everything is setup. As soon as it finds the sandevices, my internet drops. I can't figure out how to get both to work right. Has anyone had this problem before? I need the internet because my show is played with the MIIP. Attached is the network map of my show pc and my savdevices setup page. It says unicast, but I switched it back to multi (old screenshot). 

post-7323-0-33310400-1416308582_thumb.pn

post-7323-0-44938200-1416308583_thumb.pn

Link to comment
Share on other sites

Is there a reason this computer requires access to the internet?  One of the best practices for E1.31 is to place it on its own network region.   You will probably have to set a static IP address on your show computer (in the same IP range as the E68X).

Link to comment
Share on other sites

Are you running your Internet connection and your E1.31 from the same physical NIC?

You E1.31 device is on a 192.168.1 network

Where (IPwise) is your Interent connection.

 

I dont run MIIP, but I need an Internet connection to update our Show Status on our webpage ...

I run the E1.31 off the NIC

I run the Internet connection from Wireless

There is a route you can drop in that will ensure the two remain isolated from each other.

 

Might simply your setup ... I dont see the need to add the router (unless it was being added to route two dissimilar networks as mentioned..) ..

 

Bob

Edited by bob_moody
Link to comment
Share on other sites

On multicast all the data is broadcast to all devices and they are left to sort it out. It's just to much information on the network and it bottlenecks.

If you can't do the separate network for your San device you will need unicast.

Last, can you get each computer doing internet via wifi and leave the wired network to the show. Even if it's just for the season.

Edited by sticks4legs
Link to comment
Share on other sites

The question was are you running your internet connection and your E1.31 network to the same physical NIC on your computer?

 

Your E1.31 network is running at IP address 192.168.1.206

What is the IP of your computer?

do a couple of things to help things along...

 

Run an IPCONFIG /ALL  > IPC.TXT

That will run the ipconfig command and port to a text file that you can paste here...

 

Also run C:\ROUTE PRINT > RTE.TX

That will print out the routing table that you can paste here as well ..

 

those would help us to see your config better.

And maybe help you sort things out..

 

Does your PC/Laptop have a wireless connection?

Are you running Wireless Internet at your home?

 

Bob

Link to comment
Share on other sites

Off the wall question .. the switch that didnt recognize the SanDevice.. was it already powered up and running when you brought the E1.31 device online?

 

I ask becasue E1.31, unlike ethernet, is not bi-directional.

In other words, if you had established a connection with E1.31 then moved the cable to another switch port, unlike a computer it wont see it right away ... You have to wait for the devices to give up, timeout and poll again. In a switch once you connect the MAC address is stored and all traffic for that address is routed only to that port.

 

I found on my Cisco that if I moved E1.31 connections while the switch was running.. I had to cycle the power on the switch and make it start new.

 

Also .. you might want to run the command ARP /D to refresh the ARP table on your pc.

 

It seems that all of your connections are on the same network which is why I dont understand the need for the router. Its routing nothing .. basically a pass through switch (and another point of failure) ..

 

With all that being said .. I think you will find that you whole house network is going to be affected with E1.31 running Multicast along side your Internet .. the routing I mentioned wont help since everything is on the same network.

 

What I think would be a good solution and very cheap to roll out .. run down to Walmart, Best Buy, Offic depot .. whomever may have a NIC card for your machine and add a second nic to run your E1.31 from.

 

Use the onboard (existing) NIC as you are now .. for internet connection .

Use the new NIC by setting a static IP of something like 192.168.100.1

Set the SanDevice to 192.168.100.206 (or what ever you want between 2 and 254)

Then you can add a route (I can send that to you.. ) which make sure that all traffic behaves itself and you have a smooth running show ..

 

Bob

Edited by bob_moody
Link to comment
Share on other sites

Off the wall question .. the switch that didnt recognize the SanDevice.. was it already powered up and running when you brought the E1.31 device online?

 

I ask becasue E1.31, unlike ethernet, is not bi-directional.

In other words, if you had established a connection with E1.31 then moved the cable to another switch port, unlike a computer it wont see it right away ... You have to wait for the devices to give up, timeout and poll again. In a switch once you connect the MAC address is stored and all traffic for that address is routed only to that port.

 

I found on my Cisco that if I moved E1.31 connections while the switch was running.. I had to cycle the power on the switch and make it start new.

 

Also .. you might want to run the command ARP /D to refresh the ARP table on your pc.

 

It seems that all of your connections are on the same network which is why I dont understand the need for the router. Its routing nothing .. basically a pass through switch (and another point of failure) ..

 

With all that being said .. I think you will find that you whole house network is going to be affected with E1.31 running Multicast along side your Internet .. the routing I mentioned wont help since everything is on the same network.

 

What I think would be a good solution and very cheap to roll out .. run down to Walmart, Best Buy, Offic depot .. whomever may have a NIC card for your machine and add a second nic to run your E1.31 from.

 

Use the onboard (existing) NIC as you are now .. for internet connection .

Use the new NIC by setting a static IP of something like 192.168.100.1

Set the SanDevice to 192.168.100.206 (or what ever you want between 2 and 254)

Then you can add a route (I can send that to you.. ) which make sure that all traffic behaves itself and you have a smooth running show ..

 

Bob

 

Bob,

Can you post the routing info here please, or send it to me in a PM if you want, whatever is easier.

 

I've got a similar setup, expect my show computer has internet access off the wifi, and I'll be running the E1.31 through the wired NIC which will be set to operate on a different network than the rest of the house. E1.31 will be running in unicast, atleast that's the plan right now.

 

Thanks

Link to comment
Share on other sites

There is a great thread here :

 

http://forums.lightorama.com/index.php?/topic/27736-e131-bogs-down-wireless/?hl=%2Bstatic+%2Broute

 

The command to isolate MULTICAST is

 

route -p add 224.0.0.0 mask 240.0.0.0 <ip of correct pc interface to use> metric 5         
 

This will keep all the Multicast traffic on the specified NIC (sepcified by its IP) ...

 

This is the comamnd that I used on my show ...

The "-p" makes the route persistant (permanent) so you dont have to enter this everytime you boot or put it into a startup or batch file.

 

Bob

Edited by bob_moody
Link to comment
Share on other sites

Doubt the wire run is an issue (assuming your running CAT5) .. You should be good for at least 300'

Curious about the router with the WiFi turned off.. What did you do to configure it as a router? ( or is it basically just another switch)

 

SanDevice to switch in the basement.. is this a commerical cable or did you make it?

Are you 100% sure on the pin config on the RJ45 .. maybe accidentally built a cross over cable that the router you added will flip and make right but the desktop switch wont or doesnt?

What switch do you have (the original one .. not the router you turned the WiFi off on) ?

 

So right now .. what seems to be working(?)

Sandevice ---> Router (less Wifi) ---> Switch ---> PC .. ?

 

Still curious about he IP address on your PC, and the switch ..

 

Bob

Edited by bob_moody
Link to comment
Share on other sites

Router is set up like a router without wifi

Yes, it is home made cable, but I have a tester to verify the pinout. 

The switch I have is called "3com superstack"? bought it used but always worked great for me. 

and right now, it seems like the tree can communicate with the pc but nothing else works. Installing a new plan card in the pc right now. Trying to find the right driver.

Link to comment
Share on other sites

The 3Com ... Managed or Unmanaged?

 

I'm sorry .. Router is setup like a router without the Wifi .. really doesnt tell me much..

Its .. a Belkin N-Router and you turned off the Wifi radio and using the ports in the back ??

If so.. not a router .. its just another switch in line (basically.. Look for anything in router discussing IGMP)

 

If the 3-Com is managed .. you will need to look at the IGMP config.

 

Bob

Edited by bob_moody
Link to comment
Share on other sites

One last thing before I excuse my self for a little while to finish my porch ....

 

You said the switch was next to the PC ? .

Can you bypass the switch and go directly to PC and manage your SanDevice from there?

If so, the problem, I would suggest is in the switch... maybe the PC or SD is plugged in to an MDI-X port that needs to be switched? (and the extra router/switch is automatically doing that which would explain why its needed)

 

Bob

Link to comment
Share on other sites

No, I had a lot of trouble with it and then I had to leave again. It is a Cisco valet router and I use the ports on the back but just turned off the wifi. When I plug it directly into the back of the pc, it does not work. The switch is unmanaged, it just works by itself. I couldn't get the driver for my Ethernet card as it only works up to windows Xp and I have windows 7. I will try to take the extra router out today, also it seems as if it has started to cause issues across my whole home network.

Link to comment
Share on other sites

So .. if you plug the cable from the SanDevice directly into the NIC card on the PC, you cannot access the SanDevice ...

3 componets ....

PC - Check the IP on the PC and make sure its on the same network as the SanDevice

 

Cable - I would check and double check this... Since you had a PC that was working fine and and SD that was working fine .. possible flipped pair .. I actually did that last night... flipped the 4,5 blue pair .. box showed connected (LED on solid).. but HW util wouldnt pick it up ..

 

SanDevice - check the IP, Netmask and GW on this as well ...

 

I would bring the device in, use a known good cable and start from there .. PC --> SanDevice.

 

Dont know what type of cable tester you have .. but I've seen some that will simply test continuty ... not specifically that the wires are in order... In other words .. as long as it can see the other end .. it gives a light saying good ..

 

As far as your whole network .. I would suspect as much ..

That is why I mentioned getting the SD off the house network with another isolated network and that Static route i referenced.

 

Still willing to help if I can ...

 

Bob

Edited by bob_moody
Link to comment
Share on other sites

Well that explains the router.

 

Your PC is at 10.0.0.10 and your SD is 192.168.0.206. Entirely different networks .. (post #6)  

 

 

If you put the SD on the 10.0.0 network you wouldnt need the router however I still think you are going to see some major performance issues with your home network when you fire this up.

 

Bob

 

PS... Although a moot point now .. I led you wrong on the ARP command .. its arp -d , i think i gave /d ... my bad ..

I'm pretty sure now that your cables are good.. Also .. unless you have a specific need for it .. I would turn off IPv6 on the PC .. it will sometimes get in the way ..

Edited by bob_moody
Link to comment
Share on other sites

I will change that tonight. Totally makes sense as to why it would do that. Im not good with networking stuff, so thanks for taking a look. 


Could I do 10.0.0.206 ?

 

Also, my home router is 192.168.1.1, that connects after the switch. Should that be moved to like 10.0.0.1

Edited by Caleb Linburg
Link to comment
Share on other sites

Interesting ... let me make sure I understand ...

 

Your home network is on the 192.168.1 network

Your PC is on 10.0.0 network

Your SanDevice is on 192.168.1 network

 

Will this PC... as it sits right now talk to the home network (can you get to the internet)?

We alredy know if you plug the SD directly into the PC it wont work (because of 2 different subnets.  10. trying to talk to 192. ) which explains the need for the extra router . It also apepars that the 10.0.0.10 address on your PC was issued as a DHCP address from (some) router which confuses me a little on the home network being 192.168.1.1

 

Unless.. the extra router you added, and turned off WiFi is still acting like a DHCP server and that is actually where the PC got the 10.0.0.10 address from and not from your main (original - home network ) router which again would explain a lot of why nothing on the home network side is working and why the router is needed for the SD and why the PC is on a completely different network..

 

1. Plug the PC into the cable for you home network and reboot it...

2. Run IPconfig /all again and see what the IP address is

3. If it is now a 192.168.1 address .. then the main router gave it a DHCP load and it should it communicate with the Internet.

4. If its still a 10.0.0 address then look at the home network setup and see what the WAN and LAN configurations look like.

5. If #3 is true, then take the extra router out (the one with WiFi off) and plug the cable from the SD into your switch

5. Plug the home network into your switch

6. plug your PC into the switch ..

7. If I'm guessing right .. now everything is on 192.168.1 and you should be able to manage the SD and get to the internet.

 

NOTE: Again, I can almost assure you that when let this off the chain .. its going to beat your home network performance into the ground ...

 

I wholeheartedly suggest a trip to Walmart, Office Depot (If I actually found your web site and understand where you live, you should be able to locally find an inexpensive NIC card. )

Add the card and set up a new static network on it ... 192.160.10 for example.

Set your SD to the 192.168.10.206 if you want .. anything from 1 to 254 for the last #

Set the new nic for

192.168.10.1/255.255.255.0

You really dont need a GW ..

 

Add the static route I gave you .. this will force all Multicast traffic to the new NIC and keep your home network free of extra traffic ..

 

You should .. at this point be golden ..

 

Bob

Edited by bob_moody
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...