Jump to content

E682- Runs on router but not directly from computer


Chris A
 Share

Recommended Posts

Hello,

 

I have configured everything on the E682 and the LOR side, but maybe I'm missing something. When I plug the E682 directly into my wireless router the LOR sequences run fine. I see all the pixels doing exactly what they should do.

 

When I plug the E682 into the show computer, The lights do not come on, even though the E682 appears to be talking to my computer. I have tried disabling the network connection and tried to enable it using the wireless router, neither one work. I also can not access the E682 config screen, with or without the network connection on. I even tried changing the local network to only read the E682 address but that also did not work.

 

I have tried the exact same thing with my laptop which is also wireless and the lights do not come on.

 

I'm pretty confident with my settings on the E682 and LOR because I can get everything to work when hard wired to the router. I can access the E682 config page and all the settings are good.

 

What the heck am I missing?

 

Thanks, Chris

Link to comment
Share on other sites

My first guess is that you have your show computer set for DHCP.  In most home networks, that is the norm, and the router acts as the DHCP server.  No router = no IP address for the computer.  That means no talking.  Set your show computer for a static IP address on the same sub-net as the E682 and that should fix your problem.

 

Another slim possibility is that neither your show computer nor the E682 has automatic crossover (properly called Automatic MDI/MDI-X).  If that is the case, then you would need a crossover LAN cable.  I say this is a slim possibility because almost every LAN device built in the last decade or so has automatic MDI/MDI-X so it will automatically crossover if needed.  I have never tested the E682 so I don't know if it has Auto MDI/MDI-X, but I would guess that it does.  OK, just looked at the operating manual and it says that a crossover cable is not required for a direct connection to a PC.

Link to comment
Share on other sites

This is how I setup my E682 before my dedicated router was purchased. You have to force a change in the network settings. This is from the manual:

Connect an Ethernet cable directly between a PC and the E682. If there is a wireless connection to the PC it must be disabled. Reboot the PC. With the E682 powered on, press AND HOLD the PROG button. While holding PROG, press and release RESET. Continue to hold the PROG button pressed, and after a few seconds you will see the red and green LEDs flash on and off together. Wait until the 3rd on/off cycle has completed, then release the PROG button (after the LEDs go off for the 3rd time, but before they come on for the 4th time).

Since no DHCP server will be found by the E682 or by the PC, they will both have assigned addresses in the 169.254.x.x range. Wait until the E682 completes it’s startup as indicated by the red LED being steady on. Now start up the PC’s web browser; you should get an error page rather than your usual default page since there is no internet connection to the PC. Now type 169.254.74.73 into the address bar of your browser and press ENTER. This should bring up the E682’s web page. From there, you can use the system configuration commands described later, to reconfigure the E682 to use a static IP address that is available in your network.

Link to comment
Share on other sites

My first guess is that you have your show computer set for DHCP.  In most home networks, that is the norm, and the router acts as the DHCP server.  No router = no IP address for the computer.  That means no talking.  Set your show computer for a static IP address on the same sub-net as the E682 and that should fix your problem.

 

Another slim possibility is that neither your show computer nor the E682 has automatic crossover (properly called Automatic MDI/MDI-X).  If that is the case, then you would need a crossover LAN cable.  I say this is a slim possibility because almost every LAN device built in the last decade or so has automatic MDI/MDI-X so it will automatically crossover if needed.  I have never tested the E682 so I don't know if it has Auto MDI/MDI-X, but I would guess that it does.  OK, just looked at the operating manual and it says that a crossover cable is not required for a direct connection to a PC.

 

 

Thanks Jim,

 

I'm not sure how to change my show computer to a static address, but I did go into my LAN and changed the Internet Protocol Version 4 (TCP/IPv4) and manually inputted the IP address of the E682, it still won't bring up the config page or talk to the lights. I also tried this on my laptop to rule out it being a computer issue. I seem to be missing a setting somewhere.

 

Chris

Link to comment
Share on other sites

This is how I setup my E682 before my dedicated router was purchased. You have to force a change in the network settings. This is from the manual:

Connect an Ethernet cable directly between a PC and the E682. If there is a wireless connection to the PC it must be disabled. Reboot the PC. With the E682 powered on, press AND HOLD the PROG button. While holding PROG, press and release RESET. Continue to hold the PROG button pressed, and after a few seconds you will see the red and green LEDs flash on and off together. Wait until the 3rd on/off cycle has completed, then release the PROG button (after the LEDs go off for the 3rd time, but before they come on for the 4th time).

Since no DHCP server will be found by the E682 or by the PC, they will both have assigned addresses in the 169.254.x.x range. Wait until the E682 completes it’s startup as indicated by the red LED being steady on. Now start up the PC’s web browser; you should get an error page rather than your usual default page since there is no internet connection to the PC. Now type 169.254.74.73 into the address bar of your browser and press ENTER. This should bring up the E682’s web page. From there, you can use the system configuration commands described later, to reconfigure the E682 to use a static IP address that is available in your network.

 

 

Thanks Baron,

 

I tried the suggestion before your reply and again after I read it from you. There is still no change. I would not be opposed to getting a dedicated router if that would solve my problem. My current Linksys wireless router is located upstairs in a room and the show computer is in the garage. I don't have a way to hook up another router in my garage do I?

 

Thanks, Chris

Link to comment
Share on other sites

Chris, you are really close. It sounds like you set a static IP for your computer, but you don't want the computer and E682 to have exactly the same IP - just close. I am doing this by memory as I'm in my phone right now, as I recall the default IP for the E682 is 192.168.1.206. Set your computer to 192.168.1.anything except 206. For example 192.168.1.201. If it does not default the subnet mask, set 255.255.255.0 and the default gateway to 192.168.1.1. If you need to enter a DNS server use the same 192.168.1.1

BTW, the default IP I gave is in version 4 of the firmware. I think it was different in older versions.

Link to comment
Share on other sites

Chris, you are really close. It sounds like you set a static IP for your computer, but you don't want the computer and E682 to have exactly the same IP - just close. I am doing this by memory as I'm in my phone right now, as I recall the default IP for the E682 is 192.168.1.206. Set your computer to 192.168.1.anything except 206. For example 192.168.1.201. If it does not default the subnet mask, set 255.255.255.0 and the default gateway to 192.168.1.1. If you need to enter a DNS server use the same 192.168.1.1 BTW, the default IP I gave is in version 4 of the firmware. I think it was different in older versions.

 

I entered all that information and I'm still not seeing lights. Glendora isn't that far from Simi, I'm looking for a consultant. You were correct on the IP address for the E682. I'm really not sure why this isn't working. Thanks, Chris

Link to comment
Share on other sites

For anyone watching this topic, Chris and I (and eventually a friend of mine) and resolved his problem.  Turns out the network card in his old computer did not really like operating automatically as far as speed setting.  Although it said it was operating at 100 Mb/s, it really was not operating correctly that way.  Forced it down to 10 Mb/s and it's working fine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...