Jump to content

Strange LOR network happening


plasmadrive
 Share

Recommended Posts

I have been using my LOR network going on the third year now.  I use ELLs to talk to 3 locations from the transmitter.  One location has an IDMX and the other has 16 CBT16pc connected.  I have never had an issue with the network other then the other day when I found out one of the RJ45 jacks on a G3 has gone bad.  I use a Y for a work around.  All has been working fine.  I have had no issues... Tonight I ran a few songs and it all worked great.  I made some edits to the sequences and saved them on my programming computer.  I transferred them via flash drive to my laptop show computer, same as I always do.

 

All of a sudden I loose some of my controllers off the network.  I have no explanation for it what so ever.  I shut down the sequence editor and open the HU.  I only discovers 30 of the 31 controllers. (IDMX takes up 16) and for some reason it always sees one more than is there. Then I run it again.. now it comes up with 27 and also a bunch of the lights turn on out in the yard.  This has never happened before.  I run the HU again.. now I get some other number of controllers.  OK.. now I am a bit miffed.  I unplug the ELL that talks to everything, I reboot the computer, I power cycle the #6 controller which is one that showed up missing every time I tried the HU since it messed up.. I they the HU again and I get 27 controllers.. Now I am really in a snit.  I shut all LOR software down again and power cycle the ELL. by unplugging the  USB to 482  converter... this time when I come back up and try to discover the controllers, it works fine.  I ran all my songs and they ran fine.  I did see a couple of points in the songs where I have some fast moving effects and it skipped a command or two but you would not know it unless you knew what to look for.

 

Anyway.. It all worked fine... I have no explanation for the hiccups.. or why a reboot and restart didn't cure them the first time.  Something had to get on the network and cause the problem.  I did not open any controllers or mess with any jacks for plugs or cables other than on my laptop and that was just the USB to the 485 converter..  And before you ask.. yes I have all the right hardware, cables power supplies and up to data software.  The entire system has worked for a couple of days already this year.  The sequences I transferred work fine now and I did not have to down load them again.. This was a network hiccup and I don't like it. 

 

Any thoughts or suggestions? 

Link to comment
Share on other sites

Temporary interference on the network?

Did you lay your phone down on top of the network cable?

Run a test sequence that has all on for a few seconds and all off for a few seconds; that should keep the network traffic up.

Then start wiggling cords and connectors to see what is affected.

Link to comment
Share on other sites

I don't know if it makes any difference, but if that "Y" isn't using the USB Repeater from LOR, I'd be suspicious of it.

Don,

That "Y" is one from Holiday Coro that they build specifically for DMX daisy chains.  It is in one of the controllers on the RS485 line and works the same as the paralleling of the Cat5 cables on the boards except the node is about 12" farther from the controller.  With RS485 you are allowed a certain overall node length I believe, and I doubt 12" is going to mess it us..   Also, it worked prior to this, and it has worked ever since. 

 

The really weird part is that during discovery of the controllers it turned on a bunch of lights.  Discovery in the HU should never do that.  So some sort of data or noise was injected.  I went out today and tried everything again without issue... So I have no friggin idea.  I even unplugged and replugged my unit 6, which was the first to disappear from the network.  Still works fine.

 

I am a little miffed as to why the HU finds more controllers than there are actually out there.  There are 30 controllers including 10-0F for the IDMX and 1-0F for the CTB16s.   The HU finds 31 pretty much every time.. however, this morning it found #20 and said it was an IDMX.. I looked under every rock but could not find that extra IDMX.. Darn it.

Link to comment
Share on other sites

The problem with a Y is not distance, it is SIGNAL REFLECTION.

 

Y's, unless created by an active repeater type device are strictly VERBOTEN in an RS485 network (which includes DMX).  When data reflects in an RS485 network, 0s sometimes become 1s, 1s sometime become 0s, and the whole thing appears to be random.

 

RS485 devices are either 1 in 0 out, or 1 in 1 out.  When you go 1 in 2 out, not only do you reduce the signal power (data logic levels), but you create impedance mismatches.

Link to comment
Share on other sites

Actually, RS485 does allow for "stubs".  

 

I know 6" or less is a rule of thumb but that is for a pretty fast network.  I don't believe my "stub" from the wye is causing any issues.  It was working before this incident and has worked ever since...  

 

"Stub length should be much less than ¼ of a wavelength of the
frequency equal to the inverse of the bit period."
 
But, LOR did send me some connectors to fix the problem.  I do plan on solder one in when I get them.
Link to comment
Share on other sites

Hey Max! 

 

<6" is the rule of thumb, but for slower networks like the LOR network you can sometimes do up to 6'.  Just depends on the system. 

 

I don't have a terminator on the last controller.  For the distance I am running and the slowness of the speed, the protocol doesn't actually list it as required.. But... with that said.. that is not a bad idea..  I may just do that for the heck of it and see if it makes any difference.

 

Do you run a terminator on yours? 

 

http://www.baranidesign.com/rs485/rs485.html  Some info

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...