Jump to content
Light-O-Rama Forums

iDMX works perfectly using HU Test Console but not on a sequence


Recommended Posts

I have gone through many steps with support so below is the pasted text of my support ticket so its clear whats going on and whats been done. HELP!!

Wed, Nov 14 2012 5:58pm

I have my sequence that I use for my outdoor lights up and running. I added an iDMX and have it up and running using the Test Console in HU. When I add a channel to my sequence and choose "LOR Controller" and set the unit id appropriately and the channel (matching what i see on the channel fader in Test Console) and then test it in the sequence I do not get any control in the sequence. I tested using multiple channels on various Unit IDs (E0-E5 in my case). I can still successfully control the DMX channels from within HU's Test Console, im just missing the link somewhere in the sequence.

Wed, Nov 14 2012 10:00pm - John Potochnak (Cosmic Devices)

If you are not stopping the Hardware Utility, the Sequence Editor will not be able to get the USB adapter. If the HWU is stopped, make sure the adapter being used by the Hardware Utility is the same one configured in the Sequence Editor (Edit -> Preferences -> Network Preferences) and that the iDMX is configured on the correct network if you have more than one.

Thu, Nov 15 2012 4:27pm

Corel000.jpg (0.1 mb)

I change the unit ID from E0 to E1. Under Test Console I can correctly control any dmx channel. I then exit HU. I open a new animation sequence, configure the first channel as a "Light-O-Rama Controller", regular network, unit "E1", circuit "21" (one of my dmx channels thats easily seen and worked perfectly under Test Console. I add a fade on command and get nothing. I add a 100% on command, nothing. I didnt see anything under Network Preferences that would indicate anything is set up wrong (see attached).

Fri, Nov 16 2012 1:03am - John Potochnak (Cosmic Devices)

Let's make sure that the Sequence Editor can talk to the iDMX. When no LOR program is running, but the iDMX is cabled up, the status LED on the iDMX should be flashing about twice/second. Then start the Sequence Editor. The square at the lower right of the Sequence Editor window should be blue, meaning it can get the comm port. The status LED on the iDMX should go on solid. Make sure "Control Lights" is checked in the play menu and click the play arrow.

If it still doesn't work, try inserting the iDMX using the "Insert Device Below" option when right clicking a channel button. Since your unit ID is E1, use normal ID mode and select the correct number of DMX channels. Maybe there is some error in the way you inserted the device and this should correct that.

Fri, Nov 16 2012 9:57am

Corel.jpg (27.9 kb)

The blue box in the corner is on and the status light is solid. The control lights is checked in the play menu. We added the iDMX using insert device below using the unit ID E1 and was still unsuccessful.

Fri, Nov 16 2012 10:06am

Corel__2_.jpg (0.2 mb)

As you can see in the attached photos i can control Ch21 on dmx to turn on the two blue lights as seen in the background of the photo. the Test Console shows Unit ID E1

Fri, Nov 16 2012 10:06am

photo.JPG (0.6 mb)

see attachment

Fri, Nov 16 2012 10:58am - John Potochnak (Cosmic Devices)

Attach the animation sequence that doesn't modulate dmx channel 21. I will try it.

Fri, Nov 16 2012 11:00am

ryanHodgesDMXTest.las (59.5 kb)

.las attached

Fri, Nov 16 2012 11:42pm - John Potochnak (Cosmic Devices)

I set the Unit ID on my iDMX to E1 and ran your sequence. The first 32 pixels on my ribbon flash on and off which is what I would expect. Make sure your iDMX is running the latest firmware 1.41

Sat, Nov 17 2012 2:56pm

I downloaded FW1.41 to the iDMX. I hit the refresh button and it verified the firmware was installed correctly. I open the test sequence I sent and it still doesnt send the command to the dmx channel. I reopen HU, open Test Console, the light works fine through HU. There is something changing between the two applications that keeps the sequence from controlling the lights. I started with a fresh sequence, added on track that was mapped to unit ID E1, channel 21, light o rama controller, regular network. Nothing.

Link to comment
Share on other sites

having the same issue

support keeps saying I should upgrade software, but it clearly states my software fully supports iDMX. It works great in HU but no activity in Sequence Editor.

I tried to follow the instructions on


but i cannot get device added as they do at the 4:50 mark. I do not have a DMX Universe option in my drop down

Maybe you will have more luck?

Link to comment
Share on other sites

just got my iDMX to work. Was SUPER easy once I got an email from someone at support that had knowledge on the subject.

1) went into Hardware Utility and changed the ID of iDMX from E0 to 04. So now my iDMX is running as an LOR controller #04. Apparently this is what LOR calls NATIVE mode (who knew)

2)iDMX set to unit 04 - I still have all 512 channels available

in my display I have 3 LOR controllers and now an iDMX set to #04

In Sequence Editor, I change my corresponding RGB channels to

Device type = LOR

Network = Regular

Unit = 04

Circuit = 10 for red, 11 for Green, 12 for Blue

I have 3 other RGB floods and I just set Circuits to corresponding address of 20 (20,21,22), 30 (30,31,32) & 40 (40,41,42) and it all works great.

Just took 10 separate emails from support until someone actually new what they were doing and the fix couldn't have been easier.

Link to comment
Share on other sites

  • 3 weeks later...

What type of RGB floods are you using? Can you send me the emails from lor support abt IDMX1000, thanks


Link to comment
Share on other sites

For future reference - the non-advanced license levels have controller ID limitations. Since the iDMX defaults to a very high ID, it won't work (out of the box) with anything but the Advanced software.

This, and the fact that it ships with an address ending in '0' (putting it in legacy mode, which almost nobody wants) really needs to be changed by LOR. Well, at least that's how it shipped last I heard.

Link to comment
Share on other sites

  • The topic was locked
This topic is now closed to further replies.
  • Create New...