Jump to content
Light-O-Rama Forums

problem - LED status light won't illuminate

Andy Wallman

Recommended Posts

I have 5 controllers, 2 of which were new kits I put together earlier this year. At that time, they worked fine - in fact, I connected several strands of lights to them and ran a quick sample sequence.

Now that I've got my display set up, I plugged in my controllers, and the LED status light won't illuminate on 1 of them. I've used my voltmeter and detect 120 volts across all of the terminals, so I know there is proper power coming to the board and going across the jumpers. But nothing comes of the LED status light. The Hardware Utility won't detect this board either.

I've swapped out the fuses just in case, but still nothing (and the fuses that were in there work fine in the other boards). I've tried connecting to the computer with this one unit only as well as in series with the other 4, but still nothing.

Anyone have any ideas on what might cause this, and more importantly, what I can do to fix it?

Thanks in advance. Hoping to get this corrected in time for the display to kick on this Saturday!

Link to comment
Share on other sites

NEVER MIND - I just noticed one of the microprocessors had come half-way unplugged. As soon as I popped it back in, everything works fine. WHAT A RELIEF!!!!

Its always the simplest things that can trip you up :P

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...