Jump to content
Light-O-Rama Forums

X-10 not working in version 2.5.2


Recommended Posts

I've been running my Halloween show for 2 weeks now with no problems. Tonight I upgraded my show computer from 2.4.10 to 2.5.2. After the show started, I went out to take a look and found that the speakers were not on. Also not working was the FM transmitter.

Both the speaker amplifier and the FM transmitter are controlled by X10 modules (with different X10 addresses). I have a 60-second background sequence that turns these channels on for the entire sequence. My CM11A is connected to the serial port on the Dell motherboard (not a USB serial device).

The show has been working fine for the last 2 weeks until I upgraded to 2.5.2.

The hardware utility has no trouble controlling X10 devices.

The sequence editor sometimes worked on some X10 channels, but most often did not.

A restart didn't solve the problem.

Any ideas? Is this simply a bug in this version?

Link to comment
Share on other sites

Did you try rolling back your version just to double check? The fact that the sequence will sometimes trigger the X10 kinda makes is sound like a typical X10 ghost. Do you have an X10 signal meter?

As an aside (in case any LOR staff read this), any update on USB X10?

Link to comment
Share on other sites

Hmmm... I just tried out a couple X10 sequences, and they worked fine. Has anyone else had a problem like this?

One of the changes in version 2.5.2 was that the LOR Control Panel's status window now shows a log of what's happening in your show. If you start up the show, what does it say about the sequence(s) that deal with your X10?

Link to comment
Share on other sites

iresq wrote:

Did you try rolling back your version just to double check?

Yes, I uninstalled 2.5.2 and reinstalled 2.4.10. Then it worked, 100% reliable.

bob wrote:
If you start up the show, what does it say about the sequence(s) that deal with your X10?

It says that they are running.

The problem also happens in the sequence editor.

I'll check something else when I get home....
Link to comment
Share on other sites

I have switched from 2.4.10 to 2.5.2 several times. 2.4.10 is 100% reliable controlling X-10. 2.5.2 is maybe 5% reliable. In both versions the hardware utility is 100% reliable. The problems occur in both the show player and the sequence editor.

In case it helps, here is the data on the computer:

Windows XP Home SP3.
Pentium 4 1.79GHz, 1.25 GB of RAM.

X10 is on COM1, which is an Intel 82801DB LPC Interface Controller.
Serial driver version is 5.1.2600.0 (files are 5.1.2600.5512)
I/O 03F8-03FF IRQ 4

The CM11A is the old white "X10 ActiveHome" box with no batteries installed. I never installed the ActiveHome software on this system, so it wouldn't interfere with LOR, and besides, it also has a CM15A with ActiveHome Pro.

I don't want to mess with it if I don't have to, since it works so well with 2.4.10, but I'm going to need to upgrade eventually.

Is there anything other data I can collect?

Link to comment
Share on other sites

  • 1 month later...

I am using version 2.6.2 and my x10 modules will not turn off afgter the show. This process has worked with no issues all the years using LOR 1. The show will turn on al of the X10 appliance modules via a CM11A with no issues via a background sequence. When this sequence runs at the end (verified via the log) only the first x10 module turns off and he remaining 8 - x10 modules do not. I also tried to use the LOR hardware utility to turn off the modules manually and it would not work. I had to load ActiveHome to turn off modules.

When testing with the hardware utility I noticed that the utility did not remember the comm port for X10 like it had in the past. When I would go to initilize it will say unit not found. Retrying will initialize the unit. During any testing I will see the the communication between the hardware utility and the CM11A was lost.

I unloaded LOR from memory and load ActiveHome to test the CM11A and all modules responded perfectly.

I am going to load 2.4.10 to see if the problem goes away.

Link to comment
Share on other sites

My X10 channels behaved intermittently when I turned two of them off at the same time in a sequence. My workaround is to wait a second between the time I turn the first one off and the time I turn the second one off.

This year, I eliminated the Background sequence and put the X10 control in the Startup and Shutdown tabs (with the "Turn used lights..." un-checked).

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...