Jump to content
Light-O-Rama Forums

Error (8002) Open of serial port has failed


Recommended Posts

Hello!  We bought a mega trees last month and everything works fine when running a single sequence but when I went in and built a show and went to enable it, it just keeps giving me this error code 

error code 8002 open of serial port has failed
While:  Open COM3 params baud=56000 parity=n data=8 stop=1 xon=off
odsr=off dtr=off rts=off idsr=off
While:Open COM3 params baud=56000 parity=n data= 8 stop= 1 xon=off
odsr=off dtr=off rts=off idsr=off
Trace: Init Light O Rama port/LORChannellO

Is there anyone that can assist to get my show running?  I'm stuck :(  and to top it off very new to this so would appreciate it.  We are planned on having our show up and running for people this saturday and ran into this hiccup.

Edited by Paige
Link to comment
Share on other sites

Do you have the FTDI Drivers installed?  This can sometimes generate that error.   These drivers are what the LOR Adapter{s} need to operate, the device that goes between the computer and the controllers via the cat5 cables.

I thought maybe having another LOR program open may cause this error, but i just get a pop up telling me the comm port is open and in use by another program.    And I know I got this error when I replaced a failed HD and reinstalled my LOR software, and it was because I forgeiot to install the FTDI drivers that the dongle {LOR USB RS485 adapters} require to operate.

Hopefully this is your issue.   I know this error has been covered here before and there is another issue that can cause it, if I recall, but unfortunately I can't recall what it was or where the posts{tried to search for it} are that may have corrected it.

Hopefully someone who knows and remebers where that post is or what the other issue was that causes this will chime in here.

Just know my issue that caused it was because I didn't have the FTDI Drivers installed.  I also had to update to the latest FTDI Drivers too, they can be found here: FTDI Chip

Best of luck getting things working.

Edited by Orville
Link to comment
Share on other sites

I did get it fixed! Thanks so much for replying!  Now I have another issue.  For some reason the show I created in the HUB isn't playing the correct order and not everything that is saved in the show.  I go in and select from computer, create the show which is 4 songs and a 30 second inbetween show in between them all, save it, schedule, upload the show and it plays but it plays the 3 in between right in a row and only 1 song.  I keep recreating it, saving and re uploading but it doesn't change.  I'm not sure what the problem is and not sure if there is any other way to create a show?  Anyone have a clue?

Link to comment
Share on other sites

When you insert the in-between sequences, are they literally in between each sequence?   I.e. SilentNight.lms <in between sequence.lms {or .LAS if animation file}, What Child Is This.lms <in between sequence>, Have a Very Merry Christmas.lms <in between sequence>O Come All Ye Faithful.lms

If the animation or in=between sequences are together, they will play back to back, but if you're entering them like the example I gave, they should be playing the order you set them up.

I haven't played around with the Hub much, so know a little about it, but not as much as someone else might here.  Hopefully they can help you with this issue if you're doing it as I outlined and it's not coming out correctly.  As it should work if entered as the example.

Now if the file is an animation file, and there is an option in the Hub to change from Musical to Animation to insert an .LAS file, you may have to change the format between the .lms {Musical Sequence} and the .las {Animation Sequence} files to enter them where they need to be.  Like said, I haven't used it enough to know how it works in some areas as yet.   So I'm only trying to think of what may need to be done in the Hub to do what you're trying to accomplish.

Link to comment
Share on other sites

  • The topic was locked
This topic is now closed to further replies.
  • Create New...