Jump to content
Light-O-Rama Forums

Colors not the same when imported to SE


Recommended Posts

I have finally started learning how to use SS Sequencer.  The problem I'm having now, is that the purple I use in my smart pixels becomes blue when imported as intesity files to SE.  It's only in the DMX smart pixels that this is happening. What am I doing wrong?  Is there a setting I'm missing?

Edited by Dcroc
Link to comment
Share on other sites

Purple should not become blue regardless of what you are doing.


In the exported file, when you hover the mouse over a square it should tell you the percent value of red, green, and blue. What values does it give you when you hover the mouse over the square that looks blue?

Link to comment
Share on other sites

Sorry, I missed that you are exporting as intensity files. Are you using superstar with an imported visualization? If so, please email your visualization to brian@superstarlights.com


The visualization file will be at:


c:/ (your lightorama folder) / Visualizations / Editor

Link to comment
Share on other sites

Sent the visualization and the intensity files. It's only the smart pixels on the roof that I'm having the problem with. The dumb strips around the windows and doors seem to be fine.

Link to comment
Share on other sites

Have not toyed with intensity files yet, but when I export out of SS to SE, it never exports in RGB channels.  Always 3 channel blocks, which are the default LOR blue color.  Don't know if that is what is happening, just my $.02

Link to comment
Share on other sites

Thanks for the files. I duplicated the problem. The problem exist when exporting as an intensity file and also when exporting in the legacy format.


The problem has to do with dimming curves.


The only lights that don't need a dimming curve are incandescent lights. With an incandescent light, you want to send the data "as is". In other words, if you want 50% red then you send 50.


LED lights dim differently than incandescent lights. With an LED if you want 50% brightness then you have to send something lower such as 26 in order to get the LED down to 50% brightness.


So in your particular case you want the lights to be purple. To get purple you need 100% blue, and 50% red. Since your lights are RGB LEDs, in order to get purple on them you need to send 100 for blue, and 26 for red. So the bug is the reverse of what you would think. The smart pixels are working, it was the RGB dumb strings that were not working.


The bug is that the RGB dumb strings should be behaving the same way as the smart pixels, and they should be using 100 for blue and 26 for red in order to get purple. The end result is that in the sequence editor and in the visualizer purple will be more of a bluish purple. But on your actual lights it will be purple.


The bug will be fixed in the next release.


Note that I could have coded superstar to export the raw values and then the colors would look correct in the sequence editor and the visualizer, but they would not look correct on your actual lights. I figure it is more important to have the colors look correct on the actual lights so that is why it behaves the way it does.

Link to comment
Share on other sites

Thanks for the quick response.  I ran the sequence in real world.  The purple is actually a good bit lighter than the Vis or SS shows. Do I need to change the curve settings for LED? Is it a global setting, or can it be done per string/pixel?


Also, just thought I would mention that I am starting to love the SS proggie. Great job!  Getting past the initial set up took me some time, but once I got into it, the whole world opens up. 

Link to comment
Share on other sites

When you say "the purple is actually a good bit lighter than the Vis or SS shows" are you referring to the smart pixels?


When played to the actual lights, on which does the purple look better, the smart pixels or the dumb strings?


As for changing how it works, you can do the following:


1) click on the Edit menu and select Configuration

2) you will get an information dialog box saying that since you are in visualization mode the unit ID settings don't do anything. Ignore this message and click on Ok

3) At the top of the Configuration dialog box select "export raw color values"

4) click on Ok in the Configuration dialog box


Export again and no dimming curve will be used for anything. This should make purple look good in the Sequence Editor and the Visualizer, but when played to the actual lights I would expect it to be a reddish-purple.

But each string of lights is a bit different so your results may vary. Let me know if it looks better or worse with "export raw color values" selected.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...