Jump to content

Dont show CCR pixel cnt warning Options tab 5


ItsMeBobO
 Share

Recommended Posts

DevMike   I cant tell that this check box does anything.  Both present message box when entering demo mode preventing it.

 

Four CCRs in the display with the same unit id.    Can they be simulated?

 

VizOptions5.jpg

 

Link to comment
Share on other sites

I don't know what it all means either, but here is what it says in the manual.

"Don't show a warning if a CCR has an incorrect number of pixels: A CCR must consist of exactly 50 pixels, or it may not be simulated correctly.  Checking this box disables the warning if a CCR fixture has other than 50 pixels."

Link to comment
Share on other sites

Thanks Larry.   I have attached a screen snap for you to see.   This is the message which pops up when entering Simulation mode when a CCR has other than 50 pixels.  The CCR warning option does not impact this message.  It is shown either way.  But more importantly, it aborts entering simulation mode with either setting.     

 

 

 

 

SimErrors.jpg

Link to comment
Share on other sites

That check box will not prevent the error going into simulation mode.  CCRs will always require 50 pixels when going to simulation mode.  In order to properly emulate the CCR hardware, all 50 pixels must be present. 

 

Let me explain why that is:  In the case of a CCR, the Visualizer needs to not only show what the ribbon is doing, it must also emulate what the controller is doing.  If you take a physical CCR controller and hook it up without a ribbon, the physical CCR controller still thinks there are 50 pixels attached.  You can still throw commands at it for any of the 150 channels and it will accept them.  In fact, it will internally process those commands and even send the data out to the ribbon (that isn't hooked up).  The Visualizer needs to do the exact same thing -- however it has a second requirement:  It needs to actually display stuff.  

 

Big deal you say -- why can't I just leave some out then?   For the physical CCR, it doesn't care what state a particular pixel is in at any given time, since it is the END of the line for the data.  But in the Visualizer each pixel on that string also has to be emulated -- remember, it's a SMART string and each pixel has a microprocessor too.  The only way the Visualizer can simulate those 50 microprocessors is if they are defined - by creating a spot for them on the stage.    

 

Also remember that the Visualizer doesn't just have to emulate the CCR, it has to emulate an entire stage worth of controllers.   It is perfectly legal to set up a CCR to do something with a macro/color effect thing, and then start throwing commands at particular pixels -- which may also be defined channels on other non-CCR type controllers.  When that starts to happen, each pixel requires it's own separate state - which again requires those 50 pixels. 

 

Getting back to that option:

 

What that checkbox is for is if you are in edit mode and adding pixels to a CCR fixture.  Each time you attempt to add a pixel to a CCR fixture that already has 50 or more attached to it you will get a pop-up.  This check box prevents that pop up.  It does not prevent the simulation errors.
 

For the error message you posted, you have 2 or more CCR fixtures that have the same Network and Unit ID defined in the Visualizer.  That first error message tells me that at least 2 of those fixtures are trying to claim they are the master -- since there are at least 2 that are claiming to represent Pixel 1 on that Net/Unit.

 

The second error is most likely a symptom of the first.  Fix the first and try again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...