Jump to content
Light-O-Rama Forums

Whites becoming pink when exporting sequence from SSE


Recommended Posts

When I finish a sequence in superstar using the visualizer and export it into the LOR sequence editor, any pixel, morph, scene, image or text element that uses white R100, G100, B100 transfers as a pink. Any ideas what I am doing wrong? I am including a picture of the values I get (R100, G69, B60).

Attached files 294855=16289-Screenshot-2011-12-20_04.33.57.jpg

Link to comment
Share on other sites

The LEDs in CCRs are a bluish-white. To make the white a true white, and to make the other colors such as Yellow, Orange, and Purple truly be Yellow, Orange, and Purple, the SuperStar program "balances" the colors. This results in the white looking pinkish in the LOR Sequence Editor but when you play it to your CCRs it will look white. Also, some of the other colors will look off in the LOR Sequence Editor but on the ribbons they will look good.

Below is from the documentation and gives further details:

Balanced Color Mode / Full Color Mode
If you use the Light-O-Rama hardware utility and try various settings on the RGB values of each CCR pixel you will find out three important characteristics:
1- The Brightness is not linear
For example, a setting of 100 is only a little brighter than a setting of 50.To get brightness that is ½ of full intensity you need a setting of 25.
2- The red, green and blue elements are not balanced
If you set red to 100 and green to 100 you should get yellow. But you will get more of a greenish yellow. This is because the green element is stronger than the red element. If you set red to 100 and blue to 100 you should get purple. But you will get more of a bluish purple. This surprised me because blue appears to be more dim than red and green, but in reality it is stronger than the red element also.
3- The LEDs are so bright that the perceived colors will not be as deep as what you see on the computer screen. This must be taken into account when comparing the colors on the computer screen with what you will get on the ribbons. For example, red=100 and green=50 will give a bright orange. Red=60 and green=30 will give a dim orange that will show as a muddy orange on the computer screen, but on the Cosmic Color Ribbons it will be an orange that is 60% of the intensity of full orange but it will still be a fairly bright orange.

• Making the brightness linear
The SuperStar Sequencer automatically adjusts the start and end settings to make them linear. For example, a start setting of 50 in the editor will export to a setting of 25 for the Light-O-Rama sequence. This gives the proper intensity for the start and end color of an effect. But realize that a ramp that goes from 100 to 0 will not go from 100 to 0 smoothly. The Light-O-Rama hardware will bring the voltage down from 100% to 0% smoothly but the brightness will go down slowly at first and then drop fast at the end. The SupeStar Editor simulates this fast drop off when it plays the sequence onto the ribbons. Note that this fast drop off can be solved using the “Smooth Ramps” setting which is discussed in the next section.

• Balanced Color Mode
The SuperStar Sequencer defaults to “Balanced Color Mode.” In this mode, the red element is used in its full range, but the green and blue elements are limited to less than full brightness. So if you set red to 100 and green to 100 you will get a true yellow on the ribbon.

• Full Range Color Mode
To set this mode, go to the Tools menu and select Configuration. When in Full Range Color Mode the color controls will have the following ranges:
Red 0-100
Green 0-120
Blue 0-130
In this mode, setting red, green, and blue all to 100 will give the same results as in the Balanced Color Mode. Setting red to 100, green to 120 and blue to 130 will give a bluish white. The SuperStar Sequencer simulates this color shift, but to do so it must “dim down” the settings that are 100 and below in order to support simulation of the colors that are at 100 and above. Realize that even though the colors on the screen are “dimmed down” the colors on the Cosmic Color Ribbons will not be dimmed down.

• Go Back to Balanced Color Mode
When going back to Balanced Color Mode the SuperStar Sequencer advises that any settings greater than 100 will be automatically adjusted down to 100. Note also, that after going into Balanced Color Mode, the next time you click on a color control a warning box may appear that says, “Enter an Integer between 0 and 100.” This is a bug and will be fixed in the future. Click Ok on the warning box, if another warning immediately appears, click “Ok” on that box also. The warnings are bogus and can be ignored.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...