Jump to content
Light-O-Rama Forums
  • Announcements

    • DevMike

      1/18/2018 - LOR has resumed operations after the fire   01/17/2018

      As of 1/18 we have resumed operations.  On 1/16 a fire occurred in the same building that houses the main LOR offices and manufacturing.    More information can be found in 'Important Announcements'.    
Sign in to follow this  
hoosierdoc

Pixie4 testing in hardware utility, only first pixel is on

Recommended Posts

bought the 12v 100-pixel string from the LOR store. I am using a 12v power supply that is working fine. The pixie board syncs to the utility fine. I have it set as ID2. No matter what setting I choose in the pixel console or config, I can't get anything to happen other than the first pixel is on and blue.

Based on my prior post about how to wire it, I have it wired correctly I think, assuming the middle "data" cable goes to the DT connector on the pixie controller.The wires on the strand connect to the controller using the standard male/female screw in connector supplied by LOR.

I'm stumped, any ideas? Hopefully just a setting I've messed up somewhere.I have the basic software license but LOR said I should still be able to test the strand with hardware utility.

 

Update: one prong on my male/female screw connector missed. I redid that and it's working now. Yay. When I use the "test" panel in LOR Control tab in hardware control all the lights work. But when I go to pixel console only the first 50 work, despite me telling it there's 75 pixels per port. Hrm.

Also, "yellow" is rather "Green". These are LOR pixels. Is there some sort of "white balance" that needs to happen? "white" is rather "blue" also.

Edited by hoosierdoc

Share this post


Link to post
Share on other sites

Did you configure your Pixie in HU?

In the Config, then click Cosmic color/Pixie config.  There you describe your string type  (all strings must be the same type)

Now try the HU, and run Chase, tick RGBW. that should run through the lot

Share this post


Link to post
Share on other sites
33 minutes ago, TheDucks said:

Did you configure your Pixie in HU?

In the Config, then click Cosmic color/Pixie config.  There you describe your string type  (all strings must be the same type)

Now try the HU, and run Chase, tick RGBW. that should run through the lot

I think I did. Here's what I am seeing on config. Then on pixel console I am telling it I have a pixie, but only 50 pixels are showing up there.

Update: I changed "channel mode" to CCD EXtended Circuit IDs" and now I can see all 100, even though I'm only using 75 and all the lights turn on. Yay.

This is weird though. I hit "controller red on" and the first 50 are red, then three are off, then the next 21 are green. ARGH.

I hit all off, then "controller green on" and first fifty are green, then three off, then next 21 are blue. ARGH.

When I tell it off, then "controller blue on", everything is blue except last 21 that are red, then the first 50 turn red and last 21 are blue.

what the... I think I just need to try running a sequence and see what happens

 

issue5.png

Edited by hoosierdoc

Share this post


Link to post
Share on other sites

FYI....  It's my fault.

The Pixel Console in the HWU is a little 'off' when it comes to new Pixie 2s (IE, CCR2/CCB2/CCP2).  Old style CCDs even when running at 100 pixels (extended unit ID mode) still had macro channels between channels 151 and 160 (old CCDs in extend mode are actually 320 channel devices, not 300).  

Somewhere along the line the Pixie firmware guy neglected to tell me that the New Pixie based controllers do NOT have those channels when in 100 pixel mode.  All I knew was that new CCR2/CCB2/CCP2 was a direct replacement for the originals.  I assumed that new Pixie based CCDs would in fact still use dual normal when we turned on 100 pixel support (meaning a Pixie based CCD would actually consume 4 unit id's.  One for each 50 pixel segment.  Maybe better to call it 'Quad Normal'?).  It was a logical assumption, but when the firmware guy is one of the owners it's your mistake, not his :).  

So what happens currently in HWU when you press one of the buttons in the Pixel Console, the first 50 pixels are going to be the correct color.  The HWU then skips channels 151-160, and starts turning them back on with channel 161 - since it is trying to skip those macro channels.  It believes that channel 161 is the R of Pixel 51.  In Pixie based CCDs that is NOT the case.  161 is actually the G of pixel 54.  Now all the colors are 'off by one' so to speak.

 

Share this post


Link to post
Share on other sites

Weird.  My brand new Pixie2 and dual 50 node strings worked fine.  Solid color, chase, everything.

 

Edited by jtomason

Share this post


Link to post
Share on other sites

50's will work without a problem.  It's the 100's.

16 hours ago, jtomason said:

Weird.  My brand new Pixie2 and dual 50 node strings worked fine.  Solid color, chase, everything.

 

Share this post


Link to post
Share on other sites
41 minutes ago, DevMike said:

50's will work without a problem.  It's the 100's.

 

I figured two 50's in series would be the (electrical and addressing) equivalent of a single 100 string...  Am I wrong?  

Share this post


Link to post
Share on other sites

Sorry my mistake.  Yes, 2 x 50 on a single port are 100.

You may not be looking in the same place as the OP.

Share this post


Link to post
Share on other sites
8 minutes ago, DevMike said:

Sorry my mistake.  Yes, 2 x 50 on a single port are 100.

You may not be looking in the same place as the OP.

Dunno.  Didn’t have to mess with it..  Connected, ran the HW utility, selected the chase, verified that each node was working, and broke it all down for assembly in the show.   I used the flat nodes; perhaps that’s the difference somehow?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×