Jump to content
Light-O-Rama Forums
Snow

CMB-16D

Recommended Posts

Hello all,

I have just completed my first 128 channel display, I have one CMB-16D controller to drive my DC circuts. When I run the sequence all the channels form 1 - 8 or 9-16 all turn on at once. I cant sellect each channel individually via the sequence editor or the hardware controller.

Any help would be greatlly appreciated as I am a newbyy to this...

Snow - Brisbane Australia

Share this post


Link to post
Share on other sites

Check your wiring. The DC card has common +ve connections; ie on the board itself, all the +ve connections in each bank of 8 are wired together. The switching and controls are done on the -ve connections.

If you need further help, feel free to PM me your contact details - I am in Brisbane and use the LOR DC boards extensively.

  • Like 1

Share this post


Link to post
Share on other sites

If you have a 2nd generation board (the transistors have metal heat sink tabs on them), and you have the added heat sinks, you MUST have insulating kits between the external heat sink and the metal heat sink tabs on the transistors. If you don't have the insulators, you will get exactly the problem you describe.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...