Jump to content

Feature Request - Sequencer, Copy then Paste Special Option


dgrant
 Share

Recommended Posts

At this instant, I'm working on a new sequence and just thought it sure would be nice to copy and paste to match to another channel or in my case, the beat channel. Instead of spending a lot of time doing it manually, then too, possibly select a half-beat. Its just a fast thought as I know of no other way to accomplish this. Using the paste all the way to the end, never lines up for unknown reasons and I can never get the beat wizard to figure itself out. LOL, I'm sure I'm using it somehow wrong, but it just will not sync to the music and yes, I've tried it many times, many different options.

Link to comment
Share on other sites

17 minutes ago, dgrant said:

At this instant, I'm working on a new sequence and just thought it sure would be nice to copy and paste to match to another channel or in my case, the beat channel. Instead of spending a lot of time doing it manually, then too, possibly select a half-beat. Its just a fast thought as I know of no other way to accomplish this. Using the paste all the way to the end, never lines up for unknown reasons and I can never get the beat wizard to figure itself out. LOL, I'm sure I'm using it somehow wrong, but it just will not sync to the music and yes, I've tried it many times, many different options.

If I'm copy and pasting entire rows, then I set the selection mode to "Rows". Makes selection much easier.

https://www1.lightorama.com/downloads/5.6.8/help/selecting_cells.htm

Link to comment
Share on other sites

14 minutes ago, dgrant said:

I do the same but it never lines up with the beat beyond a few seconds

If doesn't that is a bug. Which paste mode are you using?

Link to comment
Share on other sites

The beat wizard gets confused in some parts of some songs. When I use it on those songs, I have to clean up the timing marks manually, but the beat wizard still makes the whole process a lot faster.

The first thing I do when starting a new sequence is getting the timing marks to match the beat. After that, copy/paste just works.

  • Like 1
Link to comment
Share on other sites

Thanks Steven. I decided to try your option and re-did all of the beats. It seemed to work better and for pasting, switched to paste by cell.

Link to comment
Share on other sites

4 hours ago, dgrant said:

I use copy by Time.

That's your trouble. When you use "paste by time" with "all the way until the end of sequence", a small difference in the length of the copied material (a rounding error) will start adding up until it's off a beat.

There has been a solution to this problem since S2. Use a timing grid with timing marks set to the beat (using the beat wizard, tapper wizard, or with manual adjustment) and then use "paste by cell". Now everything lines up nicely with the beat.

If you prefer sequencing with a .05s timing grid, there's a solution for that as well, you can instantly switch between your "beat" timing grid and your fixed timing grid.

Link to comment
Share on other sites

Posted (edited)
16 hours ago, MattBrown said:

If doesn't that is a bug. Which paste mode are you using?

Yeah Matt, I think someone needs to look at the Beat Wizard. For me, trying to get it to sync to the music is nothing but a pain in the posterior. Example, the song "Sleigh Ride", it needs to be scanned at 2X slower speed, but then it will not assign those beats to a beat channel. Instead, it assigns a much larger area of cells. Yes, the setting was defaulted to 4 beats. Lowering it to 2 helps but still not right and of course 1, doesn't work. Selecting paste by time or cell, makes no difference or appears to not make a difference. I have more luck with the tapper wizard. Different songs, different settings of course but it never seems to work based on what it thinks to what we hear.

 

Oh yes, number of beats, if you select 0, it crashes the sequencer completely

Edited by dgrant
Link to comment
Share on other sites

6 hours ago, dgrant said:

Oh yes, number of beats, if you select 0, it crashes the sequencer completely

I have verified that bug: Repeat by:

  1. Tools -> Beat Wizard
  2. Select "Turn on the selected beat channel every so many beats"
  3. Set "This many beats" to 0
  4. Click "Apply"

This puts the Sequencer into "Not responding", while it keeps allocating more memory until it is killed.

You may ask "Why would anyone set 'This many beats to 0'?"

I have 2 answers for that:

  1. Because you can.
  2. It hard to make idiot-proof software because idiots are so ingenious.
Link to comment
Share on other sites

I was just trying anything and everything to see what might or might not work. As long as the beat wizard has been around, I would think LOR would have taken another look at it. I simply want a beat mark at the significant beat timing and possibly a half-beat. The preview function of the wizard does indeed detect the correct beat but what it finds, applying it, does not result in the marks in the correct places.

Link to comment
Share on other sites

3 hours ago, dgrant said:

I was just trying anything and everything to see what might or might not work.

Try these steps. They work well for me:

  1. Tools -> Beat Wizard
  2. Check "Insert timings into the selected freeform grid for each beat"
  3. Next to the grid name, click "Add".
  4. Give it a name like "Basic Beat".
  5. Apply and Exit

When "Basic Beat" looks good, go to the timing menu in the Sequencer and select "Duplicate to New Freeform Grid". Name this grid "Half Beat".

Select the "Half Beat" grid, click in a cell, and select the entire row ("r").

Right-click -> Timing Mark -> Subdivide Timings.  Enter "2" and click "Ok". Now you have one timing grid with beats, and another with half beats.

Link to comment
Share on other sites

I appreciate your time to set all that out and I did learn from you. I think it should be way easier to do. In this image, all a programmer needs to do is make those little boxes, create the same frequency into the specified Beat Channel. Those little boxes work just fine and display the beats desired but that's not what is shown on the beat channel when applied.

 

spacer.png

Link to comment
Share on other sites

On 7/13/2022 at 8:26 PM, Steven said:

I have verified that bug: Repeat by:

  1. Tools -> Beat Wizard
  2. Select "Turn on the selected beat channel every so many beats"
  3. Set "This many beats" to 0
  4. Click "Apply"

This puts the Sequencer into "Not responding", while it keeps allocating more memory until it is killed.

You may ask "Why would anyone set 'This many beats to 0'?"

I have 2 answers for that:

  1. Because you can.
  2. It hard to make idiot-proof software because idiots are so ingenious.

This will be fixed in the next release. Thanks for the report.

Link to comment
Share on other sites

Well, the "0" for the number of beats has been fixed. The rest of the beat wizard is the same as before.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...