Jump to content

trying to get a pixicon 16 mkII 1.0 to work


Thebug
 Share

Recommended Posts

so i grabbed this controller several years ago in a spring sale and finally have the time/money this year. SO i went out bought a cheep router that i will run my DMX stuff on.  so I turn the wi-fi off on my computer hook up cat five to the computer to the router and then to the pixicon and glorious day i can configure it.  I run the color test and bloom I can make it go RGBW yahoo.  so i create a 30 second animation sequence to make sure i understand s5(switched this year) and how rto make pixels drive through DMX. so i create a preview of the pixel matrix. 

preview dmx setup .jpg

 

i then made a "show" and went to do a show on demand and i get an error. open serial port has failed  

 

 

error message .jpg

 

any ideas? 

 

 

Edited by Thebug
Link to comment
Share on other sites

Assuming your matrix is 75 pixels wide by 40 pixels high, and you are feeding it from the top, that is fine.  Personally I would change the Max Channel from512 to 510.  Not all pixel controllers can handle having a single pixel split between universes.  I don't know off hand if the PixCon 16 can or not.  It's also easier for us humans to understand.  Some people prefer to use a separate universe (or in your case two universes) per string, but it is not required and in your case wastes a lot of bandwidth.  Again, that is only to make it easier for us humans to understand.  I have been running E1.31 since 2012 and have done it both ways (generally hardware required one way or the other).

 

Link to comment
Share on other sites

To truly help you, we need to see a screenshot of your DMX Network Configuration screen.  My guess is since you are just starting to use DMX, you have the adapter assigned to a LOR Network and not the DMX universes.  You first need to unassign it from the LOR Network before you can reassign it to the DMX universe.

Also, if you are using the LOR USB485B adapter, then the protocol must be raw DMX.

Other than that, when you go to play your sequence, if you have other LOR networks in your show, you have to disable (uncheck) those com ports in the control lights tab in the lower right (if I remember correctly).  In S4, it didn't matter, but in S5, you will not be able to play those sequences if the com port is not available live.

Those are my guesses.

Link to comment
Share on other sites

I see you added the additional screen capture.  Your problem is obvious.  You don't have the DMX universes set up in Network Preferences.  I am going to assume that you are trying to use the Pixcon16 in E1.31 mode.  If that is the case, you will need to set up the Ethernet settings in Network Preferences.  Also you would be connecting to the PixCon16 via the silver Ethernet jack rather than the black RS-485 jacks.  On the computer end, it would connect to the Ethernet connection on the PC (either directly or via a switch).

 

Link to comment
Share on other sites

 

 

i have a cat 5 cable from my computer attached to the network port to an old router i had laying around. and then another cat 5 cord running and to the metal port on the controller. there is nothing connected to the internet port on the router  

 

Edited by Thebug
Link to comment
Share on other sites

6 hours ago, BluMan said:

To truly help you, we need to see a screenshot of your DMX Network Configuration screen.  My guess is since you are just starting to use DMX, you have the adapter assigned to a LOR Network and not the DMX universes.  You first need to unassign it from the LOR Network before you can reassign it to the DMX universe.

Also, if you are using the LOR USB485B adapter, then the protocol must be raw DMX.

Other than that, when you go to play your sequence, if you have other LOR networks in your show, you have to disable (uncheck) those com ports in the control lights tab in the lower right (if I remember correctly).  In S4, it didn't matter, but in S5, you will not be able to play those sequences if the com port is not available live.

Those are my guesses.

 

network preferances .jpg

Link to comment
Share on other sites

6 hours ago, k6ccc said:

I see you added the additional screen capture.  Your problem is obvious.  You don't have the DMX universes set up in Network Preferences.  I am going to assume that you are trying to use the Pixcon16 in E1.31 mode.  If that is the case, you will need to set up the Ethernet settings in Network Preferences.  Also you would be connecting to the PixCon16 via the silver Ethernet jack rather than the black RS-485 jacks.  On the computer end, it would connect to the Ethernet connection on the PC (either directly or via a switch).

 

 

ive run out of space to upload the pother screen shots so here is a link to the

DMX network settings https://photos.app.goo.gl/K1fbWinuHrrdEBst6

pixicon  network settings https://photos.app.goo.gl/KbhT77hWuBEM6T5H9

pixicon pixel port setup https://photos.app.goo.gl/h5bCYVPBtkjbnsvA8

Link to comment
Share on other sites

7 hours ago, BluMan said:

 if you have other LOR networks in your show, you have to disable (uncheck) those com ports in the control lights tab in the lower right (if I remember correctly).  In S4, it didn't matter, but in S5, you will not be able to play those sequences if the com port is not available live.

 

this is for my Halloween show and its just going to be on the pixel matrix. I went in and set the LOR regular network to none and my test animation sequence worked yahoo!!! however come Christmas time I'm going to wat to run traditional AC Christmas lights through the LOR network as well as the DMX so now I'm confused as to what i need to do to run both at a later date. or is it becasue there are no AC lights in the preview or sequence it confused it? 

 

Link to comment
Share on other sites

Your channel arrangement in the Pixcon16 do not come close to matching the channel configuration in the Preview Editor.  You would be better off to edit the Preview to match the Pixcon 16 (noting that the Max Channel is either set to 510 or that's the only way the Pixcon16 operates).

The Pixcon16 is configured for DHCP, so it (and presumably your PC) are intending to get IP addresses from the router.  That will work, but In the long run, you would be better off to use static IP addresses for both the PC and the Pixcon16.  I would also HIGHLY recommend that you use unicast (shows as "specify" in Network Preferences) rather than multicast - however at least for testing, the multicast should work.

 

Link to comment
Share on other sites

14 hours ago, Thebug said:

this is for my Halloween show and its just going to be on the pixel matrix. I went in and set the LOR regular network to none and my test animation sequence worked yahoo!!! however come Christmas time I'm going to wat to run traditional AC Christmas lights through the LOR network as well as the DMX so now I'm confused as to what i need to do to run both at a later date. or is it becasue there are no AC lights in the preview or sequence it confused it? 

 

Awesome!  Here's what I mean with S5.  IF your sequence has multiple networks (like traditional LOR and DMX), when using the sequence editor, unless those networks are physically available at the time you test them, you will get the error your seeing that it can't play it back because a certain com port is not available.  To get around this, in the sequence editor, on the right hand side is a tab called "Control Lights" or something very similar to that.  In that tab, it will list all the com ports that certain sequence uses.  If you want to test the DMX only, you will simply uncheck the checkbox on all the other com ports and then it will play.  You don't need to change your LOR network to none because if you forget to put it back, you will not have lights working on those networks and you'll be pulling your hair out then.

This particular unchecking of currently unused com ports is different than it used to be in S4.  Again, at least I think so.  haha!  Well, no matter what, you have stepped forward enough to know that the lights work. 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...