Jump to content

Configuration Channel/Prop Export/Import Mass Rename


Recommended Posts

13 years of S2 thru S4. Now need to morph my brain to S5 🙃.  I have in the past exported S4 Channel Config, hand changed names in mass and imported the changes. At the moment I'm a challenged S5 newbie. My challenge today is to do the same but in in S5.  I've tried the Grid Configuration > Export, made my changes to the names of the props (LOR Reg not RGB yet) then imported using same method. The names are not updating. What am I missing? 

example change  "Unit 01:01" to "H1.0.0.1_Tree 13ft - R"  "Unit 01:02" to "H1.0.0.2_Tree 13ft - G"  and so forth...

I looked around at the Preview but didn't see anything there mentioned in another thread.

Link to post
Share on other sites

I did the Grid Configuration since I saw the Export and Import. Not really seeing that in the preview as in export the entire xml, edit and then import the changes.

 

Link to post
Share on other sites

Sounds like you exported the grid configuration when you needed to export the preview. Go to your preview in the right hand popout tab and right click - fourth option down is "Export." You can also select it (again in that right side popout) and click the icon with the left facing green arrow. However, you really shouldn't have to export the changes unless you're switching computers. Any sequence that references that file will have the changes.

  • Like 1
Link to post
Share on other sites

Gotcha...  I did this a couple times. My mistake is not scrolling to the right far enough using Notepad++. The old file export put the channel names right at the top. The preview export adds the prop name way to the right.

Thank you for the reply and help.  Off to my next challenge...  I'm creating 450+ Props to cover my migration to S5 and creating groups to cover things like 13ft trees with 18 channels.  ;)

Link to post
Share on other sites

Just a quick followup... I had the same issue popup again. I'm finding editing a Prop multiple (lots) times to get them to fit a proper shape is perhaps ghosting and making the prop not work. Exporting the Preview rename the old one then importing the exported Preview did not fix the problem. However deleting the problem Prop saving and rebuild the prop does fix initially. Did find that building and editing a Prop multiple times using excel to model the prop, copy the text/cell pattern from excel to the prop is so much easier. Just need to edit using the excel model to make the adjustments, then go to the Prop select all and clear (this is the key), adjust the width and height if needed and then copy from excel and paste into the Prop. I did this on several Props, no ghosting, no issues (so far). Here's an example of the what I was trying to do...  The AC Icicle lights, one chn (Prop).   Thanks again Aubrey for the feedback and mentoring.    👍      53 Props complete, 400ish to go - and how long til Nov 3rd Day 1 of Xmas display build...  👀

839204540_2021-02-2009_18_09-Window.png.56a7b7b8baa3531b994916ba1f5cc20a.png

Link to post
Share on other sites

In the main preview tab, check out the "bulb" shapes - that might solve some of your issue, as will grouping props together before making height/width adjustments. Very curious how you are building props in excel though! Can you share?

Link to post
Share on other sites

Custom & Advanced props actually use an Excel Grid - the .lpeprop is a .xml file

Link to post
Share on other sites
7 hours ago, Aubrey said:

In the main preview tab, check out the "bulb" shapes - that might solve some of your issue, as will grouping props together before making height/width adjustments. Very curious how you are building props in excel though! Can you share?

Matt helped a friend out by sending him a spreadsheet that he was able to import in to the custom grid configuration.

I also didn’t know that but I am not an avid excel user.

I prefer just using a picture and filling in the node values. I’m just used to it.

JR

Link to post
Share on other sites

I didn't know about the importing of excel, hmmm learned something ;) . I was creating the shape I needed then copied the text from Excel in to the Prop grid. Something I learned from a youtube video when I was checking out xlights which was continuously crashed on me and was slow to perform on my computer. 4 weeks and no props made 😪😭😥 and no migrated Vis so I have no backup if needed. My computer is built for gaming so it was more a application issue. So far LOR hasn't crashed and doing great - 60 props in 3 days ☺️ and I have a S4 Vis preview if needed 🧐.  Also did the picture method when I built my 52in Tomato Cage trees with 4 props nested. Each Prop different color to get the Red, White, Blue, Green. Oh ya I still used excel to get the cell color where I want, grab a snippet and used the same pic for each prop. My display has lots of shrubs with 2-4 channels on each so nesting or grouping props is a must in my world. This is an example of one Icicle string mapped in Excel. Here 1 added the line to get a reference. The yellow is the number of columns and rows so I know how big the prop needed to be. I just select the cells in white, copy then paste into the Custom prop. This is a single string or channel prop. You can do the same for RGB but I'm not there yet. That will happen after I get my 40 sequences migrated. Yes 40...  25 Halloween and 15 Christmas. 😅🤣😂

image.png.7f771899331c2a09a3ef6654eae00ae2.pngimage.png.5b4d1738d24a8dffabc7399f128badbe.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...