Jump to content

False input triggers


Recommended Posts

Hello, been using input triggers for a few years on gen3 controller and it works correctly most of the time.  Occasionally I get a false trigger. The first year of testing using a trigger I got a lot of false triggers but putting a capacitor between the input pin and ground virtually eliminated false triggers except on very rare occasion. I currently use two buttons and two relays to two inputs in the controller to eliminate long wire runs inducing stray interference to the inputs but have noticed a false trigger at least once..  I don't use the LOR header but was wondering if using one may solve the problem. I was hoping someone would tell me what the chip resistors on the header board are for and do a little tracing to see if the resistors may be pull up resistors. From the stock photo the resistors look like 10k and was wondering if they were connected to the inputs and the +5V pin or maybe they are in series with the input pins. I would think if a pull up was needed it would be on the controller board. So if anyone could do a little reverse engineering on the header  board and post a schematic that would answer my question.

Thanks for any help,

Larry

Link to post
Share on other sites

do you have false triggers when a relay is triggered or the button is pushed?. if you have relays that share any common connection (ground or supplied voltage) it could be a back EMF issue. try using a fly-back diode on relay coils. i typically use a 1n4007 on all relay coils. it gets installed so the anode is on the negative side and the cathode is on the positive.

Link to post
Share on other sites

I don't have false triggers right when the buttons/relays are triggered. I had false triggers about three minutes after a button is pushed. Three minutes into show 1, show 2 started to play. I have two relays that share a common and the supply to the relays via the buttons are separate from the controller. I think the relays have the diode built in but I'm not sure, I will definitely check.  I have some spare relays to retrieve p/n and check the data sheet.

I only had two false triggers one night so I may wait until the end of the season to check that I observed the correct polarity, that is if the relays do in fact have the diodes.

Do you think it's still possible to have a fly back issue three minutes after a relay is  de-energized? 

Thanks for your help

Link to post
Share on other sites
10 minutes ago, butlerlj said:

I don't have false triggers right when the buttons/relays are triggered. I had false triggers about three minutes after a button is pushed. Three minutes into show 1, show 2 started to play. I have two relays that share a common and the supply to the relays via the buttons are separate from the controller. I think the relays have the diode built in but I'm not sure, I will definitely check.  I have some spare relays to retrieve p/n and check the data sheet.

I only had two false triggers one night so I may wait until the end of the season to check that I observed the correct polarity, that is if the relays do in fact have the diodes.

Do you think it's still possible to have a fly back issue three minutes after a relay is  de-energized? 

Thanks for your help

Back EMF is the property of an inductor resisting change (of state).  Release can generate the spike. Note relays WITH catch diodes have POLARITY markings  that must be observed or you will basicly apply a short (the diode is forward biased instead of blocking) when applying power.

Link to post
Share on other sites

the fly-back aka 'free wheel' voltage spike from a relay would be immediate. but they are common on the the collapse of any inductive load. motors. some LED's and strobes can cause the same issue. since you said the capacitors helped shows that there is something creating noise. there is another option. in the software you can change your trigger state from normally open to normally closed and use the normally closed relay contacts. this should be an easy fix and help with any noise issues since there will be a path to for any noise on your lines. also check if the lights you have are dimmable. 

Link to post
Share on other sites

Thanks D, I had thought of doing the normally closed relays but was thinking I needed to keep the relay energized but until I read your reply I didn't think of using the normally closed contacts, doh!

Link to post
Share on other sites

The first part of the sentence should have read, I had thought of using normally open contact with an energized relay.

Edited by butlerlj
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...