Jump to content
Light-O-Rama Forums

Comm Port Error


Recommended Posts


I am using 5 LOR controllers and one Pixie 8 controller. I am using 2 seperate networks. The Pixie cotroller is connected through the red USB connector and the regular controllers connected with the standard black USB connector. Last year I ran my show on an older laptop computer and kept having issues with the show stopping during the run time or not starting at all and I was getting a comm port error. If I would change USB ports on the computer, things would be alright for awhile but eventually I would see the same issue again. As long as I kept swapping, USB ports I could keep it all going.
I wanted to rid myself of that worry this year and purchased a new laptop computer just to run the show on. I started Lights on Thanksgiving evening and have run them every night since then with no troubles until last Thursday night. I was out of town and my son called me and said the lights were not working. The control panel showed that the schedule was enabled but nothing was working. I had him try to disable the show but he was unable to get it to disable. I had him shut the computer off and restart it and when it came back on the show started.

Last night the show did not start and I expierenced the same issues but got an error that said that the comm port was already in use and If I had the Hardware Utility open, I needed to close it. I did NOT have the Hardware Utility Open. I tried shutting the computer off and restarting it a couple of different times but got the same message. I finally unplugged the USB cable from the computer and plugged into anothe USB port and was able to run the scheduled show.

Tonight the show started as scheduled and ran for about an hour and then stopped. Again I was unable to disable the show. I unplugged the USB cable again and moved it back to the original port. Doing this did disable the show. I was able to restart the show and it is currently running normally.

Any Idea what may be causing this and a possible solution to my problem? Thanks in advance for any help.


Link to comment
Share on other sites

Check the show scheduler and ensure you don’t have an old show trying to start or stop. Yes it happens.

Check and ensure auto updates and all of that is set to check and run for down times and not during show times

Also - if you are using “save as” for your sequences you will have to reopen the sequence in SE, reattach the song , play it for a few seconds and then “save” if given the option. Do not use save as.

Show edition/ scheduler will skip any songs that do not have a media file attached. If all of your sequences were saved using save as and you built the show they would all be skipped and you can read that in the CL

Hopefully this helps a little


Link to comment
Share on other sites

Thanks for your suggestions.I will revisit everything. I still don't understand why it ran for days with no issues. Again I will look it all of everythig again! Thanks

Link to comment
Share on other sites

  • 2 weeks later...

Hmm I just installed S5 to learn it on another PC and I got it also. Nothing showing in Schedule. I am trying to rebuild my whole show from scratch since I learned several things. Never ran a show off it. It did have S4 and I was using it to make additional sequences. 

I actually thought about uninstalling and reinstalling. During install it said that HU was running etc etc but it wasn’t.

Link to comment
Share on other sites

  • The topic was locked
This topic is now closed to further replies.
  • Create New...