Jump to content
Light-O-Rama Forums

Board level Comm's problem....


a31ford
 Share

Recommended Posts

NOT a newbie at this.....  

tried both jacks, cable works on at least 2 other boards. 

Simply trying to set unit ID's on the 3 new boards I have (CTB16PC's) (kit)

2 of 3 work fine, 3rd light flashes correctly, tried a board reset, no comm's

swapped both 28 pin PAL and 8 pin 485 to another board, they work fine there.

put good board chips on this board.. problem is still there.

tested traces to 485 pins 4&5 from Cat 5, tested good to 485

tested D0 data trace from 485 to 4k7 resistor network R1, good, and from other side of same resistor to PAL. good.

something is not , but don't know enough about how LOR handles the 485 to PAL handshake other than the data line to PAL.

I know their is a couple of inhibit lines on the 485, so I'm assuming problems on the board, but without schematic.... :(

 

Anyone ?? 

Link to comment
Share on other sites

SOLVED !! 

1) I am using an original Serial to RS-485 adapter (the one with an actual 9 pin to cat5 connector).

2) 9 volts (10 volts latest releases) it appears that when using ONE board at a time to use HU to set board address, the adapter at the back of the computer uses the 9volt supply FROM THE BOARD, SO....if you have a board that is flashing correctly, BUT will not talk... check that you have 9-10 volts coming from the board. (mine was a bad 7810 regulator) I had a 7809 spare, replaced the 10 that came in the kit (old kits used a 7809), fired right up, and was able to set address and test boar OK.... WOOO-HOOO !!!!!

 

Link to comment
Share on other sites

Not that I have any expectation to ever use a serial to RS-485 adapter, but that is useful information to stick in the back of my mind.  There needs to be something to provide power to the adapter.  Makes sense that the adapter takes its power from the LOR network cable.  That could be a problem if either the first controller is a long ways away or is a controller type that does not supply power to the network cable.

One of these days, someone could pop up wondering why a network with a serial to RS-485 adapter that is only driving DC controllers won’t work.  Maybe I’ll remember this thread...

 

Link to comment
Share on other sites

  • Don locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...