Jump to content

Sequence/Mis-communication


BEC56
 Share

Recommended Posts

Problem: When I try to run any sequence they will only control (2) of (6) controllers. CTB16PCg3. All was well the past two seasons but this year not so good.

The only things I believe I have changed is the level of licensed software to the current 4.4.2 Pro. I upgraded the USB485B to the High speed (red) adapter.

I have tested all the Cat5 cables, they all test out fine. I have individually reset all the unit ID#s. Did this as a process of elimination.

While in HU I manually set comm port #6, only one available. When you refresh it, it locates all (6) controllers. You can test all controllers in HU mode and everything works great but when you active any sequence, show, show on demand controller 5 and 6 are all that will operate. Controllers 5 & 6 are not together at the end of the daisy chain. Chain goes 5-3-1-2-4-6

I know HU is basically a back door into the program. I exit HU , enable the schedule, blue light on and just 2 controller operate.

I used the sequence verifier to check a few. It originally showed a few errors that were common to all I checked. One recommended correction was to uninstall and reinstall the LOR program. Soooo I did this. Thought I might have accidentally cleaned something up I shouldn't have. After I reinstalled it I again verified a few sequences errors gone, (must have) all looks good now.

Past seasons the USB485B operated on comm port#3.

Firm ware version of the controllers 1-4 is 1.06 and 5-6 is 1.09

I know everyone's busy. When you get a chance, take a read and let me know if you have any suggestions.

Bruce

 

 

Link to comment
Share on other sites

If the HU is seeing the controllers, it suggests the Comm, Cables, and Connectors are all OK. Do they all have steady status lights when the HU is connected to them.

I would check my Sequence channel assignments. Sounds like an error in the ID's

Link to comment
Share on other sites

Status lights are steady when HU is connected to them.

I checked a few Sequence channel assignments. The pop up window (Channel Settings) show they are assigned to the specific channels. Device type,( LOR),Unit, Circuit, Network(regular). In that window there is a line that states Sequence, It shows blank and I do not have access to it.

Checked to make sure 5-6 matched 1-4 in the window and they do.

 

Link to comment
Share on other sites

Got it!  A little further research led me to the network, again. When I loaded the USB driver for the (Red USB adapter) it installed itself in the enhanced mode. The 2 new controllers have the newer version of firm ware. While in enhanced mode (if I understand it correctly) the signal runs in reverse. Took it out of enhanced and all is well.

I will have to upgrade the firmware in the other controllers. That's for a latter date.

Link to comment
Share on other sites

56 minutes ago, BEC56 said:

Status lights are steady when HU is connected to them.

I checked a few Sequence channel assignments. The pop up window (Channel Settings) show they are assigned to the specific channels. Device type,( LOR),Unit, Circuit, Network(regular). In that window there is a line that states Sequence, It shows blank and I do not have access to it.

Checked to make sure 5-6 matched 1-4 in the window and they do.

 

So, all the controllers are CTB16PCG3's ?  Because G2's won't play with them on a single network if you use Enhanced mode or speeds above 115K.

 You need to put them on another network (I assume, you still have the Black dongle).

It is fairly quick to adjust sequences once the cables have been rerouted. For each sequence in SE: Tools Channel configuration: Change controller (a button): Select from list) Change the network to what it should be (eg AuxA).  REPEAT for each controller.

Repeat for each sequence

Link to comment
Share on other sites

2 hours ago, BEC56 said:

While in enhanced mode (if I understand it correctly) the signal runs in reverse. Took it out of enhanced and all is well.

Glad you got it resolved.  Signal running in reverse when in Enhanced mode is not correct.  Let me explain.

The RS-485 electrical standard (what LOR is using) is designed around having multiple devices that are all capable of sending data onto the network.  While multiple devices can all send data, ONLY ONE can send data at any given time.  If two devices send at the same time, there is a collision and generally neither sender gets their data through.  This is very similar to coax based networks (for those of you old enough to remember those).  In order for that to work, the LOR Protocol requires that a device must first listen to see if the network is idle before starting to send.  In order for there to be idle periods, a sending device must stop sending at times.  It also means that a larger percentage of time is spent sending sync pulses and headers.  What the LOR Enhanced Protocol does is to change that to a one way network.  The computer or director sending data first essentially tells every other device to shut up and only listen.  Now there is no need for idle periods, and a lot of the overhead data is no longer needed.

 

Link to comment
Share on other sites

  • Don locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...