Jump to content
Light-O-Rama Forums

Please check Hardware Utility in 4.3.22 for us


Recommended Posts

I now have 2 separate reports that the Hardware Utility in 4.3.22 can’t reliably find controllers when using the refresh button, heartbeats not being sent, etc,  and that going back to 4.3.18 fixes the issue (this is one).  That does not make a lot of sense to me since all I touched was pixie testing between those 2 versions.  I didn’t touch anything with heartbeats.

Can you please fire up 4.3.22 attach some LOR controllers (pixies, CTBs, whatever you have that responds to the HWU), and try refreshing several times in 4.3.22.   Make sure the status LEDs on the controllers go solid as well.

I can’t duplicate the issue on my computer, so I don’t know if I just have 2 people that have something weird on their computer, or a real problem.

Report back here if you are successful or not, along with the version of Windows you are using.  If you do have a problem in 4.3.22, see if going back to 4.3.18 fixes the issue and let me know that too.

Link to comment
Share on other sites

Hey Mike.

I have just completed some  testing and I can confirm I am seeing comm port issues with 4.3.22. Windows 10 pro 64.

First let me say that I have been using 4.3.22 since it came out, for sequencing and playing shows on three cmb 16's and one cmb 24 plus three E 6804's almost daily with 0 issues  I had however not even opened the HU until I read your post, That was when the fun began.

Opened HU from control panel and was told the com listener had comm 3 said yes and the HU opened but still could not find com 3. (See attach 1) 

Closed HU down and ran a show on demand, Lights work.

Opened SE and played a sequence, Lights work. however the dialog appeared saying media could not be found ( attach 2)  Pressed OK and the sequence started with music anyway.

Uninstall .22 and deleted the X86 folder to be on the safe side and put .18 back on.

No issues controlling lights, with show player, SE or HU

Att 1



Att 2



Link to comment
Share on other sites

I can also confirm problems on my server - which is what is controlling my landscaping show.  I have been running my landscape lighting show ever since the day that 4.3.22 came out without any problems.  Below is a single line drawing of my LOR network configuration.  The AuxB network (blue line) is not used except for Christmas, so there are no controllers connected to it, but the USB-485-HS adapter is hooked up.  Also to be picky, CMB16D unit ID 12 is actually installed in the front door box and not the DC column as shown (it will be moving).  The computer is a Dell R710 server running windows Server 2012 R2 with all the latest updates.

When I did these tests, I was 26 miles away remoted into the server using VNC.  I was unable to see any of the controllers on my security cameras, nor in daylight could I see if any lights turned on, with one exception.  The relay in the garage box is a 12 volt relay that is powered by a 12V wall wart power supply that is in turn powered from the CTB08 controller unit ID 15, channel 08.  Across the relay coil is a four inch section of 12V 3 RGB strip with only the red LEDs powered.  I have a camera that can clearly see that LED strip.

For my tests, I unloaded LOR, and then started the hardware utility.  I started with Comm3 which is my Regular network and only has the InputPup connected.  I did a refresh on Comm3 a total of five times.  On the 1st, 2nd, & 4th refresh, there were no controllers found.  However on the 3rd and 5th, the InputPup was found.  After the 5th refresh, I selected the InputPup and then changed the test mode to Inputs and input #3 was showing tripped (it should since the sun is up).  Interestingly, I found that I could not select another Comm port for test when the Test Mode was set to Input.  After changing test mode to Output, I could select a different Comm Port.  This was repeated several times with the same results every time.

Next I changed Comm Ports to Comm4 which is my AuxA network.  There are five controllers on that network.  Four of those are downstream of the relay in the garage box, but the relay is normally de-energized which leaves the networks connected.I'm going to list the results from multiple refreshes:

1)  Found unit 11 only

2)  found Units 13 & 14

3)  Found unit 12 only

4)  Found units 13 & 14

5)  Found units 13 & 14
6)  Found units 13 & 14

7)  Found units 13 & 14

8)  Found units 11 & 15

Since I was finally able to see controller 15, I attempted to control the circuit that controls the relay while watching the camera.  I got EXACTLY the same error that Phil showed in his first capture except that it was Comm4 instead of Comm3.

9)  Found unit 14 only

10)  Found units 11, 12, 13 & 15

Again, I attempted to control channel 8 of controller ID 15 while watching the security camera.  Again, I got the same error message.

Lastly at 07:43:30, I exited the Hardware Utility and restarted the LOR Control Panel.

At 0745 - 0746 there is a show that runs that slowly pulses the relay (one second on, three seconds off).  I allowed that show to run and it did correctly.  The camera showed that the relay was energized correctly.





Since it's a little hard to read, The red line is Comm3 (Regular network) which has the InputPup (Unit ID 02).

The Green line is Comm4 (AuxA network) which has in this order: CTB08 (Unit ID 15), CTB16 (Unit ID 11), and three CMB16D (Unit IDs 12, 13, & 14).  both networks are properly terminated at the far end with 120 ohm resistors.  Both AC controllers are Gen3 (new from the 2016 spring sale), and the CMB16D controllers are about five years old, but have new enough firmware that they work on enhanced networks.


Link to comment
Share on other sites

I am also getting the serial port error and can't find any controllers in Windows 7.

Edited by Mr. P
Link to comment
Share on other sites

Thanks to everyone for the information.  With it, I did find an issue with 4.3.22.  We will be releasing 4.3.24 shortly (probably in the next day or two) to fix the issue.

If you don't need the HWU for now, just stay on 4.3.22 and then go to 4.3.24.  If you absolutely need the HWU, go back to 4.3.18 - that will mean giving up pixie testing, but it will allow you to configure units.

Link to comment
Share on other sites

12 minutes ago, DevMike said:

4.3.24 has been released and addresses this issue.  Thanks everyone!

Short answer - it worked.  Now the detailed answer and further detail on a bug I reported yesterday.  I did just like yesterday - I remoted into my server to test this.  Upgraded to 4.3.24, verified in SE that I had the update and registration was good.  then started HU and did a refresh about a half dozen times on both LOR networks.  The Regular network with only an InputPup was seen and correctly reported one input triggered because the sun is up.  My AuxA network correctly detected all five controllers every time.  Again because I was doing this remotely and it's daylight, I could only see that the indicator light for the relay that is controlled by controller 15, channel 8 was operating when viewed on my one of my security cameras.  However I cycled that one channel repeatedly and I could see that it was operating properly.  The server is a Dell R710 running Windows Server 2012 r2.

The one thing I did see that I had mentioned yesterday was that when the test mode was selected to test inputs, I could not select a different Comm Port for further testing.  This time I did a couple screen captures.  In this first one, I am in Input test mode (Red arrow).  The dropdown for Manual Select (green arrow) is greyed out and can not be selected.  Yes, input 3 being active (purple arrow) is correct because the sun is up.


In this second screen capture, the test mode is set to Outputs (red arrow), and the Manual Select dropdown (green arrow) is active.


I do not consider this to be a big deal, but wanted to document it since I noticed it.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...