Jump to content

Horizontal Scroll Bar Movement is Choppy


John
 Share

Recommended Posts

I recently updated my software to version 2.0.14 and noticed the horizontal scroll bar moves in a choppy manner when scrolling left and right with the "View Wave Form" visible or ON. If I turn OFF the "View Wave Form", the horizontal scroll bar works very smooth as it should.

The vertical scroll bar has no issues.

My Computer is a Pentiun-4 3.0 GHz / 2 Meg RAM
Video Card: ATI Radeon 9600 (AGP) with 128 Meg RAM
Display is Running: 1280 x 1024 60-Hz 32 bit color resolution
Hard Drive has 214 Gig Free

Changing the color resolution from 32 to 16 bit has no effect.
Changing the number of visible channels on the sequence editor has no effect.

When playing the sequence and "Move Grid With Play" and "View Wave Form" are enabled, the sequence screen and animation window will hesitate at the end of the sequence screen as it moves the window to the next visible part of the sequence. If the "View Wave Form" is turned OFF, there is no hesitation during play from one sequence screen to the next.

It does this with both MP3 and WAV audio files.

CPU Usage:
With the "View Wave Form" ENABLED and constantly scrolling right and left the CPU usage is between 50-53%.
With the "View Wave Form" OFF and constantly scrolling right and left the CPU usage is between 20-23%.

I searched the LOR S2 forum for a similar problem and came up empty.
Have you seen this before?


Edit: CPU Usage Details

Link to comment
Share on other sites

Additional Information:

I installed LOR version 2.0.14 on a Dell Precision Workstation-470 with an Intel Xeon processor running at 3GHz. The system has 2Gb RAM.
The video card is an NVIDIA Quadro with 256Mb RAM.
I still get the choppy horizontal scroll bar with this computer when the "View Wave Form" is turned ON.

As an experiment I started a new musical sequence with 4 channels.
The only thing on the screen are blank 0.05 timings and the "View Wave Form" is ON.
The horizontal scroll bar movement is choppy here also.
I tried this with a couple of different songs to be sure it wasn't something particular to that mp3 file. Like I said before I did experience this using a wav file also.

I also checked the horizontal scroll bar in LOR version 1.6.1 and found it to "slightly" hesitate with the "View Wave Form" ON but nothing like the hesitation in version 2.0.14.

This is just an update in case someone else has experienced this issue.


Edit: added version 1.6.1 information

Link to comment
Share on other sites

  • 2 weeks later...

Two weeks and 136+ views and no one has replied they have experienced this issue?
Give it a try with the "View Wave Form" On and then Off while scrolling the horizontal scroll bar back and forth.
Reply with your observations.

Dan?? Have you seen this issue.

I may switch back to LOR-I if this continues.
I have had two great years without a hitch using that version.

Link to comment
Share on other sites

Perhaps one thing that might help is changing the wave form to "half height" (via "Wave Form" on the View menu).

Link to comment
Share on other sites

I tested the horizontal scroll bar with the "View Wave Form" ON and changing the wave form options to "Fold Mode" | "Top Mode" | "Half Height" and they all act the same with the horizontal scroll bar being choppy.

Like I said previously, with the "View Wave Form" OFF, the horizontal scroll bar is smooth. :?

Link to comment
Share on other sites

  • 3 weeks later...

240+ reads and still no one has experienced this issue?

Dan - am I the only person expressing a concern on this?

I'm seriously considering going back to version 1.6.1
At least that worked without the choppy scroll bar.

Link to comment
Share on other sites

LightORamaDan

John wrote:

240+ reads and still no one has experienced this issue?

Dan - am I the only person expressing a concern on this?

I'm seriously considering going back to version 1.6.1
At least that worked without the choppy scroll bar.


I do not expect many people to chime in that they have the same problem because LOR II generaly runs smoother than LOR I and uses significantly less resources in many areas.

Something is obviously messing things up for you but it will be difficult to say what it is. Please send us (support@lightorama.com) a copy of one of your sequences and the audio file associated with it. Perhaps there is something "special" about them.

Dan
Link to comment
Share on other sites

  • 2 weeks later...

Are you running any anti-spyware or anti-virus software ? Those can really dog a machine and cause other programs to act like this. My laptop got so bad that I finally downloaded 'process explorer' from microsoft and then added in a column for disk i/o ... and then sorted processes by that column. I then found a couple real dogs that were killing my system performance. Ironically, I was short on memory and the virtual memory was killing me. So I bought a memory upgrade to 1.2x Gig and things were fine after that. You mentioned 2 Meg RAM ... I'm pretty sure you meant 2 Gig RAM ...

Link to comment
Share on other sites

taybrynn wrote:

Are you running any anti-spyware or anti-virus software ?
You mentioned 2 Meg RAM ... I'm pretty sure you meant 2 Gig RAM ...


I emailed Dan a simulation and audio file for his inspection.

I disabled my Anti-Spyware and the McAfee Anti-Virus Software and that had no effect on the performance.

You are correct about the RAM. That was a typo. It has 2Gig of RAM.

LOR support suggested I try the Video "Hardware Acceleration" from "Full" to "None" to see if that made any difference. That made no difference either.

Just for kicks I may try an NVIDIA video card and see what happens.
To me it really looks like a video refresh/update issue. It may not be LOR software at all. I'm using an LCD monitor running at a 60Hz refresh rate. I did try a 75Hz refresh rate but didn't see any noticeable difference in performance.

If I find a solution I'll be sure to report it back here.
Link to comment
Share on other sites

And you don't have any devices connected that could be doing constant communication with the computer? Do you have any USB drives or backup devices? Google desktop search (or other search that could be indexing ?).

Link to comment
Share on other sites

nope - nothing really running in the background on USB except the USB cable communicating with my UPS in case of a power failure to run a graceful shutdown.
There is a USB wireless mouse attached but don't think that could be causing the problem.
I still think it's video card related but I'm open to other suggestions.
Remember... this is an ATI AGP 8X video card. Not the newer PCIe.

BTW - I have been to Colorado and the Castle Rock area on vacation.
My wife is very impressed with Denver and the Colorado Springs area... especially "Garden of the Gods".

Link to comment
Share on other sites

Yes, the garden of the gods is a really pretty place. Castle Rock is growing fast ... growing pains. Boy, the real estate is so depressed right now ... you can get a 1 million dollar home for $600k

I know its a total long shot, but I've had a flaked-out USB mouse cause lots of problems for me in the past. Could you try a different mouse just to rule it out?

Link to comment
Share on other sites

  • 3 weeks later...

John wrote:

I recently updated my software to version 2.0.14 and noticed the horizontal scroll bar moves in a choppy manner when scrolling left and right with the "View Wave Form" visible or ON. If I turn OFF the "View Wave Form", the horizontal scroll bar works very smooth as it should.

The vertical scroll bar has no issues.

My Computer is a Pentiun-4 3.0 GHz / 2 Meg RAM
Video Card: ATI Radeon 9600 (AGP) with 128 Meg RAM
Display is Running: 1280 x 1024 60-Hz 32 bit color resolution
Hard Drive has 214 Gig Free

Changing the color resolution from 32 to 16 bit has no effect.
Changing the number of visible channels on the sequence editor has no effect.

When playing the sequence and "Move Grid With Play" and "View Wave Form" are enabled, the sequence screen and animation window will hesitate at the end of the sequence screen as it moves the window to the next visible part of the sequence. If the "View Wave Form" is turned OFF, there is no hesitation during play from one sequence screen to the next.

It does this with both MP3 and WAV audio files.

CPU Usage:
With the "View Wave Form" ENABLED and constantly scrolling right and left the CPU usage is between 50-53%.
With the "View Wave Form" OFF and constantly scrolling right and left the CPU usage is between 20-23%.

I searched the LOR S2 forum for a similar problem and came up empty.
Have you seen this before?


Edit: CPU Usage Details



I am having the same problem...with both 2.0.14 and 2.0.16 versions. I have a brand new Dell Inspiron 1520 lap top, dual processors (Intel T5550@1.83 GHz), 3 gigs RAM, nothing else running. With the Wave Form visible, updates are incredibly slow. The music plays well, but any scrolling is burdensome. While playing, when the curser reaches the end of the screen, by the time the screen updates, the curser is halfway through it. Even hitting the stop button has a 2-3 second pause before is works. Turning off the wave form solves the problem. I ran the same sequence with the same version on my desktop and it works fine. The beats I programmed on the laptop are in sync with the animation, but are early when played on the desktop. I am guessing there is a delay in the animation...

The sequence has three tracks and every once in awhile, the times won't line up. One track will be shifted to the right. The tracking cursor on that track runs with the track timeline and hence does not line up with the curser in the other tracks.

Now when I run an old sequence (and only 2 tracks) that has never been modified on the laptop...everything is good. But another old sequence...same problems. And turning off Wave Form fixes it.

Help!

RO
Link to comment
Share on other sites

I am also having this same issue. So much so that it causes very noticible skips in animation playback.

Larry

Link to comment
Share on other sites

Just to stay in the loop....
I have disconnected all USB devices and I'm running a standard PS2 keyboard and mouse with no difference in the choppy horizontal scroll bar so it's not a USB issue.

I have seen this problem with a blank sequence and just the music (mp3 or wav) file playing and the "View Wave Form" turned on so it appears that "View Wave Form" is the issue here.

As others have said it affects the update of the sequence screen as well as the animation screen.

I previously sent Dan at LOR an audio and sequence file for his engineers to evaluate.

Thanks to everyone for keeping us up to date on this issue!

Link to comment
Share on other sites

I wonder if this could be related to just Dell computers using some OEM version of a graphics card made just for Dell.

It this happening to anyone NOT using a Dell ?

Link to comment
Share on other sites

I started this thread and mine is NOT a Dell.
I made this computer from scratch using an ASUS motherboard, ATI video card, 2Gig RAM, DVD-ROM and hard drives..... etc.
The specifications for the computer are mostly in my first post.
I don't think it's Dell related.
It does this using an ATI Radeon video card with 128-MB RAM and an NVIDIA Quadro video card with 256-MB RAM.

I have tested this problem on three different computers and they all use different motherboard chip-sets so I don't see that being the issue.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...