Jump to content

error message:com port already open( Can't run show)


Randal Trecha
 Share

Recommended Posts

Randal Trecha

vista, using a usb485B adapter, I can get the LOR hardware to config the CTB16PC, it tests the lights and they work. I close LOR hardware and open LOR Sequence Editor. I open a sequence and try to enable shows and I get an error message. ""Shows can not be enabled because the comm port is already open, If the Light-O-Rama Hardware Utility is running,shut it down and then enable shows.

LOR Hardware was not running. " Shows are not enabled, nothing else is launched and no shows are scheduled. Tried to go back to Hardware but the port is already in use. Tried to launch LOR Sequence Editor 1st, before Hardware, and I can edit a sequence but when I go to enable shows it shows the same error. LOR Hardware was not running.

I tried scheduling a show and running it. The status dialog box said the show was running but the lights where not responding outside.

How can I get the sequence/show to run and control to lights?

Link to comment
Share on other sites

It sounds like the Hardware Utility did not release the com port on exit and could possibly be still running. Two things you can try are:

1) Bring up the Task Manager by pressing CTRL-ALT-DEL. Check the Processes tab for LORHardware.exe. If it is there, end the process and try again the Sequence Editor again.

2) Reboot, to free up the lock on the com port. After restarting, try using the Sequence Editor and don't run the Hardware Utility.

Link to comment
Share on other sites

Randal Trecha

Also I tried rebooting and launching LOR SEQ EDIT 1st and Got the same port 'error

Link to comment
Share on other sites

I guess my next question would be does the Hardware Utility remember which COM port you are using each time or do you need to Auto Configure/Manual Select each time you come into the Hardware Utility. My thought now is that the Sequence Editor is looking at the wrong port when it comes up.

Link to comment
Share on other sites

Richard Hamilton

I remember having this trouble last year. In my case, something happened where the wrong port got selected in the hardware utility. I changed the port by re-performing the "Auto-Configure" and it resolved the problem.

I recall something about the hardware utility being the source program where you configure the port you can use., and that the sequencer uses that setting. I may not recall the details, but I do remember the the port got misconfigured. This sounds like your problem based on your description and your response to other replies.

Link to comment
Share on other sites

Randal Trecha

The hardware config stays on com 4.

I don't have to reconfig when I refresh on "Select unit"

I only have 2 manual choices comm3 and comm4. After rebooting the auto config selects comm4 each time and the lights test well.

I reinstalled the LORsoftware also

Link to comment
Share on other sites

Randal Trecha

If I don't reboot and I try to auto reconfig in Hardware I get the following message: "Unable to locate the LOR port. Check that the controller is connected and that the power is on."

And they are.

Shows are not enabled

Link to comment
Share on other sites

Try going into the Sequence Editor | Edit | Preferences | Network Preferences and setting the Regular Network to com4 (or com3) and see if that works for you.

Link to comment
Share on other sites

Guest wbottomley

Randal Trecha wrote:

Task manager only shows LORTray not Hardware

Perhaps you have the LOR bulb icon in the system tray at the lower right hand corner? If you do, right click and click on "unload Light-O-Rama."
Link to comment
Share on other sites

Randal Trecha

Network pref was set to comm4 in Sequ Edit. No luck

Link to comment
Share on other sites

Randal Trecha

by the way, there is no Regular Network Area, only Light-o-rama, Dash and x-10.

Link to comment
Share on other sites

Randal Trecha

right click and click on "unload Light-O-Rama."

I tried and this didn't help

Link to comment
Share on other sites

Randal Trecha wrote:

by the way, there is no Regular Network Area, only Light-o-rama, Dash and x-10.

Sorry, I forgot that you are dealing with LOR 1.x. That is what it is called in LOR 2.
Link to comment
Share on other sites

Randal Trecha

Should this work to control lights?

Launch Sequ Edit. Select CONTROL LIGHTS from PLAY Menu Select a file Select PLAY

When I do this, the sequence plays on the screen but doesn't control the lights

Link to comment
Share on other sites

Randal Trecha

Should this work to control lights?

Launch Sequ Edit. Select CONTROL LIGHTS from PLAY Menu Select a file Select PLAY

When I do this, the sequence plays on the screen but doesn't control the lights

Link to comment
Share on other sites

Randal Trecha wrote:

Do i need LOR 2?

Need? Not necessarily. It could solve your problems or it could add another layer of onto your existing problem. Hopefully someone else will suggest something as I am out of ideas at the moment.
Link to comment
Share on other sites

Randal Trecha

Mountainwxman wrote:

Do you have any pda's or anything that uses a serial connection connected to the pc?

nothing else
Link to comment
Share on other sites

Randal Trecha

Mountainwxman wrote:

Do you have any pda's or anything that uses a serial connection connected to the pc?

i only use this laptop for LOR
Link to comment
Share on other sites

Guest wbottomley

I agree with Brad. Upgrade to version 1.6.15.

If you have any LOR applications running, please close them. Make certain to check programs running by clicking on control>alt>delete.

Link to comment
Share on other sites

I had this problem too.... It was not until I unplugged the USB cable controlling the lights and then replugging it in did it start working..... Rebooting did not help either...

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...