Jump to content

Control Panel Dilemma


Ron Boyd

Recommended Posts

I did as instructed several months ago, load LOR at startup along with the Control Panel/Comm Listener. For 2 months I had this running on 3 different computers.

 

Now comes the dilemma. For some reason I was using tons of data on my home internet connection. When I say tons, I mean 700+ Gb the first month and 900+ Gb the second month. This is something unheard of.

 

As I was going through to see if I could find where this problem lies. I came across a page within Win10, (I have no idea how to get back to it, somewhere in the network settings), that told me the Comm Listener had used a ton of data. I don't remember the exact number, but it was astronomical. Once I turned the Comm Listener off, my data for this month is just under 30 Gb of data, which is where it should be.

 

So, now to my question, should the Comm Listener be uploading to my network? Is there a way to have it, not do this?

 

If this is the way it needs to operate, I have no choice than to use a different show player this year. I will need the LAN for E1.31 and the wireless network for a show monitoring software, (Team Viewer, if I can figure out how to make it work). 

Link to post
Share on other sites

Ron, are you using unicast and do you have a separate nic for the E 1.31. I have a second nic in my machine on a different subnet so it is separated from the internet/wifi/ home LAN. Not sure why Comm Listener would be talking to the Internet connection. Any chance some malware is accessing the comm listener ports. Maybe try a Malwarebytes scan just to see. Just tossing out thoughts here.

Link to post
Share on other sites

What IP addresses do you have the Comm Listener set up to transmit to?

 

The Comm Listener does indeed use a ton of data, but it should be on your local network, not visible to your ISP.  It sounds like perhaps you're asking it to send to some computer that's not on your local network, and so it has to go through your ISP to get there.

Link to post
Share on other sites

What IP addresses do you have the Comm Listener set up to transmit to?

 

The Comm Listener does indeed use a ton of data, but it should be on your local network, not visible to your ISP.  It sounds like perhaps you're asking it to send to some computer that's not on your local network, and so it has to go through your ISP to get there.

192.168.1.101, 

192.168.1.102, 

192.168.1.103,

192.168.1.104,

192.168.1.105. Now, when I set up the PixCon16, the 192.168.1.102 (unicast) went away and was replaced with Multicast addressing, ie., 239.255.0.7 through 239.255.0.17

Computer IP is 192.168.1.xxx

Router is 10.0.0.x

 

All 3 Pcs are connected on my home network and files are shared through Dropbox and Onedrive.

 

I thought it strange too, that it was somehow going through the ISP. However, as stated above, when I shut down the listener, the data overload ceased.

 

 

Ron, are you using unicast and do you have a separate nic for the E 1.31. I have a second nic in my machine on a different subnet so it is separated from the internet/wifi/ home LAN. Not sure why Comm Listener would be talking to the Internet connection. Any chance some malware is accessing the comm listener ports. Maybe try a Malwarebytes scan just to see. Just tossing out thoughts here.

 

I keep all Malware, AV and all other programs up to date and PCs scanned.

 

This started when I was instructed to leave the Comm Listener running, instead of starting it when I need it. When I stopped doing that, and now just use it when needed, the Data went from ~30 gb/day down to ~1 Gb/day. This is more in line with what we actually use.

Link to post
Share on other sites

Not using a Pixcon so can't talk to that but I'm running the tray and listener 24/7 but it is on its own network card. Easy to do and its maybe 20 bucks. I can help you through it if you like.

Link to post
Share on other sites

Like Bob has said, the listener on a properly configured network, which includes your router(s) the computer(s) AND any other devices attached, consumes no data on your internet connection.

 

When properly configured, all those packets stay inside.  However if you have an improperly configured setup, those E1.31 packets are just trying to find their way home.  If your network provides no route for them, they go out the default gateway - which is going to be your ISP.

 

As we have said before, IP routing is a complex area and it is VERY easy (as you have discovered) for things to go out the wrong direction.  Unless you are well versed in IP routing/and networking it is best if you completely separate your lighting network from your home network.  

 

If you are positive that you had Unicast connections set up then your configuration was 'replaced' because the PixCon16 configuration offered to automatically create the configuration for you and you said yes.  You would also have been warned that existing settings were present and that continuing would overwrite those settings.  You would have again had to say yes.

Link to post
Share on other sites

For the last 2 years I have been 90% first and 100% second, E1.31. I never had this problem prior to S4. I have done nothing different than in passed years. I did not do anything different. I would prefer to run the Pixcon16 in Unicast mode. 

 

However, the data problem has been going on long before I got the Pixcon board. It's only been in my hands for a couple of weeks. My data problem started in July.

Link to post
Share on other sites

I don't know enough about the low level details of networking to have a really informed opinion, but I can't help but notice your router's IP address seems to be on a different network (10.0.0.*) than your computers and controllers and such (192.168.1.*).  Are you sure that that's proper? I can imagine that perhaps your router doesn't really think your local network is what you think your local network is, and so defaults to going through your ISP, or something along those lines.

 

What is your computer's routing table?

 

How about your router's?

Link to post
Share on other sites

Yeah, I had changed that today, however, I could not get hooked into the internet, so I changed back to auto. I'll have to do a little searching in Win 10 to find out exactly what it is.

 

I'm not quite sure what "routing table" is. I'm sure I know, but I've never heard that term before.

Link to post
Share on other sites

You might want to consider reorganizing your network along the lines Bob was sugesting. I would make my router/gateway 192.168.1.1 and turn on dhcp on all the pc's and let the router assign the IP's. Then we have to get the E 1.31 stuff sorted after that.

How many controllers are you running. Just the pixcon?

Link to post
Share on other sites

The issue isn't going to be the Listener - it's an improper network configuration.  We have seen this before with other customers.  This problem pops up if you are not experienced in IP networking.  When we say experienced, we mean more than just buying a router and following a wizard to complete the setup of it.  We are talking about knowing how routing actually works, how to subnet properly, what and how to set up a routing table, what metrics are, and a whole bunch of other topics that will be voodoo unless you have taken some serious networking classes.

 

Yes, it is the listener that is producing all that data and so turning it off will stop it from happening - while it is off.  But doing that is the same as cutting off your finger simply because you have a splinter in it.  You would have had the same issue in S3 if the conditions on your network were the same.  It may appear that S4 is to blame, but that is a coincidental thing to something else that has changed in your configuration or on your network (or both).

 

The Listener is simply trying to send packets to devices that you have said are on the network.  For whatever reason, your local LAN can't figure out how to get those packets to those devices.  When it can't figure out how to get the packets to a device (by using its routing tables), those packets go out the 'Default Gateway'.  Your default gateway is your ISP connection.  On the other hand, a properly configured network will know where those packets are supposed to go.  When it knows where they are supposed to go, they do NOT go out the default gateway.

 

The BEST thing you can do if you are not a network engineer is to completely separate your lighting network from your normal network.  A separate router is only $20 and it will prevent all these problems you are having.  We will be publishing a document shortly that describes how to best configure with E1.31.  The first thing it will tell you to do is buy a separate router.  Otherwise, one small mis-configuration and  you'll be right back to sending 30gb a day out your internet.

 

As for running the PixCon16 in unicast, I recommend that too!  However, you'll manually need to configure the universes in the Network Configuration program rather than allow the PixCon16 configuration to create it for you.  Update all the universes you need to update with the correct IP and you will be all set.  If in the future the PixCon16 configuration asks if you want it to automatically create the entries, say NO.

Link to post
Share on other sites

First of all I want to apologize "cuz" I'm NOT trying to hijack this thread but reading these posts have me a little concerned and

 

worried, I'm a Pixel newbe and I just finished up getting my Controllers & S4 & my wifi bridge & router and got everything working

 

and now is see you people who know whats going on, saying we should use another nic card in the computer. Could some one tell

 

me why this is necessary or could I get by with one card, guess I'm wondering what the pitfalls would be, and if I have to get another

 

card do I have to start all over setting everything up?  Maybe point me to a thread where I might find out.

 

Thanks in advance..............Sorry for being long winded.

Link to post
Share on other sites

What Mike is saying is have a separate network for your lights vs. your home network. That is different than having an additional NIC in your computer. In fact having two NICs in your computer also requires some IP savvy to avoid routing problems.

 

I use a laptop for everything. Surfing the web, sequencing and as my show computer. 

I have two networks.

(1) My home network with a router, and a CAT5 switch, and a router that goes to the Internet.

When I have my laptop on (1) I go to my network adapter's network properties and configure IPv4 to just use DHCP (get it's address automatically from the router)

(2) My light network, which is just a switch no router. Since E1.31 just bumps around on the LAN (layer 2) then there is no reason to have a router on this network.

When I want to play with my lights (2) I connect to the switch I use for (2) via CAT5 and I configure my network adapter's IPv4 to use a static IP (192.168.1.200/255.255.255.0) to talk to my pixel controllers, SLAN bridges, etc.

 

It means moving a cable back and forth and a couple of mouse clicks, but it keeps my home network clean of a chatty protocol.

 

*Change of subject*

 

When you have E1.31 devices configured, but they are turned off it seems that the comm listener is more aggressive. So a solution for this is to change your network settings. When I'm just sequencing and likely not on the lights network I have all my universes set to nothing in the network preferences. Then when I actually want to run the lights I load my network config in and have some fun. The newer S4 makes this possible since from the Network preferences you can import/export your network preferences. So I have one exported preferences set with nothing turned on, and another with all my universes configured. This seems to help with the chatty protocol too.

Link to post
Share on other sites

*Change of subject*

 

When you have E1.31 devices configured, but they are turned off it seems that the comm listener is more aggressive. So a solution for this is to change your network settings. When I'm just sequencing and likely not on the lights network I have all my universes set to nothing in the network preferences. Then when I actually want to run the lights I load my network config in and have some fun. The newer S4 makes this possible since from the Network preferences you can import/export your network preferences. So I have one exported preferences set with nothing turned on, and another with all my universes configured. This seems to help with the chatty protocol too.

 

Another excellent idea.

Link to post
Share on other sites

What Mike is saying is have a separate network for your lights vs. your home network. That is different than having an additional NIC in your computer. In fact having two NICs in your computer also requires some IP savvy to avoid routing problems.

 

I use a laptop for everything. Surfing the web, sequencing and as my show computer. 

I have two networks.

(1) My home network with a router, and a CAT5 switch, and a router that goes to the Internet.

When I have my laptop on (1) I go to my network adapter's network properties and configure IPv4 to just use DHCP (get it's address automatically from the router)

(2) My light network, which is just a switch no router. Since E1.31 just bumps around on the LAN (layer 2) then there is no reason to have a router on this network.

When I want to play with my lights (2) I connect to the switch I use for (2) via CAT5 and I configure my network adapter's IPv4 to use a static IP (192.168.1.200/255.255.255.0) to talk to my pixel controllers, SLAN bridges, etc.

 

It means moving a cable back and forth and a couple of mouse clicks, but it keeps my home network clean of a chatty protocol.

 

*Change of subject*

 

When you have E1.31 devices configured, but they are turned off it seems that the comm listener is more aggressive. So a solution for this is to change your network settings. When I'm just sequencing and likely not on the lights network I have all my universes set to nothing in the network preferences. Then when I actually want to run the lights I load my network config in and have some fun. The newer S4 makes this possible since from the Network preferences you can import/export your network preferences. So I have one exported preferences set with nothing turned on, and another with all my universes configured. This seems to help with the chatty protocol too.

This is what I originally thought I had to do. Wireless IP is in the 10.0.0.X range whereas, my controllers and LAN are on 192.168.1.XXX. I was told it wasn't that simple.

Now, I will need both wireless and LAN running during the show. If the LAN is on 192.168.1.xxx and the wireless is on 10.0.0.xxx, will this work at the same time? If not, I'll get a USB Nic card for this laptop.

 

I will also export the network config and then import when I need it.

Link to post
Share on other sites

Ok well obviously I'm not explaining it properly or I'm not understanding it properly.

I apologize for my non technical brain and not being able to understand.

I will go with plan "B" and not use S4 to run my show this year. I'll still use Superstar to sequence with but I'm done with this. You can delete the entire thread if you so desire.

Link to post
Share on other sites

Simple answer in layman's terms for those, like myself, who aren't network architects.

 

In the DMX network configuration, export the network config for your show, save it where you can find it to import back, then on each universe, select "Local".

 

Keeps all E1.31 network traffic on your PC.

 

When it's time for the show, import the original Network config back in.

Link to post
Share on other sites

Ron, please see the following from Wikipedia in regards to your issue… https://en.wikipedia.org/wiki/Private_network

 

… It is common for packets originating in private address spaces to be misrouted onto the Internet. Private networks often do not properly configure DNS services for addresses used internally and attempt reverse DNS lookups for these addresses, causing extra traffic to the Internet root nameservers. …

 

As others have pointed out, networking can be a very technical and complex concept.  Your home network appears to be 192.168.1.X.  Anything on the 192.168.1.X network will remain local (not hit your internet router/modem).  However once you move from the 192.168.1.X network (e.g. your 10.X.X.X), and that network does not currently exist, then the route the traffic will take, is the "default gateway" which is your ISP. 

 

If your show network is now trying to connect to the 10.X network, and it does not exist, although it is by definition "non-routable", It will still try to find it via the default gateway, which is your ISP.  When the data hits the Internet router/modem, although the traffic cannot go anywhere, it still uses data.  Assuming the LOR comm listener is always searching for the new network, this will continue until the listener is turned off, you add the network via an addition NIC (Network card), or subnet masking (more advanced). You could also block the traffic at your internet gateway/router firewall (again, more advanced), but can be done. 

FYI, the "preferred" method in networking is unicast (specific network addressing) which only send traffic to specific devices, vs. multicast, which send traffic to ALL devices. 

Think of this as sending out an email to a specific user (unicast) vs. a distrobution list or "CC:ALL" (Multicast). 

 

FYI, If anyone has any questions or needs assistance with networking issues, please feel free to PM me and I will try to assist where possible. 

Link to post
Share on other sites

I had a network friend come over this passed weekend. Here's what we found. First, it's still doing the same thing. He changed all kinds of settings trying to separate the wireless from the LAN. Nothing worked. When we would disable the wireless card, plug the Cat5e cable, the light on the modem/router settled down. As soon as we disabled the LAN and re-enable the wireless, the router light started hauling the mail again. Almost a shimmer instead of a slow flash, normally about 1-2 flashes per second. We even swapped IP addresses on the router and PC. Still the same.

So, I ordered another wired NIC card for the desktop. I'm going to use the desktop, run Cat5e from the new NIC, from upstairs down to the switch. From 10' to the switch to 100' to the switch. Should not be a problem, but a royal PITA. After it gets cold and the attic cools down, I'll get up there and run Cat5e from PC position out through the attic, out through the eave and try to hide the blasted thing as well as waterproof the connection when not in use.

This is my 5th year and have never had to do anything like this.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...