Jump to content

RGB strips not working


trini101
 Share

Recommended Posts

Hello new to RGB first time. I hook up all my RGB dumb strips to my controller then used a cat 5 from RGB controller to DC-MP3 show director cause I don't have a lap top computer. None of my RGB strips are working and I have no idea what to do next. Help Help

Link to comment
Share on other sites

Make sure that + is the common and the - is the R G B part.  If you have them reversed they wont work.

 

Also, depending on the controller your using, channels 1-12 need voltage to power the board.  If your input voltage is on the 13-24 side, the controller will not work unless you plug in the optional DC adaptor.  (assuming you are using an LOR 24 channel controller)  You can bridge the power connection.

 

As with all DC items + / - matters. 

Link to comment
Share on other sites

to test the strip connect Positive (5V or 12V which ever is correct  but make sure it is correct).  connect the negative to ONE of the Red, Green or Blue wires (then to the other two one at a time. if you connect more than one of the wires you will get color mixes).  The pixels should light up.  If they do correctly then look at the controller on setup, 

Link to comment
Share on other sites

I've suggested this before but it won't hurt to say it again. 

I find a 9V battery with wires soldered to the terminals an invaluable tool for checking 12 V Dumb RGB lights and connections without having to hook up a controller.

Just  touch the +ve to the + side and the negative to each color in turn and see if they light.

Keep it by your soldering station and check as you go.

Helps to narrow down where any problems may lie.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...