Jump to content
Light-O-Rama Forums

e1.31 DMX troubleshooting advice needed


shiner

Recommended Posts

Hi!
I am drawing a blank on additional testing steps to try and thought I would throw my question out to the group. I successfully used the router and e1.31 bridge combination in 2012, and now have changed show computers and updated software which has resulted in what appears as no communications.

Hardware Chain - 
PC: Windows 7 Ultimate, wired Ethernet
Router: Netgear router
e1.31 Bridge: RPM (Robert P Martin of martinxmas.com)
Controllers: LOR running in DMX Mode
Channels: I am running LOR (dmx mode) on U1, and RGB Pixels on U2-4

Software:
LOR S3 - network settings are e1.31 multicast for universes 1-4 (no apparent show control)
XLights - network settings are e1.31 multicast for universes 1-4 (no apparent show control)
David_AVD e1.31 tester - default settings are e1.31 multicast - WORKS....

My Observations:
1) With David's software working - it suggests to me that the hardware chain downwind of the show computer is ok. This isn't to completely rule out the e1.31 bridge, but all indications point to something else. 
2) In general, multicast is multicast.... it shouldn't matter what the PC's 
IP/gateway/subnet mask settings are? Could this be a win7 firewall type issue? - I did disable the firewall as a test and it did not change my results.
3) At 1am I hopped online and chatted on the Aussie Forum with David about his test software. I wanted to see if he was doing something special, something that would not hit the same firewall/other protections that S3 and Xlights were hitting. Why does his software work and the other's do not? He was unaware of anything special, other than he is multicast out of the box.
4) The one thing both xlights and LOR S3 have in common is that they are trying to play back the same sequence files. Maybe the issue is in the file?
5) What's changed from last year to this year? In 2012, I used a crummy XP machine with sequences configured in LSP and then converted to XLights. Aside from the PC, sequencing software, and xlights version (older given the date it was used)- the hardware downstream is the same. In our world however - these are HUGE and equate to a shotgun blast of change that could have problems at every level.
6) To test my win7 vs. XP theory, I grabbed a small PC that just arrived to my house and had a fresh image of XP pro. I installed xlights, grabbed a sequence out of dropbox, played it - WORKED... I thought my work here was done (and went to sleep). Simply roll with the XP box this season and figure it out over the summer. No such luck. I copied all my files, built the XLights show, nothing...

Possibilities I need to rule out:
1) LOR S3 Channel Config - all say DMX Universe and would appear to me to look correct. However, if something was off here, that could be a problem. I only have the Universe 1 lights hooked up at the moment. I should quickly be able to plug in the U2-4 lights and see if my problem is limited to just U1 or all. U2-4 go through a j1sys pixel controller and it is grabbing the multicast as well. If these work, it will limit the focus to the e1.31 bridge and U1. Kinda mad I didn't investigate this already.
2) Test a Xlights sequence from 2012 - one that originated in LSP. Does it do the same thing? If it works, and a 2013 from LOR does not - it is most likely something that is happening to it in the LOR S3 software (config, setting, or otherwise).

For now, I have temporarily moved into Plan B. That required a painfully manual channel reconfig to place U1 back on traditional LOR communications with a USB dongle. I only have 1 cable from my computer to the controllers outside, so it effectively prevents me from turning on my 1500 rgb channels because the cable is used for LOR instead of Ethernet. After I had the new lcc built, I was able to use ItsMeBob's awesome ImportOMation scripting tool. This allowed me to point to the new config file and have his software script roll through all of the sequences to apply them instead of me having to manually update all of them to the new channel config. While that was running, I ran downstairs to work on the rest of my troubleshooting to-do list. 

Visitors do not know there are issues, but I do and it bugs me. For now, the show is off and running and I can put boxes away until tear-down.

 

Thank you,

Chris

Link to comment
Share on other sites

Thank you for the response.  I have tried both static and DHCP addresses on the PC - all within range of the bridge.  The bridge has a static IP set to 192.168.0.101 on a 192.168.0.x network.  One suggestion I received was to set the PC address to 10.10.10.50 because that is what they had seen work with a 10.10.10.10 ethercon gateway from J1sys.  I tried it and it did not seem to have an effect, but it did change  the subnet from 255.255.255.0 to 255.0.0.0 and I was wondering if that would make a positive difference for me.

Link to comment
Share on other sites

unless you had the same ip address on the puter as the bridge,(which of course won't fly)...  I got nothin..   sorry

 

the 10.10.... won't gain you anything..

Link to comment
Share on other sites

Do you have multiple apps running at the same time? Perhaps the controlling app for David_AVD is running in the background and locking control of the hardware.

Link to comment
Share on other sites

Is the LOR Comm listener running and does it appear to be connecting as it should?

 

Since this was a new computer (from last year), had you ever plugged in a LOR USB interface (which causes the drivers to be loaded), or run the procedure required if you never expect to have a LOR USB interface plugged in (alternate way of getting the required library files installed that are included in the USB driver install)?  If not, see this thread:

http://forums.lightorama.com/index.php?/topic/23207-initial-setup-for-e131-if-you-do-not-have-an-lor-rs485-usb-adapter/

Link to comment
Share on other sites

Brian,

I did think of this potential conflict and was careful to physically close out applications to ensure only one software was attempting to multicast at a time.  However, I cannot say for sure if things really closed out beyond the scenes.  I will try a clean reboot as I cycle between S3 and Xlights as a precaution -- it can't hurt.  I will also ensure LOR Control Panel is not set to load on boot.

 

Jim,

Thanks for the info.  I can say that when I was testing e1.31 comms, I had NOT yet connected the LOR dongle.  I will need to revisit this now that I have a LOR dongle connected as my "Plan B."  Given the pain involved with applying the channel mapping (I have one for LOR and one for DMX), I have not revisited the e1.31 path but do plan to do this Friday Afternoon when I will have a considerable chunk of time to focus on resolving this.  I have read the post and I DID SEE THIS in my LOR Comm Listener prior to connecting the LOR Dongle.  With the dongle connected, these errors have gone away, so this is a possible culprit. 

 

At a minimum - thanks to everyone for the hope of a possible solution.

Link to comment
Share on other sites

  • 2 weeks later...

To close the loop here, the Dongle Drivers appear to have been the source of my issues.  Thank you to all for chiming in to assist.  Once I connected the LOR 485 Dongle, the PC loaded the drivers thus solving my issues.  Business travel got in the way of me shifting off of the LOR Dongle and back to e1.31, but we have now finished that transition and are fully up and going with e1.31

 

Thanks!

Link to comment
Share on other sites

  • The topic was locked
Guest
This topic is now closed to further replies.
×
×
  • Create New...