Jump to content

Compressed Files


mikeosf
 Share

Recommended Posts

Hi All,

 

Not quite sure what it wrong. It does seem to be not normal behavior.

 

From time to time when the music show is running (animations are shorter and less obvious haven't caught it)

 

I get (and no it's not just this music sequence, it seems to happen randomly as if it can not read the compressed file)

5:27:07 PM: Loading compressed sequence: C:\Users\michael\Documents\Light-O-Rama\Sequences\Musicbox.lms.lcs

5:27:07 PM: Cannot load compressed sequence file for C:\Users\michael\Documents\Light-O-Rama\Sequences\Musicbox.lms
5:27:07 PM: Loading sequence: C:\Users\michael\Documents\Light-O-Rama\Sequences\Musicbox.lms
5:28:53 PM: Exporting compressed sequence for C:\Users\michael\Documents\Light-O-Rama\Sequences\Musicbox.lms
5:29:14 PM: Starting Musical: C:\Users\michael\Documents\Light-O-Rama\Sequences\Musicbox.lms

 

There is a huge lag when it recreated the compress file. Though about a 1/2 hour before the same file compressed loads fine.

 

-- Sometimes the log shows this

7:39:35 PM: Loading compressed sequence: C:\Users\michael\Documents\Light-O-Rama\Sequences\ChristmastTimeIsHere.lms.lcs
7:39:35 PM: Cannot load compressed sequence file for C:\Users\michael\Documents\Light-O-Rama\Sequences\ChristmastTimeIsHere.lms: Cannot allocate memory for event table
7:39:35 PM: Loading sequence: C:\Users\michael\Documents\Light-O-Rama\Sequences\ChristmastTimeIsHere.lms
7:40:47 PM: Exporting compressed sequence for C:\Users\michael\Documents\Light-O-Rama\Sequences\ChristmastTimeIsHere.lms
7:41:08 PM: Starting Musical: C:\Users\michael\Documents\Light-O-Rama\Sequences\ChristmastTimeIsHere.lms

 

It chugs then goes again. What is strange it can go a whole evening with only 0,1,2 hick-ups...

 

-------

 

There are some bugs in the Superstar. Mainly around the limits when exceeding 40 CCR's it complains that you are over the max then lets you do it.

 

Under Layout when you change the number of CCR switching from 1/2 to full....

 

Regards

Michael

 

PS: if you need any additional details I will send whatever info you need...

Link to comment
Share on other sites

In your show editor, look under options, and select "Sequences are loaded before any are played." This will load all the sequences into memory before the show starts. This has been known to help, as the computer doesn't have to load the sequences before it plays them the first time.

Link to comment
Share on other sites

I have that off as it makes it worse. There is a huge lag at the beginning as it tries to load them all.

(it gets the same error on the odd sequence here or there)

 

I have tested 2 schedules:

one 4 hour block(show) containing 22 songs the error is more frequent (can not load all at beginning)

eight 1/2 hour(shows) schedules 6 songs in each seems to error much less (I think it may have something to do with a cleanup that may occur when swapping shows)

 

It seems to me like it tries to load the compressed file (and probably another error is occurring)

it seems to choose the solution (can't load compressed file and then re-writes the compressed file)

 

One good thing! It doesn't crash the computer like last year! (yah!)

 

Just this humble programmer's best guess!

 

Michael

Link to comment
Share on other sites

I am seeing something similar to this. Test playing the show tonight. Getting the same error cant load compressed sequence, it is then making the compressed sequence all over again even though all the compressed sequences are already in the folder. Takes a couple of minutes for each sequence to start. I am also getting winsock error 10053 thrown in because it is taking so long to create the compressed file.

 

This is my first test, hopefully after it recreates all the compressed files it will work better, are you not seeing that?


I am seeing this on every sequence it trys to play.

Link to comment
Share on other sites

Ok I tried a combination of things that seems to have worked.

 

Putting on the "Sequences are loaded before any are played." only displaced the error to up front. (22 sequences 3 fail * 2-3 minutes per failure) the show is black for 9 minutes. (PANIC!)

 

I did a dam the consequences move applied the 4gig patch to all the executable.

I left the option "Sequences are loaded before any are played." The loads FLEW by in like 2 seconds. (Amazingly NO error)

 

Ram consumption is higher (by about a gig),

 

Will keep you apprised. If it makes it thru all 22 songs no errors I may do the dance of JOY! :)

 

Michael

Link to comment
Share on other sites

I am seeing something similar to this. Test playing the show tonight. Getting the same error cant load compressed sequence, it is then making the compressed sequence all over again even though all the compressed sequences are already in the folder. Takes a couple of minutes for each sequence to start. I am also getting winsock error 10053 thrown in because it is taking so long to create the compressed file.

 

This is my first test, hopefully after it recreates all the compressed files it will work better, are you not seeing that?

I am seeing this on every sequence it trys to play.

 

I've been seeing the compressed sequence issues forever, I disable it and everything runs fine.  My sequences aren't monster huge like yours are (yet) so I'm probably still getting by without the need for having them compressed at all.   I have not seen a winsock error.   When I do try to run compressed, the sequences it wont compress for whatever reason it just skips and they never play from the show.

Link to comment
Share on other sites

I played the show through one time and it fixed the problem. Even though i had compressed sequences in the folder it recreated them while the show was playing. After it did that the show played fine.

Link to comment
Share on other sites

The way compressed sequences work in the Show Player (if you have it set to use them) is this:

 

When it comes time to load a sequence, if there is a compressed sequence for it, AND the compressed sequence is newer than the regular sequence, it loads the compressed sequence.  Otherwise (or if an error occurs loading the compressed sequence) the regular sequence will be loaded, and a compressed sequence will be created (so it can be used in future runs of the show).

 

This seems to me like it might be a memory issue, so it makes sense that the 4GB Patch might help (it increases the amount of memory that Windows will allow LOR to use).

 

One thing I'd suggest would be to make sure that you have the option "Show Player Memory Restarts" enabled.  Basically what it does is this: If there is currently no show running, and no show scheduled to start for the next (I think) minute, then the Show Player will automatically be stopped and restarted.  The idea here is that if there is some sort of memory leak in the Show Player, stopping it and restarting it should free up any leaked memory so that it can be used again.  I am not aware of any memory leak in the latest releases of the Show Player, but "Show Player Memory Restarts" could be good just in case there is one, and I don't think it can hurt if there is not.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...