Jump to content

lights are on


rednosetbird
 Share

Recommended Posts

My lights on one channel are on all the time but dimmed.Its only one channel out of my 8 boxes. The channel that is on has incandesent lights.This cannel last year would stay on for a second or two last year but would turn off. Any ideas???

Link to comment
Share on other sites

I agree with James. I had to pull one of my controllers out of the show for the very same reason.

One channel would stay on at about 25% to 50% all of the time. I submitted a support ticket to lor.

I received a timely response . They had me do several tests to see if it would rectify the problem.

It did not. Bottom line a triac going bad. They will send me the parts To fix the board or I can send them the controller and they will fix the problem for me.

Great customer service Light O Rama.

Edited by Joe Polenchar
Link to comment
Share on other sites

I agree with James. I had to pull one of my controllers out of the show for the very same reason.

One channel would stay on at about 25% to 50% all of the time. I submitted a support ticket to lor.

I received a timely response . They had me do several tests to see if it would rectify the problem.

It did not. Bottom line a triac going bad. They will send me the parts To fix the board or I can send them the controller and they will fix the problem for me.

Great customer service Light O Rama.

I had a problem with my controller. It was under warranty and Yes great customer service! and in the tech support. They ended up having to replace the controller and they send me a new one with a note that they were really sorry I got a controller with a bad board. Our QC shoulda caught it but it slipped through... we are really sorry. and I'm paraphrasing of course. i was like, no problem thanks for getting it resolved so quickly. yes, great customer service

Link to comment
Share on other sites

Me too...had a bad channel on a new controller that I discovered months ago. LOR took care of it right away sending me a new board. The defective board turned out to have a bad triac too. Crap happens. Great customer service!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...