Jump to content

Please enter integer between 0 and 100


bkdraft
 Share

Recommended Posts

You probably are not doing anything wrong. It is a bug. I know it can happen when you into the Configuration dialog box and change from "Full Range" to "Balanced" color mode. Try shutting the program down and launching again and it should take care of the problem

Link to comment
Share on other sites

Maybe you can start by giving us some more information. What are you doing? What program are you using? What operating system are you using? From your question, we have no idea what you're talking about.

More details please.

D.T.

I stand corrected - Brian seems to know what you're talking about :lol:

Edited by DownTown
Link to comment
Share on other sites

Using SS 3.8.0 on Win 7 64 bit. Trying to program 2 CCR's set up as 4 arches. Works fine for few minutes, then starts the "please enter integer between 0 and 100, asks this every time I do anything and have to answer 3 times, then command goes through. Shut it off, start it back up, works couple of times and then here it comes again. GRRRRR making it very long task to get anything done, as it does it on EVERY single command.

Link to comment
Share on other sites

If you can, email your SSEdit.cfg file and the sequence you are working on to brian@superstarlights.com and I will see if I can duplicate the problem.

The files are at:

c:\ <your lightorama folder> \ SuperStar \ SSEdit.cfg

c:\ <your lightorama folder> \ SuperStar \ Sequences \ YourAwesomeSequence.sup

Link to comment
Share on other sites

As I mentioned, it is a bug that shouldn't happening. And I have been trying to reproduce the bug and cannot. If you email me your SSEdit.cfg and .sup file I may be able to reproduced the bug.

But there is a good change if you go to the Configuration dialog box and set it to "Balanced" mode the problem will go away.

Link to comment
Share on other sites

I have experienced the bug before, and thought I had it fixed. I know that the bug has to do with checking the range of the color value in the various fields in the dialog boxes. When you are in "Balanced" mode the valid value range is 0-100 but when you are in "Full Range" mode the valid values for green go to 0-120 and for blue they become 0-130.

I know it has to do with that, and I have been setting color values for green and blue to be above 100 while in "Full Range" mode but I can't get it to happen. Even with your SSEdit.cfg and the sequence file you are working on.

Link to comment
Share on other sites

Your video helped. It is because I have not been using the "Color Picker" dialog box to set my colors. As soon as I use a color such as full green from the color picker dialog box the bug happens. For what it is worth, it is becuase it is setting a green value of 130, this value gets set in all the dialog boxes even if you don't have them up. So if you launch the scene dialog box and type in a value of 100 in the green color field and you have to launch the morph dialog box and correct it there, and also launch the text dialog box and correct it there, and then the error goes away.

But I don't expect you to do that. You mentioned that the problem doesn't go away if you set balanced mode. I expect you mean that once you start getting the error and you then go to balanced mode the problem doesn't go away.

However, if you do the following, I expect the problem will go away:

1) Set "balanced" mode

2) Shut down superstar

3) launch stuperstar

4) the problem should not happen

That is the workaround, meanwhile I will fix it so that the color picker dialog box will not cause this problem even if you are in full range mode.

Link to comment
Share on other sites

Yes it is a bug. It turns out that it was happening to bkdraft because the Color Picker was putting values of 130 into the red, green, and blue controls. This was only happening in "full range" mode. Now that I understand that bug, I have fixed it and the fix will be in the next release.

But in your case it may have been happening for another reason. If it happens to you and you are not using the Color Picker, let me know. There may be another bug in there that is not related to the Color Picker.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...