Jump to content

Can't delete a loop. Can't save sequence.


lightingnut
 Share

Recommended Posts

Hello, I am ready to punch the computer. I made a musical sequence and I try to save it but an error occurs and it says "Error saving file...do you want to try to save to another file name? Detail: Invalid procedure call or argument." I've tried naming it various things but I always get this message. One problem I've noted (thinking it might be the cause of my saving issue) is that I have somehow gotten a loop on my file. I've tried everything to get rid of it but nothing works and nowhere says how to remove it, or rather, I've found ways you can remove it but none of those work (even right clicking it). I even had people try yelling and cussing at it, which proved the least effective (JK). It was previously saved as a musical sequence, so I'm not sure why it even allowed a loop to occur. Either way, I was wondering if someone could help me out.

Thanks,
David

Link to comment
Share on other sites

It shouldn't have been possible to add a loop to a musical sequence in the first place. Are you sure it's not an animation sequence? Perhaps it inadvertently got changed to be one. What happens if you hit the play button? Does music happen, or not?

As for this "Invalid procedure call" thing, here's something that has worked for some people in the past:

(1) Stop all running programs, including LOR programs.

(2) Open up a command prompt window. You can typically find the icon to start one up under the "Accessories" menu of your computer's Start menu.

If you are running an operating system where it matters, do so "as administrator" - that is, instead of starting the command prompt window by double-clicking on the command prompt icon, right-click on the icon, and select "Run as Administrator" from the popup menu.

(3) In the command prompt window that opens up, type the following two lines:

cd c:windowssystem32
regsvr32 scrrun.dll



Note the following:

(A) There is a space on the first line between "cd" and "c:windowssystem32".

(:) There is a space on the second line between "regsvr32" and "scrrun.dll".

© There are no other spaces anywhere else on either line.

(D) The slashes in the first line are backslashes (""), not forward slashes ("/").

After typing those two lines, a message box should pop open, saying something like "RegisterDllServer32 in scrrun.dll succeeded". I'm not sure if that's the exact phrasing, but it should definitely say "succeeded", or "successful", or something like that. If it does not, please let me know exactly what it says, word for word.

After that, open up the Sequence Editor, and try again.

Link to comment
Share on other sites

Hello Bob,

Thanks for your help.

I'm not sure how it got changed or how loop got in there. Music would play when I would click play. What I finally did was copy the animation then paste it into a new music sequence. That fixed it. After that I was able to save it as a music sequence.

When I would left or right click on the loop button nothing happened. Never did get a box asking how many times to loop or anything like that. Under Edit, LOOP was gray and I could not click it. It was very strange.

The other strange thing that is happening is when I roll the pointer over the buttons I don't get the name of the button any more. I probably need to restart the program and see if that fixes it.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...