Jump to content
Light-O-Rama Forums
JESonger

Getting started with DMX in LOR

Recommended Posts

I have 3 RGB wash lights on the front of my house, each driven by DMX-RGB controllers & connected to wireless DMX receivers, paired to the transmitter on my DMX board.  For Christmas, I naturally want to integrate those into LOR.  Following this picture at LOR, I bought another USB485 adapter for a second, DMX network, and connected the DMX transmitter to it. I've confirmed in Windows Settings that both adapters have been assigned COM ports.

And that's where I'm stuck.  How do I configure the other adapter for DMX in LOR like in the picture?  I see the DMX tab in Network preferences, but no option to bind Universe 1 to COM4.

Also, I've added the correct DMX channels to my preview, so I have R1, G1, B1, R2, G2, B2, R3, G3, & B3 channels.  Am I stuck with with making green by On-ing that channel and Off-ing the other two, or can they be bound into one colorspace like LOR channels?

Share this post


Link to post
Share on other sites

I am a newbie (2 years)....  But I have had a LOT of help on here, and figure if I can help someone else i will try.    Last year I ran everything on a LOR network.  This year I added DMX.  This sounds like what you are doing.  It also sounds like you are thinking how I thought in the beginning.  That I could run both LOR and DMX on the same "network cable"....  If not I apologize.  but anyway, I am running 2 parallel networks.  1 USB485 LOR and 1 "CAT5" DMX network off of the same laptop.  This is how I had to do it to run my LOR and DMX (alphapix) controllers in the same show/sequences.  Is this what you are trying to do?  Also, i configure my LOR network in the S5 Hardware Utility, and the DMX via the IP address of the DMX controller on the LAN network...  

  • Like 1

Share this post


Link to post
Share on other sites

I've got to run real quick, but these two screen shots should help.  In my case I am using E1.31 (DMX over Ethernet), but this should give you the ideas...

S5.1.2_NetworkPrefs-DMX.png

For this screen capture, I selected Universe 5.  In your case, you would have the "Use Adapter" setting selected (instead of User E1.31), and Under Adapter, you would select your Comm port.  I don't remember if the protocol setting changes (I would assume it does) when you are using DMX over a comm port since I have never used DMX over a comm port and I don't have a computer here that has LOR installed, so I can't test easily for you.

S5.1.2_NetworkPrefs-DMX-selected.png

Hope that helped.

 

Share this post


Link to post
Share on other sites

Please look at the picture I linked.  It shows one USB485 driving its own DMX-512 network, which is what I'm trying to do, not using E1.31.

Share this post


Link to post
Share on other sites
1 hour ago, JESonger said:

Please look at the picture I linked.  It shows one USB485 driving its own DMX-512 network, which is what I'm trying to do, not using E1.31.

You have a very generic LOR graphic linked.  I did look at it.  Try reading what I inserted in between my screen captures.  It tells you what is different from my captures to what you need.

 

Share this post


Link to post
Share on other sites

Jim,

Sorry I missed that text before, but it happens to be exactly what I thought I needed to do in the first place.  But when I first click on the entry for Universe 1 Adapter, "LORNetworkConfig has stopped working" and terminates.  Every time.  Unless I unplug the second USB485; then I can access the settings and plug the USB485 back in.  But then, nothing is in the Adapter drop-down.  So I guess my question really is: why does a second USB485 crash Network Preferences, and how do I correct that?

John

Share this post


Link to post
Share on other sites
On 12/5/2019 at 12:01 PM, HADESWRAITH said:

That I could run both LOR and DMX on the same "network cable"....

Actually, you could. LOR uses pins 3,4,5,6 and DMX uses pins 1,2,7 so you could combine both networks in one cable.

This would only work if your DMX devices passed pins 3,4,5,6 through without doing anything to them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...