Jump to content
Light-O-Rama Forums
Sign in to follow this  
kevinob

CCB - devices plug in correctly but colors always 'alternate' during sequence

Recommended Posts

I have 4 CCBs setup. 100 bulbs for each ccb controller. bought from the recent clearance deal. Doing simple Sequence editor setup for basic animation I have 2 of them working correctly. Setup as CCD with 2 strings,  Unit ID2 +1 from Unit 2

CCBs all, as plugged in, light up first pixel as green... so I feel good to go...

My sample sequence fires up (I made all bulbs color Green.... looping the sequence just to get color up on house to confirm all is working)...

2 controllers (4 strings) all work fine on one side of house

but...

2 controllers (4 strings) show continuous 'alternate' colors (green/red/blue/etc) on 'other side'. Consistent in behavior.

I'm using the search to find similar problems but posting in case this sounds like a familiar problem that's been solved .... I'm going to move a string from one of the two 'working' units and see if it's string... kinda weird though for those 2 units to have problem.

wondering if it might be cat5 cable issue as sequence of controllers A,B,C,D so to speak it is C and D that have issue... maybe power injection to cat5 cable? if so I've no idea on how to do that... rats.... cable length maybe 40-50 feet to CCD "C"... and they test at plug in properly.... arg.... I did HW editor to assign new unit ID's... don't think I fatfingered any setting in there....

 

thoughts from those smarter than me?

Edited by kevinob

Share this post


Link to post
Share on other sites

Updating following some troubleshooting. 

 

Situation: 4 CCB setup. Laptop-> USB485HS -> CCB_A, CCB_B->CCB_C-> CCB_D  .   Each CCB has two 50 bulb stings. Unit C and Unit D pass hardware tests but misbehave consistently during any Sequence. Always flashing R,G,B regardless of color identified in sequence.

 

Troubleshooting so far:

  • I've ran HW test against all units. All bulbs respond correctly via Hardware utility.
  • To ensure sequence setup is not issue: During Sequence Unit A and B work fine (so that is good), but unit C and D alternate R,G,B colors during shows no matter the color settings in the sequence. A/B works... I've also built multiple sequences for C,D to ensure no muck in the sequence.
  • To check for bad Cat5, I changed setup to Laptop-> USB485-HS ->CCB_C-> CCB_D .... both the C and D continued to wrongly alternate R,G,B (hardware utility passed just like in prior setup) even though I've eliminated cat5 cable length as a concern.
  • To eliminate wall plug fuse as consideration, I checked for blown fuse in the wall plug of the CCB unit

 

Tonight I will try to swap a strands from Unit A or B into C to check for Strand issue. At that point I have no idea what to troubleshoot next.

 

Taking any ideas :)

 

Share this post


Link to post
Share on other sites

Sounds like a sequencing issue particular to those channels, or ID's if the HU test is correct. 

Are your Id's correct or overlapping, are you using hex for the Id values

Color order being incorrect would not cause alternating colors.

Cat 5 for the RS 485 can run thousands of feet. Not so the pixel leads.

Leads from the controller should be kept as short as possible. My longest pixel lead is about 30 ft on a 50 pixel prop, and is right on the edge of turning pink at 100%  

I keep the rest of my controllers within about 10 feet of the prop they control.

Share this post


Link to post
Share on other sites

Are you absolutely certain the four boxes have non overlapping Unit IDs?

for example, Unit A=ID1,Unit B=ID3, etc.  

remember that each string of 50 will have its own unit ID, so it’s as if you really have eight boxes.  The second ID for each box happens under the covers.

my debug for a situation like this would be to remove Units A and B and see what happens.

Share this post


Link to post
Share on other sites

Thanks Brian and Phil. I'll shoot some screenshots of my work tonite. 

@PhilMassey I'm using basic CCB's with normal 4 wire bulbs. no extensions to bulbs. so should be good. thanks for the clarity on the cat5... I felt I removed that as a consideration and you confirmed that. thx!

@brianfox I had the same debug thought and plugged straight into the 2 units (removing A and B, just C and D in the network). Still got same result... glad at least I'm approaching correctly

Both of you had thoughts on the ID's of the boxes so I'll confirm and screenprint.

I'll have results of my string swap test tonite as well... errgh :)

More to come...appreciate the assistance

Share this post


Link to post
Share on other sites

So since you see the problem every time on C and D, it’s telling me you have two things trying to control C and D at the same time, or that they have overlapping IDs. 

I had nearly the same problem this year with my arches.  They ran fine in Pixel Editor, but if I ran from SE, they flickered and had random white segments flash.

turned out I had made two props for each arch in PE.  One prop treated the arch like a 7 segment arch, grouping pixels into each segment.  The other prop had the arch as a traditional PE arch.  The reason I did that my display originally had incandescent arches that I programmed as segments.  So when I moved to pixels I could use e same sequences.  I later redid the sequence to use arches as traditional pixels.

problem is I never removed the seven segment props from my display.  So at some point I had SE addressing the arch at the same time PE addressed it.  I’m surprised it only had minor glitches. I deleted the segment prop from PE and suddenly the show worked perfectly.

its always something dumb like that which causes you to pull your hair out for days.

Edited by brianfox

Share this post


Link to post
Share on other sites

well.. I'll take the cake here on being dumb. Somehow those controllers had ccb config settings to be "sequential" and not "triples".... so lesson for anyone seeing random light colors in Sequences but NOT in Hardware utility: Check your channel mode setting in CCB hardware utility. It says it clearly in the documentation but I musta missed doing it or fatfingered something .....

 

Thanks for guidance and help! back to getting sequences running...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...