Jump to content
Light-O-Rama Forums
Shadow62672

CCR II ribbons seem like junk

Recommended Posts

Bought brand new this year the 16 ribbon package..... already had 2 fail. Anyone else having issues? I have original CCR they seem to be made better and hold up a lot better than these. Just curious. Seems if you sneeze they fail. 😂 Pretty disappointed in the product. 

Share this post


Link to post
Share on other sites
12 minutes ago, Shadow62672 said:

Bought brand new this year the 16 ribbon package..... already had 2 fail. Anyone else having issues? I have original CCR they seem to be made better and hold up a lot better than these. Just curious. Seems if you sneeze they fail. 😂 Pretty disappointed in the product. 

If they failed, send a help desk ticket to LOR explaining your issue, type of RGB ribbons you have so you get the correct ones. {Have you sent one?  If not, I highly recommend you do so!}.  

This time of year they are pretty busy, but if they see your issue, they'll usually send out 2 brand new strands and you send the failed ones back to them.   And many times they'll send you the new strands first, then you can send the failed strands back.

LOR has ALWAYS STOOD BEHIND THEIR PRODUCTS 100,000,000%! IMHO

  They will get you working again as soon as they can.  And their Customer Service has always been the greatest to get things going for folks when things like this happen.

 

Edited by Orville

Share this post


Link to post
Share on other sites

Two year warranty as long as you didn't modify them, cut them. As suggested, contact the help desk and send them back.

Share this post


Link to post
Share on other sites

Lightorama is always spot on with customer service. They have already sent replacements. That’s not my issue. I wanted to hear if other people were having issues with the failure with these new ribbons. I may have to go with a matrix next year vs a tree due to the height. Not an easy task to replace them once the tree is erected. 😁

Edited by Shadow62672

Share this post


Link to post
Share on other sites
5 hours ago, Shadow62672 said:

Lightorama is always spot on with customer service. They have already sent replacements. That’s not my issue. I wanted to hear if other people were having issues with the failure with these new ribbons. I may have to go with a matrix next year vs a tree due to the height. Not an easy task to replace them once the tree is erected. 😁

Okay, I really wasn't sure since the way your post was worded.  Now that makes sense, but with anything, sometimes you get a bad batch of components, and many times the manufacturer of the end products inspection team doesn't catch it because they worked when tested, therefore passed inspection and got used, then unfortunately they end up failing once an end user gets the product.  

Having worked as a QCI {Quality Control Inspector} for several manufacturing companies over my career in Electronics, so I'm very familiar with how bad components will sometimes get through to the assembly floor.   Yes, they were tested numerous times, worked fine in the factory, consumer/customer gets the end product and then it decides to fail.  Unfortunately nothing is above failure at any given time once it leaves the factory.

Yours may have been the only ones a bad set of components made it through all this testing and then unfortunately into your hands, others may not be having any issues like this at all. 

But time will tell if anyone comes forward and says if they are having or have had this issue with the newer CCR II product line.  Only time will tell if anyone else has any failures a short time after getting them and installing them.

 

 

Share this post


Link to post
Share on other sites

I bought a Pixie II this year and had a bad ribbon.

This is my second year with LOR and I had 32 channels on 2 GEN 3 controllers, and wanted to dip my toe into RGB this year. It was a little tough getting over the learning curve with a Pixie II that I upgraded firmware that I shouldn't have AND a bad ribbon. Once I determined it was a bad ribbon,  I put in a helpdesk ticket and got the same great treatment as noted...they sent new ribbon with RMA for the old one that I received in 3 days, so I was able to continue working on it. With TWO working ribbons, I flashed the prior firmware as a last resort and EVERYTHING started working as expected. Been happy ever since. Now, the switch over to software Version 5 after the this season is likely to be another story.

Share this post


Link to post
Share on other sites

Seems it was a bad batch. I ended up switching out 4 ribbons. Thank god they are awesome with customer service and warranty work! Thank you light o Rama! Think I am already over the vertical tree gonna go to a 24 ribbon matrix. Easier to work with and better resolution. Should be interesting next year. Seems my display will forever keep growing. 🤷🏻‍♀️

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...