Jump to content
Light-O-Rama Forums
k6ccc

JRW21 - Windows Command issue while editing

Recommended Posts

OS:  Windows 10 Pro

LOR version:  S5.2.2

License level:  Pro

I have run into an interesting issue.  I run MIIP for my Christmas show which requires use of a Windows command in the sequences.  I have used Windows commands for years without issues.  The command gets entered as MIIP.COM %SEQUENCE_FILENAME_NO_EXT% which is then translated to the actual path to the command as shown below.

S5.2.2_MIIP_CMD.png

The issue is that the command is on the show computer, NOT the sequencing computer.  So when editing the sequence and I attempt to play it (locally only, not controlling lights), apparently the Sequencer is attempting to process the command - which does not exist on the sequencing computer, and it results in this error.

S5.2.2_Cant-Play_error.png

The error is correct that the file can't be found because is on a different computer, but why is it even trying to see if the command is valid?  There does not appear to be any way to play the sequence on the sequencing computer without deleting the command, and then hopefully remembering to put it back when completed editing.

Now before you say, wait a minute, Windows commands are local to a computer and not part of the sequence.  On the three computers at the house that have LOR installed (the show computer, the sequencing computer, and my server which runs the landscaping show most of the year), they all have LOR files point to a folder on my server.  Therefore, on all three computers, the cmdmap.lcm file appears to be L:\Sequences\cmdmap.lcm - which is actually D:\Shared\LOR\Sequences\cmdmap.lcm on my server.  Therefore, all three computers see the cmdmap.lcm file as the same actual file.

 

 

Edited by k6ccc
Added version info

Share this post


Link to post
Share on other sites

Two ways to solve it/work around that I use.  I also use a shared folder for my Light-O-Rama install.  

1) when editing the sequence I turn off the windows command, fortunately it saves the value so you can check it again at end of the editing session.

2) I installed the MIIP client on my of sequencing computer.  I may have needed to put symbolic link to make it work but that may particular to the mismatch in usernames between the two computers.

Share this post


Link to post
Share on other sites

I tried your option 2, but it did not resolve the problem.  I realized that the issue is as you also suggested a difference in user name.  Every body logs into my domain, but not with the same user name.  The show computer logs in as “LOR” and I log in as “Jim”.  Now the solution my be to give the Jim account at least read access to the C:\users\lor\AppData\Local\MIIPClient folder.  I will try that tonight.

One more piece of information.  The Show computer is running Windows 7 Pro, the sequencing computer runs Windows 10 Pro, and the server runs Windows Server 2012 R2.  Both other computers that have LOR installed that are not on the domain run Windows 7 Pro.

 

 

Share this post


Link to post
Share on other sites

There are options to control lights and other similar settings.   Sounds like an option to execute windows command would be helpful. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×