Jump to content
Light-O-Rama Forums
Box on Rails

Will S5 sequences Play in the S4 show?

Recommended Posts

OK here is what I have. In the garage is my stand alone (no Internet) show computer with S4 software playing my shows. I have a PC in the house with S4 software that has all my current sequence files. I recently loaded the new S5 software on my laptop. I have been creating some very cool sequences with S5 and want to run some of these in my show this year. Can I copy the S5 .lms file to my  S4 show computer then play it in my show? 

Share this post


Link to post
Share on other sites

No.  We are backwards compatible, almost never forward.  You can use S4 sequences in a computer running S5 show player.  You probably can not (and even if you could we would not recommend) running a show created in S5 on an S4 show player.

Share this post


Link to post
Share on other sites

Well that means November 1st I gotta a lot of work to do. Thanks DevMike. 

Share this post


Link to post
Share on other sites

Well I learned something new, I always thought if something were "backward" compatible, the newest would run on the older {previous/BACK} version, but after seeing and checking out S5, I went back to S4, just easier for me to use.  But S5 creates new and different type filenames doe sequences, so I took it to be that S5 WAS NOT backward compatible.    Guess I need to brush up on my computer terminology again.   Seems definitions aren't what they used to be or I never fully understood the term "backward", guess it depends on what you're referencing....?  Ijdk LOL

Edited by Orville

Share this post


Link to post
Share on other sites

It's always based on the version you are currently on (or whatever).  It's a time line.

1  2  3  4  5 

If you were on the most recent S5, nothing can be in front of you.  S4 (and 1,2,3) is behind you.  S4 runs in S5, so "S5 is backwards compatible to S4".

If you were on the most recent S4, what is in front of you is S5, and what is behind you is S3 (and 1 and 2).  S3 runs in S4, so "S4 is backwards compatible to S3".  S4 however knows nothing about S5 (since it's 'from the future').  That means "S4 is not FORWARD compatible with S5".

Share this post


Link to post
Share on other sites

Thanks for that very detailed explanation DevMike.  Now it all makes better sense to me.  :D

Anyone got a really good used brain for sale?   I think mine's starting to wander in directions I don't want it to go.🤣🤣🤣

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×