Jump to content
Light-O-Rama Forums
JBruckert

When enabling schedule, pop up come up

Recommended Posts

Pop up comes up and says "shows can not be enables because the comm port is already open. 

 

Any help with this would be great.

Share this post


Link to post
Share on other sites

Can't have the show player and Sequencer controlling lights at the same time. Close Sequence editor before enabling shows. Similarly the hardware utility

Share this post


Link to post
Share on other sites

I tried that and still nothing. 

Share this post


Link to post
Share on other sites

You must have something in the LOR Software opened already that looks and uses the comm port, or you set the comm port incorrectly in the HWU when you set up which comm port to use for your show, that's the only way to get that error.

If you've selected the wrong comm port when you set up your software the first time through using the HWU, especially if you have more than one Network, make sure the Comm port is set to the REGULAR Network and not any of the other comm ports, as this too will also cause that error.

I have comm 3 set for my shows, but I also have a comm 4, which is my Aux A Network, 500K, Enhanced strictly for my RGB Lights and controllers, if you set that comm port to your show settings, it will cause this error as well. 

I know from doing it myself, because the HWU asks if this is the comm port you want to use for your shows, I clicked "Yes" on comm 4, then I'd get that error, because comm 3 is the one on my Regular LOR Network for my CTB16PC {older Version 2} Controllers, once I set it back to comm 3, exited back out of the HWU, all ran fine and no comm port errors.

Good luck on getting the issue resolved!

 

Share this post


Link to post
Share on other sites

I am fairly new to this so I might be asking stupid questions, but is there a way to reset this and start from scratch? I did notice that when the HWU is opened, says that there is something else running and that HWU can turn it off. Does this sound familiar?

Share this post


Link to post
Share on other sites

Also how do I make sure the comm port is selected to regular?

Share this post


Link to post
Share on other sites
11 minutes ago, JBruckert said:

Also how do I make sure the comm port is selected to regular?

On the Tray Lightbulb: Start the Network Utility.

 

That is where you can shuffle the KNOWN com ports between the adapters (Regular is the first one) you have

Share this post


Link to post
Share on other sites

Thanks everyone. The known comm port regular was not selected to comm 3. I have now switched regular to comm 3 and now show runs perfect

Share this post


Link to post
Share on other sites
3 hours ago, JBruckert said:

Thanks everyone. The known comm port regular was not selected to comm 3. I have now switched regular to comm 3 and now show runs perfect

Next time if you get that pop up in the HWU, that is normal, tell the HWU, yes, it is okay to turn it off, then another pop will ask if you're sure you want to do that {if memory serves}, but select yes or OK on both pop-ups from the HWU

Once I got everything back together, the next time I wanted to test my RGB Controllers via the HWU, it asked me if I wanted to change to the RGB Comm port {Comm 4} to run my shows again, I selected No and I also checked the little box down in the lower left corner of this popup top "Never ask me again", that way when I swap between comm 3 or comm 4.

Now I don't get asked "Is this the comm port you want to run your shows from" again, the first few times I was swapping comm ports, I kept telling it yes for that, because I thought it would make BOTH comm ports active, it doesn't, as long as Regular is the main active Network, all the rest will work, and don't need to be confirmed in the HWU, just in the Network Configuration software and saved.

So you may want to disable that question about "Is this the comm port you want to use for your show", this is so you don't accidentally swap your comm ports again.  

Sure has save me a lot of headaches, however, when you swap to the Aux Network the HWU will always have 2 popups asking questions, just say Yes and OK to swap ports to test your RGB lighting or whatever is on the 2nd Aux Network.  

You DO NOT need to swap it back to comm 3, you can just close the HWU and everything will be as it should, it'll default back to the Regular Network {from what you set in the Network Config file}, and you shouldn't have any other comm port issues from there at least.   Not unless you tell the HWU to select the wrong comm port again, that's why I disabled that particular popup question.

The only time you'd say No to the comm port pop up in HWU is if a show is running, as the comm ports will be in use, close the HWU, then disable the show, then re-open the HWU for testing purposes or adding a new controller to test or set up.

Happy Lighting!

Edited by Orville

Share this post


Link to post
Share on other sites
11 hours ago, TheDucks said:

On the Tray Lightbulb: Start the Network Utility.

 

That is where you can shuffle the KNOWN com ports between the adapters (Regular is the first one) you have

In the pop up menu from the light bulb icon it's actually called "Network Preferences", left click the light bulb to access it from the task bar area.  In the Windows pop up area from "All Programs" in the Light-O-Rama folder it's called "Light-O-Rama Network Configuration".

I have some of these {the ones I use most often} set as short cuts on my desktop area as well, not necessary, but I like them there.

Share this post


Link to post
Share on other sites

Thanks for the reply and all the information. It has been a huge help. 

 

One more question, I have 6 controllers total, I’m just daisy chaining them together, do I need to utilize the second aux2 port, or can I run them all from one comm 3 port on regular network?

Share this post


Link to post
Share on other sites
51 minutes ago, JBruckert said:

Thanks for the reply and all the information. It has been a huge help. 

 

One more question, I have 6 controllers total, I’m just daisy chaining them together, do I need to utilize the second aux2 port, or can I run them all from one comm 3 port on regular network?

Yes, that is hardly enough to require a second network. Daisy chain away.

JR

Share this post


Link to post
Share on other sites
2 hours ago, JBruckert said:

Thanks for the reply and all the information. It has been a huge help. 

 

One more question, I have 6 controllers total, I’m just daisy chaining them together, do I need to utilize the second aux2 port, or can I run them all from one comm 3 port on regular network?

That also depends on controller type as well.  If any are the older controller CTB16PC types and you also have newer ones {G3 Controllers}, the older units CAN NOT run on the 500K speed, they CAN NOT run on an Enhanced Network like RGB Lights prefer.  

Even if you have CTB16PC G3 Controllers and current RGB Light Controllers, I'd still separate them into separate Networks, CTB16PC on Regular, and RGB on Aux A, 500K, Enhanced. 

But you need 2 USB485 Adapters to do that, red High Speed for RGB and Gen 3 Controllers {if you want 2 Networks}, older CTB16PC can use the black USB485 adapters  

If older CTB16PC's and RGB Controllers are on the same Network, this can cause erratic lighting, lag times and music skips.  

I have older CTB16PC Controllers and RGB Controllers, so I required 2 Networks to run my show without any glitches, such as was previously mentioned, as I had those issues really bad before I broke mine into 2 separate Networks!

If they all are the same G3 Controller {CTB16PC}, then Daisy-Chaining them together is fine, and only one Network is needed.

Edited by Orville

Share this post


Link to post
Share on other sites

Ok thanks good to know. I have all new g3 controllers. I just had to buy news ones because I lost the hardware utility for my d-light controllers I used to use. Too bad but I like the LOR controls and programs better. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×