Jump to content
Light-O-Rama Forums
ukoberon

Trouble shooting and test guide for CTB16PCG2 V4 ?

Recommended Posts

looking for a troubleshooting/test guide and any schematics so i can try and fix my CTB16PCG2 V4 Controller.  it blew very quickly in use 2 years back i think and i left it sat in its box until  i got around to looking at it again a few weeks ago. There is some scorching damage showing on the board around the F2 area although the circuit does seem to be in place from hot input to the slightly exposed copper track just under the word Fuse  - the fuses are all in tact but i dont seem to be able to get the board on . Previous suggestion was i may need to surface mount a connection wire but i cannot see between which points as neutrals all connect on test meter. what points should i be testing between to see if circuit exists? Had a look through LOR guides but boards i can find are different versions.

 

thanks

lor6.jpg

Share this post


Link to post
Share on other sites

Looking through this forum i am thinking actually my board is G3 but screen printed G2?

lor5.jpg

Share this post


Link to post
Share on other sites

I have 4 of those controllers that were misprints. If it has the little LED it is G3. If it has the globe type bulb it is g2. (I cant see good this morning). Also it would show up in HU as G3 however since its not working probably not an option.

JR

Share this post


Link to post
Share on other sites

so the screen print on the board says CTB16PCG2 V4  - but have seen that there was a labelling issue back when this was produced....it is LED rather than globe. - so now i need to find a diagnosis and ffault finding process for this board as it doesnt light on power up.

Share this post


Link to post
Share on other sites
18 minutes ago, ukoberon said:

so the screen print on the board says CTB16PCG2 V4  - but have seen that there was a labelling issue back when this was produced....it is LED rather than globe. - so now i need to find a diagnosis and ffault finding process for this board as it doesnt light on power up.

Correct as mentioned I have 4 of those in my arsenol.

LOR can repair (probably) at a cost that is normally reasonable considering what they cost

JR

Share this post


Link to post
Share on other sites

Thanks JR - the cost of shipping back to the US and back to the UK plus the repair probably means its a write off sadly.

Share this post


Link to post
Share on other sites
1 hour ago, ukoberon said:

Thanks JR - the cost of shipping back to the US and back to the UK plus the repair probably means its a write off sadly.

LOR use to have a trade-in program not sure if it still exists. You could trade in an older item for 40% off a new item.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...