Jump to content
Light-O-Rama Forums
dannh

Pixel setup question

Recommended Posts

This may be dumb, but I can't seem to find the answer in any of the documentation.

I have a CCR2, with 2 strands of 100 pixels and have a couple questions:

Does each port have it's own ID, or is it just a continuous ID?

In pixel editor what would my setup be to control all 200 pixels? Would it be 600 channels? 

 

Share this post


Link to post
Share on other sites

2 Unit ID’s

I set my controllers up in SE and not up in PE.

CCR 2 is a pixie2

In SE right click on a channel butto

Add device above or below

Add Pixie

Add pixie 2

Set at 100 pixels strings and the rest is done for you

Please add software version to your profile.

JR

Share this post


Link to post
Share on other sites

Software updated.

Ok so you do all your RGB editing in sequence editor? Seems like that would be a lot of work

Share this post


Link to post
Share on other sites

In the pixel editor you build a prop first then assign the amount of pixels to that prop and the ID number and start channel of that prop

Share this post


Link to post
Share on other sites
57 minutes ago, dannh said:

Software updated.

Ok so you do all your RGB editing in sequence editor? Seems like that would be a lot of work

I use SuperStar mostly

JR

Share this post


Link to post
Share on other sites
On 6/12/2018 at 11:29 AM, dannh said:

This may be dumb, but I can't seem to find the answer in any of the documentation.

I have a CCR2, with 2 strands of 100 pixels and have a couple questions:

Does each port have it's own ID, or is it just a continuous ID?

In pixel editor what would my setup be to control all 200 pixels? Would it be 600 channels? 

 

When I set my CCB100 up in SE, it's just one unit ID, I gave it 01, it's  2 strands with 50 RGB bulbs per strand, total of 100 bulbs, it shows up in my SE as CCD 01 s1 for the first strand, the second shows up as CCD 01 s2.   So my RGB controller only has one actual physical ID of 01, but the SE splits it into two "S"ections, s1 and s2.  Works out great for me.

Share this post


Link to post
Share on other sites

yea I'm not sure what I'm missing. Hardware config verifies that I've got my CCC on ID 3, and tests fine. Pixel editor has everything set for ID 3. Go into sequence editor, everything is still set for ID 3. Go to play and got zilch.

Going to take a brief sanity break from it all ;)

Share this post


Link to post
Share on other sites
2 hours ago, dannh said:

yea I'm not sure what I'm missing. Hardware config verifies that I've got my CCC on ID 3, and tests fine. Pixel editor has everything set for ID 3. Go into sequence editor, everything is still set for ID 3. Go to play and got zilch.

Going to take a brief sanity break from it all ;)

You have to set your comm port!

That will fix it up.

Ensure that whatever comm port your HU finds it in that it is the same in your network config in SE.

Do not refresh your comm port (top left) in HU. When setting up controllers in HU only refresh the unit (top center)

JR

Share this post


Link to post
Share on other sites

Also keep in mind that the original CCP and CCB you could change the settings (normal or dual normal) to make it act a one long string (normal - one unit id) or two seperate strings (dual normal - two unit id's). The new ones are considered a pixie 2 and automatically uses two unit id's. You assign the base id (you assign id 1) and the software automatically assigns the second id to the second strand (software assigns id. 2).

Share this post


Link to post
Share on other sites
6 minutes ago, dannh said:

com31.PNGcom32.PNGYea I checked that, Comm/COM 3 on both. 

Your setup is using ID3 for one string and ID4 for the second string.

Share this post


Link to post
Share on other sites
4 minutes ago, Mr. P said:

Your setup is using ID3 for one string and ID4 for the second string.

Sorry where do you see that?

Share this post


Link to post
Share on other sites
Just now, dannh said:

Sorry where do you see that?

In the top blue highlighted area it says,  03-Oixie2-ver 1.03,  it shows you assigned ID 03 to the controller. Since Pixies automatically assign an ID to each port that means the second port (string) on that controller is ID 04.

Pixie controller are different, you assign the base ID and the software assigns a ID to each port. A Pixie 2 will use two ID's, a Pixie 4 uses four I'D's, a Pixie 8 uses eight ID's and so on.

Share this post


Link to post
Share on other sites

Ok so it should be using ID 3 for the first port of 100 pixels, then ID 4 for the 2nd port of 100 pixels. I had it setup that way at first then someone said it was all one, let me change it back and see. 

Share this post


Link to post
Share on other sites
9 minutes ago, dannh said:

Ok so it should be using ID 3 for the first port of 100 pixels, then ID 4 for the 2nd port of 100 pixels. I had it setup that way at first then someone said it was all one, let me change it back and see. 

As I stated earlier, you could run the originals in Normal, Legacy or Dual Normal modes. The new Pixie 2 can't be programmed that way. In the Pixie series controllers the number of ports determines the number of unit ID's that will be used.

Share this post


Link to post
Share on other sites

port.PNG.17861d7e6f4160be08c376d1e99e9530.PNG

 

Made the change but no difference. Neither string lights up at all. I did note that I had the hardware utility up and running when I first loaded the song to play and it did mention port 3 was already in use (I had to close the hardware utility) so it's definitely on the right com port.

Share this post


Link to post
Share on other sites
4 hours ago, Dennis Laff said:

Are you sequencing in the pixel editor 

I've got pixel editor on one machine that I've been testing, and on another machine I've upgraded to the 5 beta and tested it there in the sequencer. Both had the same result.

Share this post


Link to post
Share on other sites
1 minute ago, Dennis Laff said:

If your sequencing in the pixel editor in lor mode  that controller needs to be set to enhansed mode in network Preferances 

They can't use enhance mode as they have a Basic Plus licence. (At least that is what their profile states.)

Share this post


Link to post
Share on other sites
8 minutes ago, dannh said:

I've got pixel editor on one machine that I've been testing, and on another machine I've upgraded to the 5 beta and tested it there in the sequencer. Both had the same result.

Pixel Editor and Enhanced Mode are Pro License only.

Share this post


Link to post
Share on other sites

Sorry I upgraded it yesterday to Pro. Didn't get a chance to change this.

trying it with enhanced now 

 

Edited by dannh
found enhanced

Share this post


Link to post
Share on other sites
3 minutes ago, dannh said:

Sorry I upgraded it yesterday to Pro. Didn't get a chance to change this.

I'm not seeing a option to change to enhanced in the network preferences

 

 

In Network Configuration click on the comm port being used (comm 3 for you) and another window opens. The enhanced box is at the bottom.

Share this post


Link to post
Share on other sites

Yep, those screen shots are the newer versions.  I haven't upgraded yet, so have no idea what pixel editor is or can do, have no way to text RGB devices in my HWU like that.  I have to do it manually since I'm still using ver. 3.8.2.  Sure hope I can upgrade my software by the end of July or early August.   Especially since I am getting into smart RGB lighting {LOR} and definitely need to upgrade to the newer versions for that and get the Pro license in the upgrade.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×