Jump to content
Light-O-Rama Forums
DisneyMatt10

BGR to RGB Issue??

Recommended Posts

So, random question for you all to see if anyone knows what the heck we have done...

We had some flickering issues... So we installed some null pixels (which has helped in the same issues else where on the house) ... After we installed these null pixels and we started testing... ONE of the strips that was a BGR strip has suddenly changed to an RGB strip (in the way it is displaying the colors) ... I have no idea what we did... or how it was possible... But yeah... That happened. Thankfully changing it in the PE was an easy fix... But I am still perplexed by what happened. Anyone ever experienced this before?? 

Share this post


Link to post
Share on other sites

Where the null pixels from the same strip if not that could be the problem null pixels RGB ? strip BGR.

Share this post


Link to post
Share on other sites

That's bizarre.  I've never had to use null pixels anywhere, but several years ago I had a pixel right in the middle of a string on my pixel tree fail.  The failure caused the rest of that string to go full white all the time, so I could not just ignore it.  I had no spares for those 5V WS2811 square node pixels.  If I just cut that one pixel out and bypassed it, the rest of the string would be off by one pixel which would look strange on some effects.  My solution was to replace the bad square node with a single pixel from a WS2811 strip.  You guessed it, the color order was wrong, so I just covered it with black tape so the one pixel would appear to be dark and the rest of the string would be in the right place.  That worked perfectly until a member of the forum sent me some correct pixels (faster and cheaper than a small order from Ray Wu).  So, based on my experience, it should not cause a problem...

 

Share this post


Link to post
Share on other sites
17 hours ago, Dennis Laff said:

Where the null pixels from the same strip if not that could be the problem null pixels RGB ? strip BGR.

The null pixels were from the same type of strip. (Both BGR) 

However, we just ended up replacing both of the strips today and the show is back up and running great tonight! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×