Jump to content
Light-O-Rama Forums
  • Announcements

    • DevMike

      Fire at LOR in Glens Falls, NY   01/17/2018

      A fire has broken out in the same building that houses the main LOR offices.  More information can be found in 'Important Announcements'.  
JamesWright

Show Player Problem

Recommended Posts

I tested my full show tonight and ran into a major problem that I can't figure out how to resolve. I am getting HUGH delays between sequences on the first time through the show. I am experiencing black (no lights) for a minimum of 7 seconds to over 20 seconds, using 5.0.14. I assume that the player is loading each sequence as it needs it because CPU and disk access go up noticeably during the "no show" run. I have not had this problem with LOR software for a long time. The problem does not happen during subsequent runs through the show, just the first time. Is there a way to correct this issue in 5.0.14 or do I need to move this comment to the bugs section?

Jim

Share this post


Link to post
Share on other sites

The show player is creating the compressed sequence file on the first pass if it Is not present. After that the files will load fine until you make a change to a sequence. You can turn off compressed sequences but then it may load slowly always.

Share this post


Link to post
Share on other sites
52 minutes ago, PhilMassey said:

The show player is creating the compressed sequence file on the first pass if it Is not present. After that the files will load fine until you make a change to a sequence. You can turn off compressed sequences but then it may load slowly always.

This is true and depending on the size of the sequence it will take time for Show Player to load and compress the file. I find it helpful after I get a show organized is to manually compress the sequence before running so that Show Player does not have to.

Sequence Compressor is active again in 5.0.14, i think it was there in 5.0.12 also.

Alan...

seqcomp.png

Share this post


Link to post
Share on other sites

Thanks to the Phil and Default for the great information.

Unless my mind is failing me, in previous releases, such as S4, I think all we had to do was select an option to save as a compressed file and that was the end of it. Now we have to:  1. Save the sequence, 2. Generate the .play file, then,  3. In a completely different place, remember to generate the compressed file.

I would like to suggest an enhancement to S5. I suggest an option to generate and save the .play as a compressed file automatically, instead of having to go thru 2 separate steps. I realize that this will take awhile longer in the process, but then there is no more that needs to be done. After all, as far as I know, the only reason to generate a .play file is to run it in a show.  Having this feature added would avoid a lot of possible confusion and extra work on the user's part. Now, if I want to make a change in a sequence, after I have set up the show, I need to remember to generate a new .play file and then, in another section of the program, compress that new .play file so that there will be no interruption in the playing of a show.

Just a thought

Happy Thanksgiving All.

Jim

Share this post


Link to post
Share on other sites
3 hours ago, JamesWright said:

I would like to suggest an enhancement to S5. I suggest an option to generate and save the .play as a compressed file automatically, instead of having to go thru 2 separate steps.

Thanks for the suggestion! We will certainly be working to make this process simpler going forward.

Matt Brown

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×