Jump to content
Light-O-Rama Forums

Recommended Posts

I've been having repeated problems with getting redundant channel errors after resolving the errors. For instance, today I went to play my test sequence and was given a whole bunch of redundant channels that needed to be resolved. Some I switched to their actual correct channels and some I set to undefined because I don't have controller numbers for them yet. I saved my changes, closed the sequence and opened up the hardware utility to test some other things. Then I went back into my test sequence and tried to play my test and I got the same redundant channel errors. Thinking that it was somehow related to the preview (after several weeks of sequencing I still don't really understand how previews work), closed the sequence, deleted the preview, opened the sequence and used the preview that it said was associated with the sequence. Despite this, I still go the same errors. The errors that I was getting were errors that I had fixed not more than 20 minutes earlier and I had saved those changes. Any idea why?

I'm also having trouble with trying to then take that test sequence and apply the channel / controller setup to my show sequence and having it bring all of my changes over, especially because my test sequence is on a different computer than my show sequence. So the preview that I was using on one computer isn't there as an option when I bring it up on a different computer. I'm looking for the same kind of functionality as the old S4 way of doing things where I could make a bunch of changes to controllers / channels in one sequence, export the channel config and then import that channel config into a different sequence and all of my changes will be there. I haven't found a way to reliably do this yet. Any ideas?

Share this post


Link to post
Share on other sites

All of your channels are defined in the preview, not in the sequence. You no longer need to export a channel configuration from one sequence and import it into another -- as long as all of the sequences refer to the same preview, a change in the preview gets reflected in all sequences. However, if the channel assignments change in the preview you *will* need to go back and resave the playback files for each sequence (eventually, we will eliminate this step).

Previews are stored in this file:

\Light-O-Rama\CommonData\LORPreviews.xml

A backup copy of the preview assigned to a sequence is stored inside the sequence file. That way, if you decide to share your sequence with others, or your preview file gets damaged, the preview can be restored from the sequence. But the preview stored in the sequence is a *backup* -- if the preview is already in the preview file, the preview in the sequence file is ignored.

You should be copying the playback files to the show computer. These have an extension of .PLAY.LMS and .PLAY.LMS.PE.LID (or .PLAY.LAS and .PLAY.LAS.PE.LID for animation sequences).

I hope that helps,

Matt

Share this post


Link to post
Share on other sites

Not sure if this is related to the same problem addressed above but, I just uploaded 5.0.14 to see if it works for me. I made a preview (to include a few new props) of the display. However, when I look at Superstar, I'm getting my old preview popping up on the bottom half of the screen that I did using Visualizer. THAT visual was not capable of reading greater than 50 pixels in a string, so I was having an issue with one of my props that was 66 pixels in a ribbon (it was recommended I try S5 since it allowed me to work with more than 50 pixels in a string). How is Superstar (the 5 version) able to read my updated preview?......I've attempted to import into Superstar (under File-Import Visualization) but can't locate the file that is my current preview just made. I thought they were able to work this way in conjunction. I can't update the old visual model, since Visualizer is no longer available as a separate entity, of course. As it stands right now, the new updated layout of props in S5 on the bottom left of the screen under new animation sequence doesn't match what Superstar has (the old Visualizer model). So, if I insert a Superstar sequence in the Sequencer, I'm going to have problems. Any tips or answers as to make this happen, that would smoothly address my greater than 50 pixels issue and the added props?

Share this post


Link to post
Share on other sites
39 minutes ago, Inashesiwillreap said:

Not sure if this is related to the same problem addressed above but, I just uploaded 5.0.14 to see if it works for me. I made a preview (to include a few new props) of the display. However, when I look at Superstar, I'm getting my old preview popping up on the bottom half of the screen that I did using Visualizer. THAT visual was not capable of reading greater than 50 pixels in a string, so I was having an issue with one of my props that was 66 pixels in a ribbon (it was recommended I try S5 since it allowed me to work with more than 50 pixels in a string). How is Superstar (the 5 version) able to read my updated preview?......I've attempted to import into Superstar (under File-Import Visualization) but can't locate the file that is my current preview just made. I thought they were able to work this way in conjunction. I can't update the old visual model, since Visualizer is no longer available as a separate entity, of course. As it stands right now, the new updated layout of props in S5 on the bottom left of the screen under new animation sequence doesn't match what Superstar has (the old Visualizer model). So, if I insert a Superstar sequence in the Sequencer, I'm going to have problems. Any tips or answers as to make this happen, that would smoothly address my greater than 50 pixels issue and the added props?

Have a look at this thread:

And this thread:

 

Share this post


Link to post
Share on other sites

Thanks Matt, got it going...albeit in limited fashion. Only my props that have smart rgb LEDS are able to be programmed via Superstar (right click in the yellow box, insert SuperStar effect). When I right click on a row corresponding to props that have dumb rgb LEDS or are the regular variety of string lights, that "insert SuperStar effect" option is not there. Is that a beta limitation currently, or is there another roundabout way of getting to it? Also, I don't know if SuperStar would even provide me access to the new props I added in S5 preview, since I am unable to do that "insert SuperStar effect" for those. It certainly would be nice to have that option (if it doesn't exist) for dumb rgb's and regular string lights. I'm thinking it would, since the smart LED ribbon that I had with 66 pixels (that didn't work in S4) worked great in the S5 preview screen section. I must also mention that I tried doing a prop group SuperStar insert, as well (click and drag the yellow box over a group of props) and it didn't offer an "insert SuperStar effect" either. That certainly would be nice to have if you wanted continuity in multiple props with the effects that SuperStar came up with.

Share this post


Link to post
Share on other sites
4 hours ago, Inashesiwillreap said:

When I right click on a row corresponding to props that have dumb rgb LEDS or are the regular variety of string lights, that "insert SuperStar effect" option is not there.

You can add a SuperStar effect to any motion effect row.

* Groups created in the preview will have motion effect rows, as long as the group's arrangement is not "none".

* For non-pixel props, right-click on the prop name and select "Add motion effect row". Now you can select a region on that row, right-click within the region, and "Insert SuperStar Effect" will be included in the pop-up menu. Non-pixel props do not get displayed correctly once SuperStar opens --- this is a bug we are working on.

Matt

Share this post


Link to post
Share on other sites

okay, thank you. That was easy! That issue seems to be cleared up. Only you can't insert SuperStar effects on multiple motion effect rows at the same time (drag the yellow box over multiple rows). Forgive me if this has been covered in another thread, but is that something that could be added in the future to S5 to get continuity between props for effects during a song (in other words, not having SuperStar effect props all doing the same thing during the same song at the same time)?

Share this post


Link to post
Share on other sites
2 hours ago, Inashesiwillreap said:

you can't insert SuperStar effects on multiple motion effect rows at the same time

If you want to add a SuperStar effect to multiple props at once you will need to create a group in the preview. The preview group should contain all of the props you want to sequence together. The arrangement setting of the group specifies how the props are related to one another spatially. An arrangement of "none" does not allow motion effect rows, so don't use that one. An arrangement of preview also probably won't work well for SuperStar effects. Any of the other arrangement types should be fine.

Once the group is created, you can add it to your sequence's current grid view and add motion effect rows to it.

It may take some trial and error to create a group that loads up they way you want in SuperStar.

Matt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×