Jump to content
Light-O-Rama Forums
woodinvillejohn

Pixcon 16 color shift

Recommended Posts

Hello,

First year adding pixels and what a learning curve.  Trying to get everything going has challenged me.  I finally got it all going and have an issue with  my new 4 pixel arches run off a pixcon16 controller.  When the arches light up there is a big color change from what is programmed.  My red is showing up as Blue and Yellow shows up as green, purple shows up as a green/blue.  This happens in all 4 arches.  2  arches are within 3 feet of controller.  The other 2 are within 12 feet.  The color is constant in all of them.  My whites are not too bad, maybe a little blue, but acceptable.

I'm not sure where to go with this.  Is this a pixel issue (Ray Wu 100 pixel strips), or a controller set up issue (pixcon16), or could I have done something when I set up the visualizer or superstar sequences that affects color?

When i view the sequences in superstar and the sequence editor the colors all appear correctly.  Has anyone else experienced this?

Thanks for your help.

Share this post


Link to post
Share on other sites

Change the order to GRB and that should fix it.  Rob 

Share this post


Link to post
Share on other sites

I’m going to explain Rob’s correct answer in more detail.  

When a pixel controller sends data to a string of pixels, for each pixel, it sends the data for one of the primary colors, then the data for another primary color, and then the data for the third primary color.  It then repeats that process for each pixel in the string.  Note that I did NOT say which primary color is sent first, second, and third.  When pixel chips are manufactured, the order in which the the colors are expected is set.  This order of colors CAN NOT be changed by us end users, and it can (and likely will) differ between different string or strip types, or even between different production batches.

The only thing we can do to handle this change of color order is to send the data in whatever order that the pixels are expecting it.  Fortunately for us, all the pixel controllers can handle this for us.  There will be a setting in the pixel controller setup for color order.  If you think about it enough, you can test a string and determine the order in one test, but in reality, I suspect that most people simply keep trying the option until they get the one that works right - there are only six options so that’s not hard.  

BTW, this is one of the reasons that it is generally recommended to buy spare pixels at the same time as you buy the pixels for some prop.  If you find that later you need some replacement pixels, even if you get them from the same source, they may not have the same color order - MAJOR problem.

 

Share this post


Link to post
Share on other sites

I would also like to add that some controllers can change the RGB order for each port and others will only change the RGB order for the entire controller.

Share this post


Link to post
Share on other sites
17 minutes ago, Mr. P said:

I would also like to add that some controllers can change the RGB order for each port and others will only change the RGB order for the entire controller.

I was going to add that (thought about it right after I posted me message), but needed to get off my train...  Thanks Mr. P

 

Share this post


Link to post
Share on other sites

Just to be useful, here is a partial screen capture of one of my SanDevices E682 controllers.  The green arrow points out where you set color order on this controller.  BTW, for other SanDevices users who don't recognize this screen, this controller is using SanDevices beta firmware 5.023 and the screens changed.  You can ignore the red arrow as that was done to answer a question in a different message thread.

Null_Pixel.png

 

Share this post


Link to post
Share on other sites

Thanks to all of you.  As i was lying in bed last night it dawned on me that the RGB order must be incorrect.  I was thinking i would have to change the wiring at each port.  I'll see what i can figure out for the Pixcon 16 settings.  I don't find this controller to be very easy to set up, but that might just be me.

 

Thanks again.

Share this post


Link to post
Share on other sites
2 hours ago, woodinvillejohn said:

Thanks to all of you.  As i was lying in bed last night it dawned on me that the RGB order must be incorrect.  I was thinking i would have to change the wiring at each port.  I'll see what i can figure out for the Pixcon 16 settings.  I don't find this controller to be very easy to set up, but that might just be me.

 

Thanks again.

You can't change the wiring at the port. The wiring is inside the lights themselves and the info for those lights is sent on the data wire. If you go into the advanced settings of the Pixcon you can change the RGB order for each port of the Pixcon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...