Jump to content
Light-O-Rama Forums
JoeFerone

iDMX 1000 Help

Recommended Posts

This is my fifth year decorating first time using this DMX controller bought it there is really no instructions I went online and tried going from the user manual didn’t really make much sense I got it to work and hardware or utility but I can’t get it to work in sequence editor can anyone help me with this please thanks joe

Share this post


Link to post
Share on other sites

It's more then likely your channel config in SE if it works in the HU, what are you trying to run and how are the channels set up?

Edited by Mr. P
  • Confused 1

Share this post


Link to post
Share on other sites

Uh I have 5 normal controller for lights and then I was gonna have the 5th controller go into the DMX one but I was just trying to program a light I had from my dads job to work with it it’s on E0 in HWU but I try to go E0 in sequence editor and it doesn’t do anything 

Share this post


Link to post
Share on other sites

If the fifth controller is a 16 channel ac  controller it can be controlled by dmx but it can't controll any Dmx lights 

Share this post


Link to post
Share on other sites

First thing you need to do is re-ID the DMX1000. Do not have it end in "0" (zero) So rename it from E0 to 1-9, E1, A1 but nothing with a "0" that keeps the DMX1000 in what was legacy mode. So it would only support 256 of what is 512 DMX channels in a DMX Universe. Might not be critical, but you should know this. 

The Hardware Utility will see it, if there is nothing wrong with the DMX1000. You have to go into the "Console" which is next to the "Help" and "Exit" button at the top right of the UI. Once in the console you set it up to speak to the DMX1000. If you do a search, you need to ensure you have your Max Unit ID set way out there beyond what you listed as E0.

Next the DMX1000 can be anywhere in your LOR network. You dont need it at the end.

Also, an LOR controller with no modifications (except it has to have one of the newer firmware updates) will react to LOR commands, or DMX. It does not need to be connected in any way to the DMX1000.

All this said, it is sort of assumed you have some fundamental understanding of DMX. DMX is just like LOR, you just have to understand it first. On my website in my signature, I have a How-To page that has some basic DMX presenations I have done over the years at various mini meetings, or Christmas Expo. 

Explain what you are trying to accomplish.

Edited by zman

Share this post


Link to post
Share on other sites

Not to hijack the OP but I am having the same issue he was.  Mark, I spent a lot of time looking at all of your DMX how to's.  I have my idmx1000 ID set at A1 just like your how to showed.  I am trying to get my Chauvet SM250 snow machine to kick on.  I have my SM250 set to starting address 1.  When I am in HU, My Unit ID is set to A1 and when I try to slide channel 1 up to a value that says it will produce snow but nothing happens.  I feel like I am missing something simple here and any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

RDVC what license do you have? You need to have at least an "Advanced" license of the software.... to output DMX.

Share this post


Link to post
Share on other sites

I currently have the standard license.  I guess this is where I am also confused too. I was on the LOR software version page and it stated that I could use my standard license for DMX (via the idmx1000). Advanced was only needed for DMX (native).

Share this post


Link to post
Share on other sites

Good point, I don't know know for certain how that affects things. May be a good question to ask the Support Team or hopefully someone chimes in. I have always had the max license from LOR...

In the HU are you setting the Controller Type to one of the iDMX1000 and the Channel Mode to Extended Circuits? In the HU is the iDMX found, and do you have your Max Unit ID set far enough out that A1 is found?

Share this post


Link to post
Share on other sites

In HU the idmx is found and I have tried the extended circuits. I have my max unit to F0 currently which should be the max. The status light is solid on the idmx and the data light is flashing. Just trying to add all the info I know.

I will try and open a ticket to see about the license issue too if I don’t hear anything thing else form the group. 

Share this post


Link to post
Share on other sites

There is a little confusion when it comes to using the iDMX and what level of software you need.

As Mark said, the first thing to do is get that iDMX set up with a NON 0 ending address.  It is confusing to leave it at 0, and legacy mode has not been required for quite some time.

Now is where the software level comes into play....

NATIVE DMX requires Advanced or Higher.  What is Native DMX?  Anything that uses a DMX adapter (like an Entec or one of our USB adapters), or E1.31.  You are going to be setting the channel up in Sequence Editor (PE/Sequencer or SS) as a DMX channel.

DMX Via an iDMX1000 requires nothing more than Basic - the iDMX is a bridge and it accepts LOR commands and outputs them as DMX.  Since it accepts LOR commands it is NOT native DMX.  In the sequence program you will set up the channel as an LOR channel (even though it eventually goes to a DMX device).

HOWEVER...  The Unit ID restrictions of the software DO come into play when using an iDMX.  In other words, you could use your iDMX1000 set as unit ID 01 or ID 02 with Basic.  But if you set it to 03 (or higher) it is no longer going to work.

Share this post


Link to post
Share on other sites

Thanks DevMike for the additional info.  So if I change the iDMX unit ID to 01 or 02, should I be able to still control it in console mode in HU just to test it?  And if I did leave the iDMX at 01 or 02, I would just change the IDs of my other LOR controllers that are currently 01 to something higher?  

Share this post


Link to post
Share on other sites

I just wanted to THANK Mark and Mike for all of your help today. 

I was finally able to figure out after all of the suggestions and troubleshooting on my end that there was no issue with the iDMX or the software.  The DMX connection on my snow machine seems to be broken as I was able to get a friends DMX light to work.  Always something..........

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×