Jump to content
Light-O-Rama Forums
alchrisr01

pixcon 16 & e682 on same network, what do i need to set this up?

Recommended Posts

Hi folks,  I am expanding a bit and adding a second RGB controller (pixcon 16).  I plan to run in e1.31 as I already use an e682 for the pixel tree.  If I understand all I need to do is install a network gigabit switch to direct the traffic and make sure that the pixcon is set to run as e1.31.  I have misplaced my notes from the initial setup a few years ago of the e682 so i don't know why some of my settings are as they are but the IP address of the controller is 169.254.74.73. The settings  for the network adapter are set  for a static 169.254.74.1, subnet 255.255.255., and default gateway as 196.254.74.1.  I have nothing in the DNS area.  The e682 works fine here and can be accessed via the setup page for IE.  The factory default for the e682 is 192.168.1.206 and I don't remember why I had to change it to get it working, it has been awhile.  Now when adding the pixcon 16 it's Ip address is in the 192 range.  When I plug in the Ethernet cable (direct from laptop) and run the LOR network config to find the unit, click on the highlighted line to get into config, it ask to run the troubleshooter and changes the IP of the pixcon to 169.254.74.50 but I still can't get into the board config.  This has been driving me nuts.  I spent 5 or 6 hours last night online reading and watching and could not find the answer.  I did see that the 169 range of IP addresses is usually for wireless configs, so that may be why I have to disable the wireless adapter for this to work. So maybe I did learn something. :)  I may have a board issue as well due to the fact that all the pixels stay lit white when the board is plugged in.  I am not a network guy but could be considered an apprentice nerd with basic understanding at best.   Do I need to re-name all my IP addresses to the 192 range?  Will I need to change any config info in SE if I do that? Any advise would be great.

 

Thanks,

Chris

Share this post


Link to post
Share on other sites

Your best bet is to change all the IP addresses and use the 192.168.xxx.yyy as this is set aside for consumers.

As an example; my Local area Connection on my computer is set to 192.168.125.1 and my E1.31 controllers start at 192.168.125.50. I have 14 E1.31 controllers and they are all set to static  so they go from 192.168.125.50-63. This way I know what every controller is hooked up to and when I program LOR in my Network Config I can use Unicast instead of Multicast.

  • Like 1

Share this post


Link to post
Share on other sites

Yes, you have IP config issues.  That's why stuff is not talking.  Short answer is that the computer, PixCon and Sandevices controllers all need to be on the same subnet.  I would darn near put money that your PC with an IP of 169.254.74.1 is NOT static, but rather a default IP because it's set for DHCP and there is no DHCP server on that LAN.  Since presumably you only have the two E1.31 devices and your PC on that LAN, you can in reality use almost any address rand that you want as long as all three devices have the first three octets the same and the fourth octet different.  However with that said, I would recommend that you use IP addresses in the 192.169.something.xxx.  I can give the technical answer as to why I recommend that  address range if you really want it.

Once you have the IP addresses set and everything talks to each other, you will need to use the Network Preferences to set the IP address for each universe IF you have the IP address setting to Specified (properly called Unicast).  If you have the IP for each universe set to Multicast, you do not need to specify the IP address.  BTW, I recommend that you use Unicast.  The E1.31 cards also need to be configured for Unicast.

BTW, you don't need a gigabit switch - a 10/100mb switch is fine and in fact the Pixcon does not even support gigabit, and I don't think the SanDevices does either.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the replies guys.  Most of what I read last night you two had posted and gave the most info as well.  I wish i could find my notes on why this is setup this way.  If I recall, the e682 manual states to use a static IP but my notes I did find say to set ipv4 properties to "obtain IP auto".  That just confused me.  I did set the laptop IP manually under IPv4 properties to the address I listed, it was set to auto. 

So this is my plan based on your response:  Reset pixcon 16 to factory IP (192.168.0.50), e682 to 192.168.1.206, and the laptop back to auto.   For simplicity I think I will leave the network config set to multicast.  These are the only e1.31 controllers on the network, everything else is AC.  LOR will remain the same I guess?

 

If I am wrong please let me know where I am going a-stray.

 

While typing this I was re-reading the e682 manual and found this on page 12:

"#2) You use a wireless network for your internet connection, and Ethernet jack on you PC is unused.

In this case you will connect the E682 directly to your PC's Ethernet jack using an Ethernet cable.  Typically, an unused PC Ethernet port will be given an IP address of 169.254.X.Y when Windows starts.  Therefore we will use an Override to force the E682's IP address to be within this range.  Perform the OVERRIDE function (described below) using an override code of 4.

 

Now, go back to the browser address bar and type this in: 169.254.74.73 and press ENTER.

 

Do you see the E692's web page?  If so, success, please jump ahead to Configuring, if not please re-read and repeat instructions in this section."

 

At least now I know where I got that IP address!  Looks like I need to grab a glass of tea and read that manual again.....

 

Thanks,

 

Chris

 

 

 

Share this post


Link to post
Share on other sites

First off, your computers wifi and ethernet are two seperate controllers and each can have its own IP address. Your wifi will be set on DHCP (what you call auto) as it will receive its IP address from the wifi router. Your Local Area Connection (ethernet) should be set to static as it will not be connecting to your router to receive an IP address so you should assign it as this would also keep it from changing.

Second, all of you controllers need to be in the same subnet as your computer. If your computer is 192.168.1.1 then all your controllers need to be in that subnet 192.168,1.xxx so they can speak to each other. Also, setting everything to static ensures that everything is assigned the same IP address every time it is turned on.

Jim (k6ccc) knows more about this stuff then I do so he will proably chime in soon but this should get you going in the right direction.

Share this post


Link to post
Share on other sites

And remember , No duplicates

192.168.x.1 is usually the router-gateway  (Microsoft also assigned this to the computer hosting (over dialup) Internet connection sharing (because it WAS the gateway).

Note: the subnet mask matches the addressing scheme used. The typical home uses class C : 255.255.255.0 . That say that any address starting with 192.168.1. (the same subnet) will not be routed, )

Using Mr. Ps example. turning your WiFi off and still connected to your LOR LAN (via cable), you will not be able to access anything on you main (home) network  The device needs 2 network ports to be able to bridge the networks

Share this post


Link to post
Share on other sites

Thanks again for the replies.  i just got done testing the setup again using your info.  Long story short, reset laptop to 192.168.1.1, left e682 alone = SE still controls lights.  Reset e682 to 192.168.1.68, test again and all is good.  Reset Pixcon 16 to factory defaults per manual, IP should be 192.168.0.50 - no access via I.E. but LOR network config does find it.  IP shows to be correct but can't access board config page.  Troubleshooter runs and sets a static board IP to 192.168.1.50, still not able to access either way.  I am leaning toward some sort of issue with the board as the LED's will turn full on (white) with the first in the string blinking.  I may need to open a trouble ticket.  Bummer, just got this in this week after UPS screwed the pooch on delivery and sent it back to LOR.

Forgot to mention that I left the default gateway and the DNS section blank.

 

MrP, do you know a guy named JR that lives near me?

 

Chris

Edited by alchrisr01
add info

Share this post


Link to post
Share on other sites

You need to go in and set the pixcon ip to static and set it in the same subnet as your computer, 192.168.1.xxx

I speak to jr all the time, great guy.

Share this post


Link to post
Share on other sites

That is sorta my problem, I can't access the config page either through IE or the LOR network config.  I get a pop-up box that wants to run the troubleshooter which is supposed to set a static IP for the pixcon.  When done and try to access through LOR network config I get another pop-up wanting to run the troubleshooter again.  I attached a pic of the pop-up box.  This and the strings staying full on lead me to think I have a board issue.  I though that if I could get into the config and make the setting, the lights would not stay on.

 

Jr knocked on my door one morning wanting to know if I still did lights.  He is compiling a list for our city so people can have a tour.  You retired Mil guys have lots of time! And deserve it.

popup.jpg

Share this post


Link to post
Share on other sites

Here is what you need to do:

Temporarily change your computers LAN IP settings to 192.168.0.xxx. Then go to the pixcon and force the default IP address of 192.168.0.50. To do this hold the Factory IP button down and power up the pixcon, release the button once it is powered up and the IP address will be set to its default IP. Go to your web browser and type in 192.168.0.50 and the pixcon settings should pop up. In the settings set it to static IP and set the IP to 192.168.1.xxx.

When all that is done go back and change your computers LAN settings back to what they were, 192.168.1.xxx and everything will be in the same subnet and speaking.

Look at pg 16 of the Pixcon manual.

http://www1.lightorama.com/PDF/PixCon16Manual-V1.5-Showtime(S4).pdf

Edited by Mr. P

Share this post


Link to post
Share on other sites

Thanks, but that did not work either.  I got the same results.  Just for giggles i set the adapter back to dynamic and gave that a whirl, no dice either.  LOR config would not even find the board.  I set everything back to 192.168.1.xxx so I know the e682 will work.  Strange that the utility will find the board and even change the IP but will not open the configuration screen.  I can't even access the board for IE.  I did not mention this before, but when I first plugged the Pixcon into the Ethernet jack and attempted to run the LOR network config, the board came up RED and I got a message that I needed to upgrade my software.  I installed 4.3.24 PRO (I was running 4.3.14 PRO) and then the board would show in the LOR config in WHITE.  I am not sure if that would have any impact on this.  Hopefully somebody from LOR will see this and chime in later.

 

thanks,

 

Chris

Share this post


Link to post
Share on other sites

I had a nice conversation with Jim (K6ccc) and we determined that my network configs are all working correctly but the pixcon still will not let me into the config screen.  I am leaning to the board itself having an issue as the lights will come on full white and stay on when plugged in.  I am not sure if there is a jumper issue or something else.  I have not changed anything on the board.  The green led is on constant and the red status led blinks fairly slow when powered up and the Ethernet cable is attached.  The LOR network config finds the pixcon and displays the info in white on the screen, but will not let me enter the config screen nor can I use IE to get in.  Jim was not familiar with the pixcon so we determined that maybe someone here or LOR may shed some light.  At least the network stuff is good to go so that does not seem to be the issue.

 

thanks,

 

chris

Share this post


Link to post
Share on other sites

Chris put a ticket in for this board, and it really does look like an IP config problem.

Jim, you helped him and I trust your judgement. Can you PM me and let me know your thoughts so I can assist?  THANKS!

Share this post


Link to post
Share on other sites

Thanks guys. I got back in town tonight and followed the instuctions from the ticket response. Still no dice. I seem to be stuck in and endless loop of troubleshooter windows. Btw. The board is stamped V1.3, the book that came with it says it is for V1.5. I was running SE 4.3.14 pro and when i initially plugged the board into the Ethernet port and found it with the LOR network config program,when i clicked on the found board I was instructed that my software could not access the board and needed to be upgraded. I am now on 4.3.24 pro. I say this because the help desk response stated that 4.3.14 would work. I have used laptop adapter set to static and dynamic plus rebooted after changing settings more times than I can count. I get the same response each time, endless troubleshooter windows asking to change the IP of the pixcon. The LOR config always finds the board and the line is white with the info contained in it seemingly correct. I am stuck. The e682 is not part of this equation. It is not in use nor has it even been accessed since i started trying to figure this out. I know how to make changes for that board to work so i am not concerned with it at the moment. I just need to access the pixcon config so i can set all the network configs.

Thanks

Chris

Share this post


Link to post
Share on other sites

Success!  I have been talking to the help desk on this and we have solved the issue.  Dev Mike mentioned using a factory reset router between the laptop and the pixcon. You can read my response to the help desk below.

I found and old Linksys wireless G router and used the ports on it.  I reset the pixcon to fact defaults, set the IPv4 to dynamic, reset the router to fact defaults.  Success!  I was able to get into the pixcon config screen and make the needed setting adjusments.  I now have connectivity and the pixels work as they should.  For whatever reason my laptop and the pixcon would not communicate without a router between the two regardless of the adapter settings.  To test further, I attached the E682 to an unused port and successfully connected via the IP address and ran the pixel test.  I then re-booted everything and ran SE to check pixel control from there.  Success!, sort of...Pixels connected to the e682 and the pixcon both ran simultaneous.  I guess I need to properly set my universes up as the pixcon has never been used on any of my sequences.  I did let the pixcon utility automatically set my universes upon exit and that may be the issue.

 

 

Thanks to all for the help.  Maybe this ordeal can help others

Share this post


Link to post
Share on other sites

Glad Mike was able to get the last step to making it work.

 

Share this post


Link to post
Share on other sites

thank you too, Jim.  I don't know if I missed the part about a router being necessary or something is goofy with my set up. Regardless, all is good now.

Share this post


Link to post
Share on other sites

I had this exact same issue and had tried everything until I read this post.  I noted that tech support had the user default the router.  I did that, but my router (Belkin) uses the 192.168.2.x subnet by default.  On a hunch I changed the subnet to 192.168.0.x and rebooted everything.  As soon as I did everything worked perfectly.  

Share this post


Link to post
Share on other sites

I am glad that we all learned something.:)  Maybe I missed it or maybe the instructions need to be updated to include that a router or switch must be between the PC and the Pixcon.  Now I need to figure out how to sequence these lumi-cans that I built!  I ran a test just using pixel tree sequences and they look pretty good.  There are 77 of them in total, 4 universes just to make programing easier, I hope.  I linked a test of the first 12 completed and a diagram of the setup.

 

https://www.youtube.com/watch?v=KLprM3KeaJ4

lumi cans_0001.pdf

Share this post


Link to post
Share on other sites

Two things here.

I'm not sure what is going on Charles Jones's case.  I regularly run the PixCon16 on 192.168.1.x (which is as different as 192.168.2.x is in the networking world) with a DHCP server and it works fine.  As soon as I get the time, I will set up my DHCP server to give out addresses in 192.168.2.x and see if there is still a problem.  I suspect that there is something wrong with Charle's configuration (or possibly the DHCP server that runs on that router), and setting the 192.168.0 set of addresses masks that issue.

The instructions, at least the checklist, DOES say to use a router between the computer and the board, and that is the easiest way to configure the PixCon16.  HOWEVER you don't need a router or a DHCP server, or any network hardware more than a CAT5 cable.  All you need is a properly configured computer and understanding of how IP works.  When testing PixCon code, I run in multiple configurations - including connecting directly, routed over separate LANs, a segmented LAN, and via a circa 1992 10 Base T HUB.  

As I have said time and time again, IP networking can be complex and does require some in-depth knowledge.  

Share this post


Link to post
Share on other sites

Hi Mike and thanks for your input in this.  You guys are the greatest.  I am no where near an expert in networking but I am pretty sure I had the adapter settings correct during initial testing and the only way I finally got into the config was to use a router.  I tend to blast trough instructions as I am an old man, after all.:)  Not being any sort of expert, this is what i read from the manual:

from page 7:

Should you need to reconfigure the board, or reload the firmware in emergency mode, the easiest way may be to connect the board directly to a computer’s network card via a CAT-5 cable. 1.Ensure no wireless network is active on the computer.   2.Shut down the computer and disconnect any existing network cable .  3.Power off thePixCon16.  4.Plug a CAT-5 cable directly from the adapter to the computer’s network card. A crossover cable is not required, any standard CAT-5cable will work.  5.Power up the board. Ensure the board is running correctly, or has been placed in the bootloader mode.  6.Turn on the computer and wait for it to fully boot.  7 Now start the LOR Network Configuration program and press the PixCon16 button. You should be able to find the board now to configure it, or to re-install the firmware.

from page 15:

Typically the controller is connected to a network of computers/controllers/etc. either though a switch or router. You can however directly connect the Ethernet port of the PixCon16 to a computer network card. This can be useful if for some reason your network configuration has changed, or you are having some other issue with configuration. Be sure to turn off any other network connections, including
wireless connections, and then re-boot the computer.
 
You are very correct that the "intro to DMX..." doc does in fact state in bold letters on page 7, "Before you start..Get a separate router".  I didn't interpret that to mean I needed a router since I read the above instructions and nothing else was connected to my laptop.  Rookie mistake on my part, but you can see why there was confusion.
Thanks for your patience and assistance.  I can send screen shots of my settings if it would help you figure this out as it seems I am not alone.
 
Chris
 
Edited by alchrisr01
correction

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×