Jump to content
Light-O-Rama Forums
PKingRoch

Debug/Repair single pixel on CCR

Recommended Posts

I have a CCR strip that is having an issue with Pixel #1's Red LED.  It's a little flakey and red doesn't always work, but it you press around on the area of the flex circuit items (traces, LEDs elements, etc), it will turn on and function.  Green and Blue work without an issue.  All other pixels work as expected.

I'd like to repair the strip or have it repaired as the cost of a replacement strip is pretty high.  What should I be looking for?  The section contains resistors, diodes, capacitors and an IC.  There has to be a bad trace in there somewhere.

Advice?

Thanks!
Paul King

Share this post


Link to post
Share on other sites

I have struggled with repairing ribbons myself.  My guess is the one that failed is near a bend or a flex point. Probably just a cracked solder, loose resistor, diode as you figured out.  When it is only one I have cheated by strategically securing it down with a zip tie/ tie wrap.  You might have to adjust how you mount the strip so you can get some support to secure it with a zip tie and it will lay flat. 

Share this post


Link to post
Share on other sites

For what they charge for the strip they should be repairing it for you. Make a call and see if that's an option. If no you can pursue other options. 

Share this post


Link to post
Share on other sites

They don't repair these, I checked.  They will sell you a replacement for $100.  The pixel out is Red on pixel #1.  I bought a replacement and I'll dig into this eventually.  I just haven't had the time since the snow melted :)

Thanks!
Paul

Share this post


Link to post
Share on other sites

That price is outrageous. Smart strips from most anybody else are a quarter of that price. Or they offer  you a discount. 

Edited by Ebuechner

Share this post


Link to post
Share on other sites

A bottle of (black) Nail Polish may be the least expensive solution for 1 Pixel :)

Share this post


Link to post
Share on other sites

Are you using the entire strip?  If not, adjust where the ribbon sits and make the first pixel a "null" pixel, then you won't see the flicker.  If you have some spare pixel ribbon, you can cut the first section at the cut mark and solder on a new section.

Share this post


Link to post
Share on other sites

Will they at least sell you a pixel section so you can repair the strip yourself?

I repaired many strips and it's not that hard if you have some experience with a soldering iron. 

Edited by Ebuechner

Share this post


Link to post
Share on other sites

I didn't ask.  Since my strip problem is intermittent, I figured the best thing to do would be to rip it a part and reflow the connections on that first pixel.  If that doesn't work, I'll see about a section.  I'm just not sure if it's worth the hassle.  It may be cheaper to use something else for that prop.

Share this post


Link to post
Share on other sites

Do you have a rework station? I've tried fixing sections with my rework station and I got mixed results. Now I just change out the bad section to end up with a solid repair. 

Share this post


Link to post
Share on other sites

I don't know what a rework station is.  If I had a section, I'd use it, but I don't have a section either.

Share this post


Link to post
Share on other sites

Rework or reflow stations are great to have. You can buy different heads to fit over different sized pcb chipsets or whatever your needs allowing you to heat and reflow the entire item at once.

I repaired many, many xbox and PlayStations in my days.

Good investiment.

JR

Share this post


Link to post
Share on other sites

No.  My solder station doesn't have all that on it.  I don't have the air gun, just the iron and digital setting for temp.

Share this post


Link to post
Share on other sites
1 hour ago, PKingRoch said:

No.  My solder station doesn't have all that on it.  I don't have the air gun, just the iron and digital setting for temp.

If you can afford it great investment. They also have the iron so it's an all in one system. They can go from around $50 to $1000 but the one pictured above is a good price. 

Mine is Aoyue.

Had it since 2006

JR

Edited by dibblejr

Share this post


Link to post
Share on other sites

Right now, I'll probably just keep the one I have. Concerning the repair, I only use 4 CCRs in my display.  I currently have 2 working spares, and the one flakey CCR at the first pixel.  I'll probably just keep the flakey one as a donor for any new problems and pull working segments off of it to help any future problem.

 

Thanks for all the help!!

Share this post


Link to post
Share on other sites

Well I may be able to help. I think I still have some bad ones and should be able to go through my inventory

to see if I can find one. How long of a section will you need?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×